[DIOS MIOS] Can't get my backup GC games working from USB.

Discussion in 'Wii - Emulation and Homebrew' started by HarlsHicks, Aug 9, 2013.

  1. HarlsHicks
    OP

    HarlsHicks Newbie

    Newcomer
    2
    1
    Aug 9, 2013
    United States
    I just want to play PSO!!!

    So I've tried just about everything. I was having issues with DIOS MIOS and launching games. I was getting the dreaded "Fatal error apploader size is zero!" I had DIOS MIOS 2.10 and USB Loader GX r1215 installed.

    Yesterday I decided to start from scratch and re-install all the cIOS's and updated IOS's as well using ModMii. They all installed properly. After that I installed DIOS MIOS (NOT lite) 2.10 on IOS 236 and USB Loader GX 3.0 r1215 through IOS 249.

    I have a Star Fox Adventures folder in "/games/Star Fox Adventures [GSAP01]" on my HDD. In the folder is the game.iso and the sys folder (I believe that contains the neek files?). I used gcit to extract the DiscEx. I also tried Star Wars Bounty Hunter by putting in it's folder and only the original iso renamed to "game.iso". Neither of these worked.

    They show up in USB Loader GX properly, but when I launch them, the DIOS MIOS screen comes up with this message:

    "a! al error app_entry is not within the apploader are"

    I noticed that the disc sounds like it spins when this happens, almost like it's looking for a disc. I tried putting a random disc, and it didn't help. Same message.

    I also don't have any settings changed in USB Loader GX except for the Main Gamecube Game Location. That's changed to the "USB1:/games/" location.

    And lastly, I have checked the drive, and it's FAT32 with a 32KB cluster size.

    So yeah. What next? Any ideas? I am open to ANYTHING at this point. Thanks in advance!

    UPDATE: Talked to Cyan in chat, and I'm going to try using the "Align 32KB" option in DMToolbox when I extract the game (Referencing this post: http://gbatemp.net/threads/wiiflow-gamecube-backup-loading-question.341006/). If that doesn't work, I'm going to try re-formatting the drive. I'll post results after I try. Thanks again Cyan and JDbye for helping me brainstorm!

    UPDATE (8/10/13): So after WAY too much testing, Cyan, FIX94 and I finally pinned it down to DIOS MIOS not liking my hard drive. After trying a new hard drive, it worked perfectly! Hopefully it will help someone else in the future!
     
    _acid_ likes this.