Different switch questions

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Enterchrishikari, Jul 31, 2019.

  1. Enterchrishikari
    OP

    Enterchrishikari Member

    Newcomer
    1
    Jul 21, 2019
    United States
    Hello everyone.

    So I’m just trying to get an understanding of all the different switches out there and how they’re able to be hacked.

    For example we have the day one consoles that can and always will be able to be hacked. So does that mean for these switches you don’t have to worry about the firmware you’re on? You could always update without a worry?

    Then we have the patched consoles. Can those only run CFW on 4.1? That means you can’t run anything that requires a higher firmware then that?

    Lastly we have those that are completely unhackable.

    Is that correct? Or am I missing something?

    Thank you.
     
  2. stephrk398

    stephrk398 GBAtemp Fan

    Member
    5
    May 29, 2018
    United States
    Currently all unpatched units can run CFW up to 8.1. It's recommended not to update immediately once a new update releases as it will likely break CFW. You then need to wait for CFW support on that FW version.

    Yes, but you can run Emunand up to 8.1 which will let you play the latest games.

    If you're brand new I'd highly recommend getting an unpatched unit.

    — Posts automatically merged - Please don't double post! —

    Any ipatched unit above 4.1. For now...
     
    Last edited by stephrk398, Jul 31, 2019
    Lacius likes this.
  3. Enterchrishikari
    OP

    Enterchrishikari Member

    Newcomer
    1
    Jul 21, 2019
    United States
    thanks for responding! I was a bit confused but I think I got it now
     
  4. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    Follow this guide for exploring your exploit options: https://switch.homebrew.guide/gettingstarted/choosinganexploit
    1. If your Switch is unpatched, it's forever hackable regardless of system version. However, as stated above, CFW like Atmosphere usually requires an update before it's compatible with a new system version, and you will usually have to wait a few days or more before you can use a new system version on an unpatched system. Atmosphere is currently compatible with all system versions (as of this post, 8.1.0 and lower).
    2. If your Switch is ipatched, it can only be hacked right now if it's on 4.1.0 and has never connected to the internet. Patched systems on 5.0.0-7.0.1 might be hackable in the distant future. Patched systems on 8.0.0 and higher might never be hackable.
     
Quick Reply
Draft saved Draft deleted
Loading...