Desperate with my Wii's SD

Discussion in 'Wii - Nintendo Wi-Fi Connection' started by joseluki, Aug 26, 2015.

  1. joseluki
    OP

    joseluki Newbie

    Newcomer
    7
    0
    Aug 26, 2015
    Hello, my Wii is on 4.3E.

    I have had this wii for 1 month, hacked it with letterbomb, and never had a problem, playing everyday emulators and nintendont GC games from SD without a problem.

    Till one day nintendont stopped recognizing the folder with the isos, and the emulators began to have problems recognizing folders and roms.

    HBC is able to read all the apps and launch them without problems, but the ones that need to write on the SD, cant (like homebrew browser, or the config files of nintendont or the emulators they just dont save the info, and they crashes when trying to create savestates).

    I am using a SDHC sony 8gb, but I tried with a Kingston 2gb normal SD, and had the same issue.

    I tried formatting both SDs, and no results.

    I think it must be some software issue, because if the SD reader would be damaged it couldnt be able to read from the SD (and never had a problem launching the apps).

    HELP PLEASE.
     
  2. _v3

    _v3 GBAtemp Advanced Fan

    Member
    540
    267
    Oct 12, 2013
    Croatia
    Umm, did you maybe lock your SD card???
    Check on the side of the SD card for a small white nub and push it upwards.
     
  3. joseluki
    OP

    joseluki Newbie

    Newcomer
    7
    0
    Aug 26, 2015
    No, is the first thing I tried. I can also write when I use the SDs in my laptop.
     
  4. gburgue

    gburgue GBAtemp Regular

    Member
    148
    18
    Nov 12, 2011
    Argentina
    Unfortunately I don't think it's a problem related to your cards or even the softmod. It sounds more like a problem with the Wii card reader. I have an old SD card adapter for PC that reads perfectly, but at writing on them corrupts the cards most of the time.
     
  5. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,974
    3,758
    Apr 2, 2011
    United States
    The Twilight Zone
    I was thinking the same thing.

    I suggest you try a different SD card and see if it works. If it doesn't, either use a USB adapter like this, or get a flash drive.
     
  6. joseluki
    OP

    joseluki Newbie

    Newcomer
    7
    0
    Aug 26, 2015
    I have tried with a normal SD and I've got the same issue, Wii HBC reads perfectly and loads the apps, but f.e. emulators are not able to savestates, and they dont recognize the folders where roms are placed.

    But did not have any problem loading any app, also apps that write a config file are unable to do so, or the ones that download things into the SD (but Uloader that is able to download the covers from the games).

    Launching Pimpmywii I discovered that I lacked of the d2x cIOS, and a few more, I updated with pimpmywii, but I still have the same problem.

    I am using now a USB device to do all the things that I used with the SD, but is a pain in the ass, because I do not know why, forwarder channels do not find my apps on the USB and it reset the console (yes, I placed the apps int the proper route).
     
  7. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,974
    3,758
    Apr 2, 2011
    United States
    The Twilight Zone
    Stay the f*ck away from BrickMyWii.

    Not all forwarders are USB compatible.
     
  8. Guinea

    Guinea .

    Member
    101
    23
    Sep 13, 2015
    United States
    ----
    It's problably the sd card reader that went bad