Desmume Wi-Fi under Linux

Discussion in 'NDS - Emulation and Homebrew' started by shawly, May 23, 2014.

  1. shawly
    OP

    shawly Member

    Newcomer
    46
    2
    May 23, 2014
    Gambia, The
    Hey Guys,

    so, since I can't use any fake GTS anymore to check my IV's I need a more unconventional way to get my pokemans into Pokegen.
    So I wanted to trade it with Desmume to my PC and edit the savegame to check it.
    Problem is, I changed my main OS to Arch Linux and I can't get it working...
    Compilation with --enable-wifi works without problems, when I start Desmume over the terminal it already says:

    Code:
    WIFI: SoftAP: using dbus-system as device.
    WIFI: SoftAP: PCap: failed to set non-blocking mode: F_GETFL: Illegal Filedescriptor
    
    The first line is probably just info, but the second one looks like a problem.
    Libpcap is installed.

    Desmume starts anyways, I load up the Wi-Fi settings and then I want to search for access points,
    that works too and I can see SoftAP, but when it gets to the test of the connection, it fails with errorcode 52000.
    In the terminal it says SoftAP connected, sends some packets and then the Wi-Fi icon turns red in desmume and in the terminal it says SoftAP disconnected and then the error 52000 appears.

    Since my windows vm isn't set up at the moment I can't use windows.

    Is this a problem with pcap, desmume or is it because I use dhcpcd to get a network connection?

    Any help would be appreciated..
     
    Hiccup likes this.
  2. master801

    master801 GBAtemp Fan

    Member
    352
    85
    Feb 24, 2011
    United States
    I know how you feel. :( I think you actually might have to dump/get the bios and firmware files yourself if you haven't done so. That's how I fixed it a long time ago for me...
     
  3. shawly
    OP

    shawly Member

    Newcomer
    46
    2
    May 23, 2014
    Gambia, The
    I got my old dumps! But where do I have to put them? 0.9.11 (the svn trunk) doesn't have any options anymore to select the firmware and bioses, I tried to edit the ~/.config/desmume/config.cfg and add the paths, but it doesn't seem to recognize them..
    Can you tell me where I have to put my dumps?
     
  4. TechZilla

    TechZilla Newbie

    Newcomer
    1
    0
    Jun 7, 2014
    United States
    I'm not convinced this is firmware related, It could be, but considering this is on Linux who knows what settings this thing actually requires. I'm also attempting to get my wifi working on the newest SVN, the build went as expected, and I got somewhat passed your part.

    Have you set your capabilities properly? PCAP requires elevated permissions beyond a normal usermode application.
    Read the error messages as root, do they differ? If so set your caps like this,

    setcap cap_net_raw,cap_net_admin=eip /usr/local/bin/desmume

    Please respond back too if you got anything working, I'm stuck at 52000 error during SoftAP test.... not sure how this gets an IP, or what must be configured on the OS level... Or which device pcap should even be using, my usually active eth1? an open bridge device br0 to the active eth1, manually assigned with an IP? A full DHCP proving softap0 ???? I can;t find that info anywhere online.

    Actually I've also just checked the code, and I cannot verify you can load the firmware.bin in any possible way on linux. Not from the command line, not from the inexcusably limited gtk launcher. Bios files, yes they can be loaded from command line options.... firmware.bin no way I've found thus far.
     
  5. dehavilland

    dehavilland Newbie

    Newcomer
    1
    0
    Nov 5, 2014
    United States
    Baltimore, Maryland
    Hi,

    To use firmware in linux requires a patch...see http://sourceforge.net/p/desmume/patches/166/

    However, I already chgrp to pcap, chmod 750 ,setcapped and using wired network, it still gives out 52100 error(both DHCP and manually)...

    Maybe it is broken...