Controller Emulation Working in Nintendont Menu but not In-Game

Discussion in 'Wii U - Emulation & CEMU' started by 08heat28md, Jul 12, 2017.

  1. 08heat28md
    OP

    08heat28md Member

    Newcomer
    23
    1
    Apr 19, 2017
    United States
    After designing my own controller.ini for my specific and uncommonly used brand of controller, I tested it out in HIDTest and a new set of data had appeared below the hex. This data told me the specific buttons I was pressing, and all of the buttons worked correctly and were mapped to the right controls. I then went to the Nintendont menu and the controller had worked there, too. I launched the game I wanted to play (Super Mario Sunshine) and waited for it to load. Once it got to the game's progressive prompt, I tried inputting the start button. That did not work, and neither did any of the other buttons. From what I've seen, if the controller works in the menu it should work in-game. Are there any settings I should turn on or off? My settings are in File_000.jpeg and my controller.ini is in the second one. Tell me if you notice anything wrong with it.

    TL;DR - Nintendont menu works with the controller, doesn't in-game.

    EDIT: Is this in the wrong category? I'm somewhat surprised I haven't gotten any replies yet. Or is it just an issue that is not frequent and no one knows how to fix? To expand on the issue, should I post a picture of my files themselves? And say that this was the wrong category, would I be able to repost this on the correct one?
     

    Attached Files:

    Last edited by 08heat28md, Jul 17, 2017