Hacking Classic NES Metroid.gba

3DPiper

Well-Known Member
OP
Member
Joined
Jun 13, 2004
Messages
414
Trophies
0
XP
824
Country
United States
For some reason, I can't get the Classic NES Metroid rom working..

I have tried many different versions, they always lock up the Supercard DSTwo AND the Supercard MiniSD..

Everything extracts OK..

Not sure what the problem is..

?
 

BORTZ

DO NOT SCREENSHOT
Supervisor
Joined
Dec 2, 2007
Messages
13,222
Trophies
3
Age
33
Location
Pittsburgh
XP
15,470
Country
United States
The NES classics are bitchy games.

No honestly theres a good chance you wont be able to get it to work. For some reason the NES classics are released with different programming than that of the rest of the GBA library. I dont know if there is a way to get them to act normally. You have a better chance getting the original NES ROM and emulating that instead.
 

Rockhoundhigh

Man with a mission
Member
Joined
Apr 2, 2011
Messages
477
Trophies
0
Age
27
Location
Southern California
XP
702
Country
United States
Yeah, general consensus, they're programming nightmares like the Golden Sun games except here you have the better alternative of just using the nes versions with a different emulator (nesDS).
 

3DPiper

Well-Known Member
OP
Member
Joined
Jun 13, 2004
Messages
414
Trophies
0
XP
824
Country
United States
Thanks!

at least I know I'm not crazy..

It doesn't even work on visualboy emulator (it says ROM ERROR)..
 

Neodemon

Member
Newcomer
Joined
Sep 15, 2011
Messages
12
Trophies
0
XP
74
Country
United States
Ahhh after a lot of confusion I understand now. Sorry to possibly confuse you more.

I did test it out, and however I patch the game it just wont run on the Supercard MiniSD.
Better yet, when I tested it on my DSi SC DSTWO It crashed the bottom screen and kicked me into the NDS loader. :wacko:
 

DanTheManMS

aka Ricochet Otter
Member
Joined
Jun 2, 2007
Messages
4,449
Trophies
1
Age
32
Location
Georgia
XP
714
Country
United States
There are patches you can try using at http://gbatemp.net/topic/63195-ips-patches-for-classic-nes-series/

But really, you'd be much better off emulating the NES rom with either NES DS or PocketNES to begin with
 

Xarsah16

GBATemp's Official Village Dingus/Idiot
Member
Joined
Oct 6, 2007
Messages
722
Trophies
0
Age
32
Location
Hyrule
XP
430
Country
Is NESDS compatible with the SuperCard DSTWO? I don't see why it wouldn't be, as I have it working on my Acekard2i. If it's classic Metroid you want to play, I'd suggest getting around it by trying to emulate the classic NES games in their original NES rom form. To put it simply, using .nes files on your card instead of .gba files.

I love Metroid like many others, and it runs perfectly fine on the NESDS NES emulator. http://www.zophar.net/consoles/nds/nes/nesds.html :)
 

OrGoN3

Well-Known Member
Member
Joined
Apr 23, 2007
Messages
3,186
Trophies
1
XP
2,798
Country
United States
Is NESDS compatible with the SuperCard DSTWO? I don't see why it wouldn't be, as I have it working on my Acekard2i. If it's classic Metroid you want to play, I'd suggest getting around it by trying to emulate the classic NES games in their original NES rom form. To put it simply, using .nes files on your card instead of .gba files.

I love Metroid like many others, and it runs perfectly fine on the NESDS NES emulator. http://www.zophar.ne.../nes/nesds.html :)

The DSTwo natively supports NES roms. Just load up moonshell, go to the rom, and hit enter! Done. No need for NESDS with the SCDSTwo. Alternatively, you could use NESDS, it'll work.
 

Xarsah16

GBATemp's Official Village Dingus/Idiot
Member
Joined
Oct 6, 2007
Messages
722
Trophies
0
Age
32
Location
Hyrule
XP
430
Country
Well in that case, even better. Just using a different kind of rom, i.e. the NES roms in this case might actually work better. :)
 

Terminator02

ヽ( 。 ヮ゚)ノ
Member
Joined
Apr 10, 2010
Messages
4,516
Trophies
0
Location
Somewhere near monkat
XP
1,026
Country
United States
Is NESDS compatible with the SuperCard DSTWO? I don't see why it wouldn't be, as I have it working on my Acekard2i. If it's classic Metroid you want to play, I'd suggest getting around it by trying to emulate the classic NES games in their original NES rom form. To put it simply, using .nes files on your card instead of .gba files.

I love Metroid like many others, and it runs perfectly fine on the NESDS NES emulator. http://www.zophar.ne.../nes/nesds.html :)

The DSTwo natively supports NES roms. Just load up moonshell, go to the rom, and hit enter! Done. No need for NESDS with the SCDSTwo. Alternatively, you could use NESDS, it'll work.
This is news to me, I'll have to try this out.
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
  • M4x1mumReZ @ M4x1mumReZ:
    @Sonic Angel Knight, Bet it made him high as a kite
    +1
  • sombrerosonic @ sombrerosonic:
    got midi to run on VLC
    +2
  • AncientBoi @ AncientBoi:
    ♫ We al live in a Flex Seal Submarine A Flex Seal Submarine, a flex seal submarine ♫
    +1
  • K3N1 @ K3N1:
    Looks like Eagles Wii be in Superbowl this year
    +1
  • AncientBoi @ AncientBoi:
    [sends Washington after them]
  • sombrerosonic @ sombrerosonic:
    girls kiss other girls and nobody bats an eye, BUT WHENI KISS MY HOMIES GOODNIGHT IM NOW GAY
    +1
  • sombrerosonic @ sombrerosonic:
    double standers

    are a bitch
    +2
  • C @ ch13696:
    Did you make sure to have socks on before kissing them goodnight?
  • sombrerosonic @ sombrerosonic:
    The Core i9 seems like a nice CPU
  • sombrerosonic @ sombrerosonic:
    need 32 gigs for Blender and shit like that
  • sombrerosonic @ sombrerosonic:
    also dual wielding 580's are pretty nice for several games and blender
  • sombrerosonic @ sombrerosonic:
    Hi Catboy
    +1
  • The Catboy @ The Catboy:
    Hey hey~
  • K3N1 @ K3N1:
    Jesus super bowl tickets are like 5 grand this year
  • gudenau @ gudenau:
    Imagine if they didn't sell.
  • K3N1 @ K3N1:
    Who would pay Rhianna then
  • D @ Danali:
    hi, does someone know how to get the kernel update? for NDS
  • FAST6191 @ FAST6191:
    There is no kernel update for DS
  • FAST6191 @ FAST6191:
    There might be kernel updates for various DS flash carts
  • captainbob321 @ captainbob321:
    what is a kernel update? and what is it for?
  • FAST6191 @ FAST6191:
    In which case find either the website or suitable download section and hopefully it is there
  • FAST6191 @ FAST6191:
    *website for the flash cart in question
    FAST6191 @ FAST6191: *website for the flash cart in question