CIOS222 and CIOS223 error!

Discussion in 'Wii - Backup Loaders' started by jadog, Apr 1, 2010.

Apr 1, 2010

CIOS222 and CIOS223 error! by jadog at 2:20 AM (5,184 Views / 0 Likes) 19 replies

  1. jadog
    OP

    Newcomer jadog Member

    Joined:
    Mar 27, 2010
    Messages:
    41
    Country:
    United States
    I followed the CompleteSoftmodGuide to a 'T' and yet I still seem to be having this problem. I backed up a game using CFG USBLoader on my FAT32 formatted hard drive. When I try to load a game, I get the following error:

    "Error: CIOS222 and CIOS223 required for starting games from a FAT partition!"
    Set_frags -128
    Error: Set WBFS: -128

    I have already installed both of those already though. Also, using USB Loader GX fails as well. What am I doing wrong?
     
  2. smf

    Member smf GBAtemp Advanced Fan

    Joined:
    Feb 23, 2009
    Messages:
    839
    Country:
    United Kingdom
    what version did you install? what options did you use?
     
  3. jadog
    OP

    Newcomer jadog Member

    Joined:
    Mar 27, 2010
    Messages:
    41
    Country:
    United States
    I followed the instructions from here: http://sites.google.com/site/completesg/cios/hermes-cios.

    Below are the steps I used:

    1. Downloaded the cIOS222/223 installer and extracted it to the apps folder on the SD card/USB device
    (First I tried the newer version 5, but when it didn't work with the usb loaders, I went back and did it again with version 4)

    2. Ran the cIOS222/223 Installer with the HBC. Used IOS249 when it asked.
    *Selected cIOS222. In the new menu, I chose 38 merged 37. Let it install, and exit.

    3. Ran the cIOS222/223 Installer and again and used IOS249.
    * This time I selected cIOS223. In the menu, chose 38. Let it install and exit.

    4. Ran the installer again. Used IOS249.
    * Now I chose IOS202. Then chose 38 merged 60. Let it install and exit.
     
  4. jadog
    OP

    Newcomer jadog Member

    Joined:
    Mar 27, 2010
    Messages:
    41
    Country:
    United States
    I just figured out that Hermes v5 doesn't work with USB loaders using the FAT32 format [​IMG]. How do I uninstall v5 and go back to Hermes v4???
     
  5. jadog
    OP

    Newcomer jadog Member

    Joined:
    Mar 27, 2010
    Messages:
    41
    Country:
    United States
    I tried just running the v4 installer again, but it didn't make any difference. Does anybody know how to help me?
     
  6. Bitnick

    Newcomer Bitnick Newbie

    Joined:
    Apr 1, 2010
    Messages:
    1
    Country:
    United States
    quote me if im wrong but, I think you delete IOS222 with any title deleter. But i'd just wait until someone intelligent comes along and helps you. Or you can look around the site some more
     
  7. DGenerateKane

    Member DGenerateKane GBAtemp Fan

    Joined:
    Jul 18, 2009
    Messages:
    330
    Country:
    United States
    Did you set the game to load ios 222 or 223? Most loaders default to 249. What version of CFG are you running? 56 or 56-222? You should be running 56-222.
     
  8. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,127
    Location:
    Belgium
    Country:
    Belgium
    That's true, but not needed*. The 222/223 v4 installer will automatically overwrite any IOS currently in the slot, no matter whether it's a higher or lower version number. [​IMG]

    I +1 on DGenerateKane's post, but I'm a bit unsure. It would seems to me that the error message would be different (jadog...you still get that same message after installing v4, right?). [​IMG]
    Oh, and also: the more recent versions of CFG support v5 of IOS222/223. To my knowledge, it's only the music games that still require v4 (with a merge of 38/37**).


    Just in case this doesn't work...can you download and install Dop-mii, please? It'll allow you to see which versions of the cIOS 222 and 223 you have. It may shed some light on your situation as well. [​IMG]
    (note: it could be that anytitledeleter also supports this feature. I'm not sure about it, though).




    *I downgraded from v5 to v4 myself some time ago. Now that CFG fully supports v5
    **that is, if you absolutely want to use Hermes's IOS for that. rev19 with a base of 37 is IMO a better choice.
     
  9. DMC

    Newcomer DMC Advanced Member

    Joined:
    Jun 15, 2009
    Messages:
    75
    Country:
    Venezuela
    Sorry to Hijack but I have a similar problem using Hermes V5 and V5 when loading video from MPlayer/Mplayer CE via USB.
    I followed Jagdog's instructions listed as well but still cannot get it to run.

    I have run it several times for V4 AND 5 and using the USB installer seperaetly under IOS 249.

    Anyone think there's a link here as similar CIOS/IOSs are being used and both aren't working?
    I use the CFG USB loader for backups under mload v228 (I think) so its not an issue.

    Any help appreciated.
     
  10. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,127
    Location:
    Belgium
    Country:
    Belgium
    *confused* Are you saying you get an error saying cIOS222 and 223 are missing when using MPlayerCE?

    If so, that's very strange, because to my knowledge, MPlayerCE doesn't use Hermes's IOS'es to begin with. Yes...it uses IOS202. But as Hermes wasn't the first one to use these numbers, and games only use the cIOS you tell them to use (which is usually 222 or 223...I never heard of a 228 cIOS, and I doubt it's even selectable as a cIOS to be used in CFG).
    Perhaps this link'll help you out, DMC.
     
  11. jadog
    OP

    Newcomer jadog Member

    Joined:
    Mar 27, 2010
    Messages:
    41
    Country:
    United States
    Ok guys, you all are right. I should have my Wii taken away for a mistake as stupid as this [​IMG]. I ran Dop-Mii and I have v4 of Hermes. The problem was that while using v.56 of CFG USBLoader, I forgot to set the IOS from 249 to 222 before starting the game. Does it ever make a difference if I use 222 or 223?

    Also, is v4 of Hermes still preferred over v5? I never actually got to try it since it was only trying to use IOS 249.

    Thanks for your help (and patience) you guys! Still learning...
     
  12. shuntu

    Newcomer shuntu Newbie

    Joined:
    Jan 4, 2010
    Messages:
    2
    Location:
    canada
    Country:
    United States
    Hi everyone, I'm have the same error as jadog.

    This all started when i tried a beta of cfg, before i tried beta, everything was wonderful. now all my games ios are set to 249, and i have to change them to 222

    i figured if i revert back to old version it would be ok.

    i downloaded: http://cfg-loader.googlecode.com/files/Cfg_USB_Loader_56.zip
    latest full release, but i'm still experience the same issue.

    i realize i can just set ios to 222 before i play my games, but before i tried the beta, it was defaulted fine, and i could just boot my games without any option altering.

    hardmodded d2c
    softmodded 4.1U

    i recently did a friend of mine, and I used the same "http://cfg-loader.googlecode.com/files/Cfg_USB_Loader_56.zip" pack to put on his SD card, and his works fine.

    Thanks for reading & your time

    Take care
     
  13. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,127
    Location:
    Belgium
    Country:
    Belgium
    Shuntu...you should realise that there are two versions of each CFG release. A 'normal' one, and a '-222' one (formerly called '-FAT'). From what you're telling, it looks like you tried out the -222 one in beta, and upgraded to the normal one in release.
    The solution is simple: just download and use the -222 version. [​IMG]

    @jadog: it's okay. We all make mistakes. [​IMG]
    The difference between 222 and 223 is only in which merges you use. The IOS38/IOS37 merge (which you installed on ios222) is needed to play music games correctly.

    Version 5 doesn't do with the merges anymore. That makes things less complicated to install, but alas...under CFG, you can't get those music games working. A such, you can choose to keep v4, or install Waninkoko's rev19 with a base ios of 37.
    v5 of Hermes's ios'es are needed if you want to use uLoader to play wiiware from emulated NAND, but that's outside the scope of CFG. [​IMG]
     
  14. jadog
    OP

    Newcomer jadog Member

    Joined:
    Mar 27, 2010
    Messages:
    41
    Country:
    United States
    Ok, thanks, that makes sense. Then I'll probably just stick with v4. So what's the difference between IOS 56 and IOS 56-222? Which should I use?
     
  15. Dr. Clipper

    Member Dr. Clipper GBAtemp Addict

    Joined:
    Aug 28, 2007
    Messages:
    2,487
    Country:
    Australia
    It's not an IOS, it's Cfg's version number. Every release of Cfg comes as two .dols. They have subtle differences, but in most cases, either of them can be used to do anything (although some drives will only work with one or the other due to compatibility reasons).

    The differences of Cfg versions X and X-222 where X is the version number are:

    1: X will load IOS249 as the first thing it does while X-222 will load IOS222 (this is before config.txt is read).
    2: The default value of the "ios" option for X is "249" and for X-222 is "222-mload" (you can change the value with config.txt).
    3: The default value of the "partition" option for X is "wbfs1" and for X-222 is "fat1" (you can change the value with settings.cfg or config.txt).
     
  16. shuntu

    Newcomer shuntu Newbie

    Joined:
    Jan 4, 2010
    Messages:
    2
    Location:
    canada
    Country:
    United States
    solved! :

    Dr. Clipper in another post states:
    "That error means you are trying to use IOS249 to run the games and that the revision is less than 18. Do any of the following to fix it:

    1. Use the -222 version of the loader which defaults all games to 222 (as long as you don't have "ios=249" in config.txt.
    2. Set "ios=222-mload" in config.txt which defaults all games to 222.
    3. Change the ios option for every game to use IOS222 (this is tedious and not recommended).
    4. Install rev 19 of IOS249."

    i installed rev19 an its perfect [​IMG]

    kudos to him
    thx to everyone else that helped
     
  17. jadog
    OP

    Newcomer jadog Member

    Joined:
    Mar 27, 2010
    Messages:
    41
    Country:
    United States
    Thanks shuntu. Glad you got it working. What loader are you using and how many games have you tested?

    It's noted in the CompleteSoftmodGuide, to wait and not use version 19 of Waninkokos cIOS. I jumped the gun and installed Hermes v5 a little too soon and had to go back and re-install the previous version. I just don't want to make the same mistake again.
     
  18. jadog
    OP

    Newcomer jadog Member

    Joined:
    Mar 27, 2010
    Messages:
    41
    Country:
    United States
    Anybody else have any thoughts on v19 of Waninkoko's cIOS?
     
  19. OGTiago

    Member OGTiago GBAtemp Regular

    Joined:
    Nov 21, 2006
    Messages:
    244
    Location:
    London, England Rank: Temp God
    Country:
    Portugal
    Awesome, thanks! That solved the problem for me.

    When you go to load the game press 1 for options, set it to 222 (mine was on 249). It should load fine after that.
     
  20. Riley

    Member Riley GBAtemp Maniac

    Joined:
    Mar 9, 2009
    Messages:
    1,123
    Location:
    BC Canada
    Country:
    Canada
    Install cIOS249

    IOS249 - base 38 / 57 ( it matters if you need this IOS to install wads )
    IOS250 - base 37

    To do this install as base 37 first then dump IOS250 with Bluedump then boot the ciosx installer and install the base you want for IOS249. Then open your fav wad manager and install the IOS250 wad.
     

Share This Page