Cheats remaining in effect after disabling them?

Discussion in 'Supercard' started by SgtShaeffer, Apr 3, 2014.

  1. SgtShaeffer
    OP

    SgtShaeffer Newbie

    Newcomer
    4
    0
    Sep 6, 2012
    United States
    Hello all!

    I've been a proud owner of my DSTWO for roughly two years now, however, I've always had a problem with cheats.

    Specifically, many of them don't seem to turn off, one type in particular being in RPGs with random encounters... Whenever I use a cheat to force a specific monster, if I then save the game, the monster I forced will forever be the only monster I can fight.

    Cheats that apply multipliers, such as to EXP/Gold are also prone to sticking---Thankfully, the DSTWO's cheats.dat typically comes with everything between x2-x512, so if I go for some higher number, I can set it to x2 later and return to a sense of semi-normalcy.... But still.

    So, after having fubarred my 40hr save of Dragon Quest 5, here I am asking if anyone has any idea how I could fix this.

    Things I have tried:

    • Disable the specific cheat and make a new save state, before resetting and loading the new save state.
    • After doing the above, load the new state and do the same again, but using ingame saves.
    • Disable cheats altogether, and then do the above two steps again, starting from in game saves and save states once each
    • running the game clean---this, however, disables the dstwo menu---and by extension sav states---and when I load the ingame save it (somewhat predictably, i might add) hangs at a black screen
    Any help whatsoever would be appreciated ^^



    Also, while I'm posting I might as well ask about some minor slowdown/framerate dips i've been having. They are mostly minor, but they are quite a nuisance. Games like Rune Factory 3 slow down greatly when I have more than 3 or 4 townspeople on screen at once, and it instantly stops when someone walks off screen, while Dragon Quest 4 has had some of the same issues when too many things are displayed at once---i.e. one village early on has ~8 townspeople outside an inn, which stutters a bit when loading but stops shortly after, running smoothly even when changing camera angles.

    I'm using a class 10 32gb samsung microSD card, so it shouldn't be that unless it's either defective or badly fragmented... Except I've formatted it once or twice before hoping to fix the problem but to no avail. I've been unable to try another card as I don't have a second one available, nor do I have another flash cart available to test the SD on there. I also feel I must mention that about a year back I bought a third party battery pack for my 3DS that covers the entire back, though I quickly switched to using my regular DS instead once I remembered there was a secondary CPU on the cart xD At that point in time, however, despite it going through a marathon test of the battery's life it hadn't yet developed the frame rate issue.

    Thanks again in advance!
     
  2. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    6,640
    4,361
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    the post is too long and i didn't read everything, did you tried to disable the cheat, then reseting the game, without using save states? if you use a save state you make a copy of the entire game memory, so if you forced a cheat before, probably it will continue to run until you reset the game

    i dont own yet a dstwo, but this is based on emulators experience.. however if the game doesnt have saves, it can be problematic..
     
  3. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,204
    8,969
    Nov 21, 2005
    As migles said if you are using savestates rather than normal in game saves it will tend to stick as you have edited memory that does not normally get edited/reset.

    We can go into methods by which you can fix things but most should be solved by saving in the game and loading it back up properly.

    If you must carry on with savestates then you get to reimplement the normal things. Fortunately by their very nature the cheats will have the exact addresses that would have been changed, the cheats themselves describe what they change said locations to ( http://gamehacking.org/wiki/Hacking_Game_Boy_Advance ) which may be enough to reverse it and if not then load up a normal game and look at those addresses before copying that into a cheat.
     
    migles likes this.
  4. SgtShaeffer
    OP

    SgtShaeffer Newbie

    Newcomer
    4
    0
    Sep 6, 2012
    United States
    *Facedesk* Apparently I never went directly through the in game menu with cheats wholly disabled... Well, that solves that one. Thanks!