Homebrew CFW and Pokemon Bank: Update required but there isn't one

Ar7ific1al

Well-Known Member
OP
Member
Joined
Jul 12, 2009
Messages
134
Trophies
1
XP
324
Country
United States
I've tried Google and the search function on the forum already and have not come across any instance of this so I'm making a thread to ask.

I'm on O3DS, 9.2 SysNand, 11.0.0-33U EmuNand with rxtools (the old one from lavanoid).
Of course, my questions pertain to the EmuNand of the above specification.

Everything else seems to work fine: I can go online in my games (digital and retail copies), I can use the browser and eShop*, I just did the Mystery Gift on my Pokemon games to get Shaymin.
But I can't use Pokemon Bank. For some reason, whenever it tries to connect to the server, it tells me I need to update my system in order to use the service. But my EmuNand is updated - it's on 11.0.0-33U. Just for the hell of it, I tried "updating" and it told me there was an error and then my 3DS rebooted.

What gives? Anyone else experience this?

*EDIT: My eShop apparently does not work. It too tells me there is a system update (Which there is not) and to update in order to use it. :/
 
Last edited by Ar7ific1al,

CeeDee

fuckin dork
Member
Joined
May 4, 2014
Messages
5,361
Trophies
3
XP
9,955
Country
United States
I've tried Google and the search function on the forum already and have not come across any instance of this so I'm making a thread to ask.

I'm on O3DS, 9.2 SysNand, 11.0.0-33U EmuNand with rxtools (the old one from lavanoid).
Of course, my questions pertain to the EmuNand of the above specification.

Everything else seems to work fine: I can go online in my games (digital and retail copies), I can use the browser and eShop, I just did the Mystery Gift on my Pokemon games to get Shaymin.
But I can't use Pokemon Bank. For some reason, whenever it tries to connect to the server, it tells me I need to update my system in order to use the service. But my EmuNand is updated - it's on 11.0.0-33U. Just for the hell of it, I tried "updating" and it told me there was an error and then my 3DS rebooted.

What gives? Anyone else experience this?
IIRC it's a known issue. Update to a newer CFW that patches the issue, like Luma3DS.
 

SimplyFedorable

Evangelion Geek
Member
Joined
Apr 7, 2016
Messages
575
Trophies
0
Location
melee hell
XP
511
Country
United States
try using this. Its a free homebrew alternative to pokebank and is much more powerful than the original pokebank. If you have any pokemans on your pokebank as of right now, I don't know the answer. Try switching to luma3ds which you can get here. Just copy all the files from the regular release, not the dev version or the source code to the root of your sd card, and get the file from the menuhax folder that comes with luma put that in the root of your sd card too. Rxtools is very outdated and that mayy be your issue

--------------------- MERGED ---------------------------

just install the cia for PHBank
 

Ar7ific1al

Well-Known Member
OP
Member
Joined
Jul 12, 2009
Messages
134
Trophies
1
XP
324
Country
United States
IIRC it's a known issue. Update to a newer CFW that patches the issue, like Luma3DS.
Where have you read such? I was unable to find anything about it. :/
Thanks, though. I do have Luma3DS as well, but it won't boot; it was working fine last I tried it several weeks ago and nothing at all has changed. lol But someone on the Luma3DS thread (saw it while trying to find something else) said theirs wouldn't boot with a game in the slot so I'll try that. :P

try using this. Its a free homebrew alternative to pokebank and is much more powerful than the original pokebank. If you have any pokemans on your pokebank as of right now, I don't know the answer. Try switching to luma3ds which you can get here. Just copy all the files from the regular release, not the dev version or the source code to the root of your sd card, and get the file from the menuhax folder that comes with luma put that in the root of your sd card too. Rxtools is very outdated and that mayy be your issue
Thanks, but no thanks; I already have it. I don't want to use it. I want to use the actual Pokemon Bank. :P I didn't ask for suggestions for replacements but thanks anyway.
 

CeeDee

fuckin dork
Member
Joined
May 4, 2014
Messages
5,361
Trophies
3
XP
9,955
Country
United States
Where have you read such? I was unable to find anything about it. :/
Thanks, though. I do have Luma3DS as well, but it won't boot; it was working fine last I tried it several weeks ago and nothing at all has changed. lol But someone on the Luma3DS thread (saw it while trying to find something else) said theirs wouldn't boot with a game in the slot so I'll try that. :P
How are you launching it? It works fine for me with a DS flashcart in.
The same error happened to an older build of Luma3DS, which would make sense - rxtools hasn't been updated in a while so that couldn't have been fixed.
 

SimplyFedorable

Evangelion Geek
Member
Joined
Apr 7, 2016
Messages
575
Trophies
0
Location
melee hell
XP
511
Country
United States
Where have you read such? I was unable to find anything about it. :/
Thanks, though. I do have Luma3DS as well, but it won't boot; it was working fine last I tried it several weeks ago and nothing at all has changed. lol But someone on the Luma3DS thread (saw it while trying to find something else) said theirs wouldn't boot with a game in the slot so I'll try that. :P


Thanks, but no thanks; I already have it. I don't want to use it. I want to use the actual Pokemon Bank. :P I didn't ask for suggestions for replacements but thanks anyway.
PHBank is a lot safer than pokebank, as it dons't interfere with cfw. As a general rule, if you are on cfw, its generally better to use usermade tools, as they tend to be safer and have safe guards against anything bad happening
 

Ar7ific1al

Well-Known Member
OP
Member
Joined
Jul 12, 2009
Messages
134
Trophies
1
XP
324
Country
United States
How are you launching it? It works fine for me with a DS flashcart in.
The same error happened to an older build of Luma3DS, which would make sense - rxtools hasn't been updated in a while so that couldn't have been fixed.
Launching Luma3DS the same way I launch RxTools: using ctrbootmanager. I've added an entry to point to sd:/luma/menuhax/boot.3dsx. Like I said, it worked a few weeks ago and nothing has changed.
Only difference between rxtools launch and luma launch is my rxtools entry points to sd:/rxtools/sys/code.bin instead of a 3dsx.

PHBank is a lot safer than pokebank, as it dons't interfere with cfw. As a general rule, if you are on cfw, its generally better to use usermade tools, as they tend to be safer and have safe guards against anything bad happening
Again, thanks but no thanks; I do not wish to use this. I am not asking for suggestions or replacements for Pokemon Bank, I am asking for assistance in getting Pokemon Bank working.
 
Last edited by Ar7ific1al,

Xenon Hacks

Well-Known Member
Member
Joined
Nov 13, 2014
Messages
7,414
Trophies
1
Age
30
XP
4,687
Country
United States
PHBank is a lot safer than pokebank, as it dons't interfere with cfw. As a general rule, if you are on cfw, its generally better to use usermade tools, as they tend to be safer and have safe guards against anything bad happening
Pokemon bank is better to you because it can be used as a personal hack checker.
 

Ar7ific1al

Well-Known Member
OP
Member
Joined
Jul 12, 2009
Messages
134
Trophies
1
XP
324
Country
United States
How are you launching it? It works fine for me with a DS flashcart in.
The same error happened to an older build of Luma3DS, which would make sense - rxtools hasn't been updated in a while so that couldn't have been fixed.
Got Luma3DS to boot; had to remove the config.bin, I guess something was wrong with it.
But no beans. Still, Pokemon Bank tells me I need to update my system to use the service.
I'm using the latest Luma3DS (non-dev build), 5.5, released on May 27. That was the latest version when I first acquired Luma3DS, as well.
 

EmuAGR

Well-Known Member
Member
Joined
Jan 11, 2016
Messages
205
Trophies
0
Age
31
XP
246
Country
Update Luma to nightly using StarUpdater. The latest Luma build is obsolete. I don't understand why Aurora hasn't updated the "known to be buggy" stable release yet. :mellow:
 
  • Like
Reactions: Ar7ific1al

Ar7ific1al

Well-Known Member
OP
Member
Joined
Jul 12, 2009
Messages
134
Trophies
1
XP
324
Country
United States
Update Luma to nightly using StarUpdater. The latest Luma build is obsolete. I don't understand why Aurora hasn't updated the "known to be buggy" stable release yet. :mellow:
Thanks, I'll try that. :)

Doesn't seem to do anything. I'm not using A9LH to launch Luma3DS; I have an autoboot menuhax and CtrBootManager.
CtrBootManager is set to point to SD:/luma/menuhax/boot.3dsx for Luma3DS.
If I open StarUpdater (installed via CIA), change mode to menuhax, and tell it update unstable, it says...
File downloaded!
Backing up payload
Moving to payload location...
Done!

Reboot and still no eShop or Pokemon Bank.
Where does it download the file, do you know? I don't know if I'm using a non-default path for Luma's boot file. Luma's install instructions just say to put the files for your entrypoint on the SD card, then put the correct folder (menuhax in my case) in SD:/luma/. Maybe there's something I've done wrong? I'm not dense, I can read, and I've done what is instructed, but I guess I could still have done something wrong.
So where does it download the updated file(s) and where should I be putting them if I need to move them? :/

EDIT: Found something else somewhere and I've changed my ctrbootmanager to boot from Luma3DS.dat instead (and manually downloaded the latest nightly). Still not able to use Pokemon Bank...
 
Last edited by Ar7ific1al,

jagerstaffel

Well-Known Member
Member
Joined
Aug 20, 2008
Messages
533
Trophies
0
XP
312
Country
United States
Hm, it shouldn't be your browser that's the problem, right? Seeing as how your emunand is up to date, unless you recently did change your browser, but if the eshop doesn't work as well, I think something in the firmware is out of date.
 
  • Like
Reactions: Ar7ific1al

Ar7ific1al

Well-Known Member
OP
Member
Joined
Jul 12, 2009
Messages
134
Trophies
1
XP
324
Country
United States
Hm, it shouldn't be your browser that's the problem, right? Seeing as how your emunand is up to date, unless you recently did change your browser, but if the eshop doesn't work as well, I think something in the firmware is out of date.
You just gave me an idea: I was screwing around with twlfirm trying to get my old ass R4 to work. I came to the conclusion that it's impossible for my original R4 to work with twlfirm patches.
I'll try and reinstall a normal twlfirm if I can. Thanks for the idea!

--------------------- MERGED ---------------------------


Reinstalling legit AGB_FIRM and TWL_FIRM didn't solve anything...
I made a NAND backup on June 6 (haven't done anything to EmuNAND since then besides TWL_FIRM crap) so I'll try injecting that. :)

--------------------- MERGED ---------------------------

@jagerstaffel YAAAAASS Thank you so much for jogging my memory! I love emunandtool. xD I make an emunand backup anytime I screw with it like messing with twl_firm and agb_firm. :) Thanks again. <3
 
  • Like
Reactions: jagerstaffel

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    SylverReZ @ SylverReZ: 3D printing with chocolate. :D