1. JimPlayz912

    OP JimPlayz912 A.K.A. UltraGamer912
    Member

    Joined:
    Jun 9, 2018
    Messages:
    398
    Country:
    Greece
    The game runs perfectly when playing by myself, but when I hit the multiplayer modes...
    mariokart8glitch.png

    ...yeah, it's horrible.
    Now, this may be happening because I'm running this on Intel UHD graphics 630, but idk.

    SPECS:
    -Intel core i3 10100 3.60ghz (up to 4ghz)
    -Intel UHD graphics 630
    -8GB ram
    -250gb SSD
     
  2. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08
    Member

    Joined:
    Mar 17, 2010
    Messages:
    20,644
    Country:
    Norway
    Try switching between OpenGL and Vulkan.
     
  3. JimPlayz912

    OP JimPlayz912 A.K.A. UltraGamer912
    Member

    Joined:
    Jun 9, 2018
    Messages:
    398
    Country:
    Greece
  4. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08
    Member

    Joined:
    Mar 17, 2010
    Messages:
    20,644
    Country:
    Norway
    That's normal. Look for pre-made shader packs for the games you want to play, otherwise you will have a lot of lag/stuttering/microfreezes on the first "play through" as it needs to compile every shader and there's thousands scattered across the entire game.
     
  5. Laf111

    Laf111 Advanced Member
    Newcomer

    Joined:
    Mar 19, 2019
    Messages:
    58
    Country:
    France
    Intel GPU: Limited support. Vulkan is recommended

    (From CEMU main page)
     
  6. JimPlayz912

    OP JimPlayz912 A.K.A. UltraGamer912
    Member

    Joined:
    Jun 9, 2018
    Messages:
    398
    Country:
    Greece
    Hmm, now that I think about it, I remember enabling something called "shared libraries" and THAT gave me some slowdowns. Maybe now that I have it disabled... something will happen? IDK, I will try it out (But I still have no idea why some gamecube games have image freezes when running in vulkan in dolphin)

    Update: STILL FREEZES
    I really have no idea why Vulkan doesnt work in most games.
    Like, in dolphin (specifically mario sunshine, mario kart and wii play) vulkan works perfectly.
    But the rest, either the picture gets frozen, or the entire game

    — Posts automatically merged - Please don't double post! —

    I actually tried it, got the pre-compiled shaders, and nope, still didn't fix the freeze
    Note: it freezes right here when playing on vulkan:
    DAMNIT.png

    P.S. I gave up at this point. Now im stuck with a nice, slooow "copiling shaders" screen for the rest of the day.
     
    Last edited by JimPlayz912, Jan 31, 2021
  7. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08
    Member

    Joined:
    Mar 17, 2010
    Messages:
    20,644
    Country:
    Norway
    You need the right type of shaders. The newer type that is universal (it still needs to be compiled a final time for your specific GPU, but you can simply set it to pre-compile all of those before starting the game in the settings)
    The older type was GPU specific, Cemu version specific, and generally had to be completely rebuilt any time you changed anything.
    You can tell by the folder name which type it is, but anyway, I would just look for the most recently uploaded pack you can find.
    If you set it to precompile the shaders (only works if you are using a shader pack with "intermediate" shaders like mentioned and does nothing for shaders that haven't been extracted from the game yet or need to be updated because of some changes in Cemu or in a game update) then before the game starting up you'll get a loading bar with Compiling shaders xxxx/xxxxx and it will take a few minutes the first time, but should be fast after that. Precompiling them this way saves the emulator having to do it when they're first loaded and pausing the emulation every time.
     
    Last edited by The Real Jdbye, Jan 31, 2021
  8. JimPlayz912

    OP JimPlayz912 A.K.A. UltraGamer912
    Member

    Joined:
    Jun 9, 2018
    Messages:
    398
    Country:
    Greece
    Thanks a lot, but now I gave up. I'll just wait till I get an actual gpu, instead of hanging around with intel uhd 630 (literally)
    But regardless, thanks for your help!
     
  9. JimPlayz912

    OP JimPlayz912 A.K.A. UltraGamer912
    Member

    Joined:
    Jun 9, 2018
    Messages:
    398
    Country:
    Greece
    Welp, tried it, what do you know, still doesnt work.
     
  10. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08
    Member

    Joined:
    Mar 17, 2010
    Messages:
    20,644
    Country:
    Norway
    Well, because you are using Intel graphics, the shader compilation might just be that slow, even the few shaders that will need recompiling once loaded in the game (there are always some, the shader packs aren't perfect or completely up to date) will slow everything down to a crawl. Don't think you can do much about it, it's just a rather demanding system to emulate.
     
  11. JimPlayz912

    OP JimPlayz912 A.K.A. UltraGamer912
    Member

    Joined:
    Jun 9, 2018
    Messages:
    398
    Country:
    Greece
    OK, I'll just wait until I get a gtx 1650 or something. Thanks for the help though!
     
  12. sviru

    sviru Newbie
    Newcomer

    Joined:
    Feb 28, 2021
    Messages:
    2
    Country:
    Poland
    I play MK8 all the time split screen 60fps. ZERO visual glitches. Not ever. I play ona NVIDA Vulkan, async, 4K + Visual Mods.

    Every game I play works so much better on VULKAN. YUZU is the same. OPENGL stutters so much. Not playable for me.
     
    Last edited by sviru, Feb 28, 2021
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - SplitScreen, glitches, [CEMU]