Can't play The Third Birthday on my PSP (retail version).

Discussion in 'PSP - Hacking & Homebrew' started by RedHero, Sep 13, 2011.

  1. RedHero
    OP

    Member RedHero GBAtemp Regular

    Joined:
    Dec 27, 2008
    Messages:
    208
    Country:
    Netherlands
    Well, I saw the CE version of the game for cheap and decided to buy it. Sure, my PSP may be modded, but I still buy retail games. But to my surprise... the PSP couldn't play it. It gave me an error. After some researching I found out that I have to update it to the final version to play it (which frankly, is just BS).

    Of course, I'm not willing to unmod it for just a single game. And I would rather not use a patched ISO (which I would have to download first). I bought it and I want to play it from that disc. Problem is that I Googled and pretty much every site I encountered just said to use a patched ISO -__-

    So here I come to you. Might you guys perhaps have the magic solution that I'm looking for? Do you guys know of a way for me to play my game?
     
  2. prowler

    Member prowler Sony

    Joined:
    Jul 14, 2009
    Messages:
    9,473
    Location:
    Ragol
    Country:
    United Kingdom
    Either update to one of the latest PRO firmwares (6.39 or something) or rip the ISO and patch it yourself.
     
  3. DarkShinigami

    Member DarkShinigami #1 strongest Shinigami BANKAI

    Joined:
    Sep 12, 2009
    Messages:
    1,836
    Location:
    Soul Society
    Country:
    United States
    prowler the latest pro is actually 6.60
     
  4. prowler

    Member prowler Sony

    Joined:
    Jul 14, 2009
    Messages:
    9,473
    Location:
    Ragol
    Country:
    United Kingdom
    I know.
     
  5. DarkShinigami

    Member DarkShinigami #1 strongest Shinigami BANKAI

    Joined:
    Sep 12, 2009
    Messages:
    1,836
    Location:
    Soul Society
    Country:
    United States
    ok didn't know that you knew.
     
  6. nl255

    Member nl255 GBAtemp Advanced Maniac

    Joined:
    Apr 9, 2004
    Messages:
    1,998
    Country:
    Even the latest 6.20 Pro should work as it has all the newer keys. If it doesn't then you should submit a bug report that UMD games that require higher than 6.20 are not working.
     
  7. DarkShinigami

    Member DarkShinigami #1 strongest Shinigami BANKAI

    Joined:
    Sep 12, 2009
    Messages:
    1,836
    Location:
    Soul Society
    Country:
    United States
    he could be on a cfw prior to 6.20. if ur firmware is prior update. thats all i gotta say
     
  8. RedHero
    OP

    Member RedHero GBAtemp Regular

    Joined:
    Dec 27, 2008
    Messages:
    208
    Country:
    Netherlands
    Ah, this worked. Thanks a lot [​IMG]
     

Share This Page