Can't load USB loader cfg from Preloader 3.0

Discussion in 'Wii - Backup Loaders' started by JaapDraad, Nov 2, 2009.

Nov 2, 2009
  1. JaapDraad
    OP

    Newcomer JaapDraad Member

    Joined:
    Jan 2, 2009
    Messages:
    33
    Location:
    Netherlands
    Country:
    Netherlands
    I'm trying to make USB-loader config to boot directly from powering on my Wii

    I have bootmii as boot2, phpgeek's preloader 3.0 rev 4, USBloader config v46.
    I am using Narolez' forwarder dol for preloader from USBLoaderCFG_NForwarder. I also installed the forwarder channel from that package
    I am on system menu 4.1E with cios rev 14 and hermes installed.

    When I press (1) in the preloader load/install file screen, USB-loader loads nicely.
    However if I press A to installed it and then go back to the preloader main menu and load the installed file I get a blackscreen with Exception (DSI) occured etc.
    When I set preloader to autoboot to the installed file, I don't get the eror message, but a black screen instead.

    Any idea's?
     
  2. biarritz

    Newcomer biarritz Newbie

    Joined:
    Dec 16, 2009
    Messages:
    1
    Country:
    Netherlands
    Jaap Draad,

    Saw your message, which is exacty my problem. Did you find a solution yet?

    Thanks
     
  3. jhoff80

    Member jhoff80 GBAtemp Advanced Fan

    Joined:
    Jan 23, 2006
    Messages:
    806
    Country:
    United States
    Same issue here using priiloader v0.2 r30 instead of preloader.

    Also, if I autoboot directly to the cfg50_fat.dol, it appears to load fine at first, but it has graphical issues when it loads the theme.
     
  4. wiiuser2

    Member wiiuser2 GBAtemp Regular

    Joined:
    Sep 12, 2009
    Messages:
    181
    Country:
    Netherlands
    Preloader 0.30 has issues autobooting the CFG USB loader (bug in preloader I think).
    The only way to get this working currently without issues is downgrading to preloader 0.29 (as I did myself).

    BTW: 0.29 is much more stable anyway then 0.30 and above versions
     
  5. giantpune

    Member giantpune GBAtemp Addict

    Joined:
    Apr 10, 2009
    Messages:
    2,860
    Country:
    United States
    just grab a forwarder that is compiled to work with preloader and that loader. you need to take into account the size and entryoint of each app (preloader, the forwarder, and the USB loader). i know preloader 0.30 and all variations of it use 0x81000000. i made a forwarder for GX that uses 0x8000d000 and it goes fine with all the newer preloader variations. you will just need to see where CFG loader starts and then do some subtracting to find a spot in memory that is big enough for a forwarder and doesnt intersect with either app.
     
  6. jhoff80

    Member jhoff80 GBAtemp Advanced Fan

    Joined:
    Jan 23, 2006
    Messages:
    806
    Country:
    United States
    The forwarder IS compiled to work with Preloader and CFG loader.


    Anyway I hope the forwarder gets updated for .30 / Priiloader, because I'd prefer to not need to patch my IOS70.
     

Share This Page