Hacking Can't Install NSP "Invalid PFS0 Magic!"

Jungle_Jon

Well-Known Member
OP
Member
Joined
Dec 26, 2015
Messages
114
Trophies
0
Age
31
XP
203
Country
This seemed to all happen after updating to 9.0.1 via ChoiDujourNX .
I have the latest version of atmosphere (forked version from hbg) and have the latest beta version of sxos, I also have the latest version of tinfoil (the bundled one and directly from their site), mercury and SX installed 3.0.
Every time i try and install a nsp (either locally or via USB) i get the following error in the console / log;
Could not open nsp
Invalid PFS0 Magic!

I boot from r4s, I have the correct time and date set, im currently using backing up my SD card, so that i can reformat back to fat32.

One reddit post said to install "sigpatches" but im sure sx os came already patched?

I am out of ideas, what could cause this ?
 
Last edited by Jungle_Jon,

MegaGab

New Member
Newbie
Joined
Nov 21, 2019
Messages
1
Trophies
0
Age
42
XP
26
Country
Canada
Hi Jungle_Jon, have you found a solution to this problem?
I have the exact same issue, and I can't find any solution.
 
Last edited by MegaGab,

dawgslayer69

Member
Newcomer
Joined
Mar 3, 2017
Messages
7
Trophies
0
Age
54
XP
81
Country
United States
For me, the cause has something to to with the WerWolv's overlay utility. I turned it off by renaming `switch/.overlays` to anything else. Then rebooted. And magically tinfoil stopped complaining.
 
  • Like
Reactions: RobvonBothmer
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: https://youtube.com/shorts/3jVZMEPLAfE?feature=share