Hacking Question Can't boot in OFW except when using Hekate

Autrui

Member
OP
Newcomer
Joined
Aug 17, 2015
Messages
18
Trophies
0
Age
26
XP
69
Country
France
Hello,

I followed this guide in order to migrate my emuMMC on a bigger sdcard.

I'm not sure what went wrong, but I can't boot my Switch normally on OFW. Nothing happens, no light, just a pitch black screen. AutoRCM is disabled. I can enter RCM and send a payload, and when I'm in Hekate, I can boot the OFW from there, everything seems to be working fine.

I don't really understand what is happening and I'm looking for an explanation of what went wrong and how to fix this.

Can you help ? Thanks ! :)

Edit :

Problem solved doing a MMC repair following this guide.
 
Last edited by Autrui,

Basketto

Well-Known Member
Member
Joined
Jun 25, 2019
Messages
557
Trophies
0
Age
31
XP
588
Country
Australia
The only reason i can think ofw firmware would boot from hekate and not normally is a fuse mismatch.
Try holding power down for 20 seconds and reboot. Have you ever restored an old nand backup?
 

Autrui

Member
OP
Newcomer
Joined
Aug 17, 2015
Messages
18
Trophies
0
Age
26
XP
69
Country
France
No I didn't restore NAND backup !

The OFW version is up to date to 10.2.0, and Hekate says I have 13 - 0 burnt fuses.

emuMMC version is 9.2.0|AMS 0.14.4|E

AutoRCM is OFF.

I can't boot my SysCFW either. I posted the error on github and received this anwer from SciresM :

A partial update was improperly performed.

To fix, try manually flashing latest package2 to MMC.

Can you help ?
 
Last edited by Autrui,

Autrui

Member
OP
Newcomer
Joined
Aug 17, 2015
Messages
18
Trophies
0
Age
26
XP
69
Country
France
I did a MMC repair following this guide. All went well, I can access my OFW booting normally and from Hekate, I can access my sysCFW and my emuCFW. Problem solved !
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: I would Photoshop movie stars kissing donkey balls lol