Can i update my 3ds??

Discussion in '3DS - Flashcards & Custom Firmwares' started by neto333, Aug 2, 2017.

  1. neto333
    OP

    neto333 Advanced Member

    Newcomer
    52
    2
    Jun 9, 2011
    Mexico
    Hi, i hacked my 3ds almost a year ago, and i havent played since then, now that i want to play there is an update but i dont know if is safe to update so i dont loose my hacks. Im on Sys 11.2.0-35U on a new 3DS XL. The apps that i currently have are: FBI, Luma Updater, CHMM and some other apps.
     
  2. Catsinabucket

    Catsinabucket GBAtemp Regular

    Member
    106
    46
    Aug 18, 2015
    United Kingdom
    Assuming you're using A9LH, you should update to Boot9Strap using 3ds.guide, as A9LH is now outdated. There is a section there for updating to Boot9Strap from A9LH. Once you've installed that and made sure your CFW is up to date, you should be safe to update your system
     
    neto333 likes this.
  3. neto333
    OP

    neto333 Advanced Member

    Newcomer
    52
    2
    Jun 9, 2011
    Mexico
    just to be sure, how do i know that im using A9LH? also this is the guide https://3ds.guide/a9lh-to-b9s?
     
  4. Catsinabucket

    Catsinabucket GBAtemp Regular

    Member
    106
    46
    Aug 18, 2015
    United Kingdom
    Yep, that's the right guide :) and I think you can find out by going to /luma/payloads/ on your SD card and seeing if the arm9loaderhax.bin is there
     
    neto333 likes this.
  5. Lacius

    Lacius GBAtemp Guru

    Member
    6,123
    2,450
    May 11, 2008
    United States
    If you're using Luma3DS, it's safe to update to 11.5.

    As @Catsinabucket already said, it's also highly recommended that you update to B9S if you haven't already done so.
     
    neto333 likes this.
  6. neto333
    OP

    neto333 Advanced Member

    Newcomer
    52
    2
    Jun 9, 2011
    Mexico
    Thank you very much. One last question, do i loose my game saves by doing this?
     
  7. Lacius

    Lacius GBAtemp Guru

    Member
    6,123
    2,450
    May 11, 2008
    United States
    You will not lose your games or save files if you update to B9S and 11.5.
     
    neto333 likes this.
  8. neto333
    OP

    neto333 Advanced Member

    Newcomer
    52
    2
    Jun 9, 2011
    Mexico
    Hi, thank you very much. I followed the guide and i think is done, i mean, i didnt got any error and i was able to launch GodMode9, so now i can just update luma and then update my firmware or first update my firmware and then luma? also Is normal that i have 2 luma updater apps (the previus one and the new one that i just installed)?
     
  9. Catsinabucket

    Catsinabucket GBAtemp Regular

    Member
    106
    46
    Aug 18, 2015
    United Kingdom
    I updated Luma before updating my 3DS firmware and it worked fine :) And yes I think that is normal (well, it was the case with me at least). I just deleted both cias and re-installed the new one through FBI
     
    neto333 likes this.
  10. naddel81

    naddel81 GBAtemp Advanced Maniac

    Member
    1,502
    186
    Dec 14, 2009
    United States
    Is updating to b9s required? Or does a9lh still work?
     
  11. hurrz

    hurrz GBAtemp Regular

    Member
    197
    74
    Apr 17, 2017
    Gambia, The
    A9LH does still work. You don't HAVE to update but it is recommended to go with B9S because Luma is not supporting A9LH anymore. Therefore A9LH is called outdated.

    If you try to update Luma on A9LH, your device will no longer boot because of the need to update to B9S. So if you want to stay with A9LH, make sure you don't update Luma.

    If you did (for example by accident), you can still follow the guide (link was mentioned in this thread) to update A9LH to B9S.

    It is your choice though! :-)
     
    Quantumcat and naddel81 like this.
  12. Lacius

    Lacius GBAtemp Guru

    Member
    6,123
    2,450
    May 11, 2008
    United States
    Most people make sure they're using the latest version of Luma3DS, and then they update to the latest 3DS system version. Since you just updated to B9S, you are likely already using Luma3DS 8.1, which is the latest version of Luma3DS. With regard to your two Luma Updater apps, the older one is useless and can be deleted.

    If you want newer versions of Luma3DS, then the update to B9S is required. If you are fine using Luma3DS 7.0.5 forever, then you can stay on A9LH. The update to 11.5 works just fine on Luma3DS 7.0.5 and A9LH.
     
    naddel81 likes this.
  13. naddel81

    naddel81 GBAtemp Advanced Maniac

    Member
    1,502
    186
    Dec 14, 2009
    United States
    same goes for emunand and menuhax, right? I can just update from 11.2 emunand to 11.5 emunand with my menuhax + luma setup on the other machine?
     
  14. Lacius

    Lacius GBAtemp Guru

    Member
    6,123
    2,450
    May 11, 2008
    United States
    You can, yes. You should make sure you are using the latest version of Luma3DS that menuhax supports, which is 7.0.5.

    When it comes to menuhax, however, I highly recommend you switch to B9S. If your sysNAND accidentally gets updated, you will lose access to CFW. With B9S, you don't have that risk.
     
    Quantumcat likes this.