broken cyclo ds?

Discussion in 'CycloDS' started by discostew, Dec 16, 2008.

  1. discostew
    OP

    discostew Member

    Newcomer
    29
    0
    Mar 11, 2008
    Canada
    well firt of all when I launch evolution it stops at like 99% of the loading. When I remove the card from the cyclo ds it says there's no micro sd card in it. I tried formating my sd card but it doesn't want to, some file in it doesn't want to delete. I delete all the stuff that is deletable but when I remove it from my card reader all the cards are back.

    Is my cyclo ds broken or my sd card?

    if you need more info, please let me know.
     
  2. DeMoN

    DeMoN GBAtemp Guru

    Member
    7,649
    100
    May 12, 2004
    United States
  3. discostew
    OP

    discostew Member

    Newcomer
    29
    0
    Mar 11, 2008
    Canada
  4. Tanas

    Tanas GBAtemp Addict

    Member
    2,258
    25
    Aug 19, 2006
    If its saying that your sd is write protected then your sd is physically damaged. I've had two 4GB ADATA's die in my CycloDS in the last two months.
     
  5. Rayder

    Rayder Mostly lurking lately....

    Former Staff
    6,613
    130
    Jan 14, 2007
    United States
    USA
    If you have one of those full size translators to put your microSD in to make it like a full-size SD, then put your microSD in it and there SHOULD be a switch on the translator to enable/disable write protection.

    It sounds like you accidently set write protection to ON.

    See if that works for you.
     
  6. discostew
    OP

    discostew Member

    Newcomer
    29
    0
    Mar 11, 2008
    Canada

    oh alright thanks a lot, I guess I'll have to buy a new one


    Bought a new one and now it works! thanks a lot