Borked spring loader

Discussion in 'Acekard' started by Stavros90, Jul 8, 2009.

  1. Stavros90
    OP

    Stavros90 Member

    Newcomer
    21
    0
    Jun 9, 2009
    United States
    So I decided to buy two acekards about a month ago and at least one has been great. The other one not so great. I was hoping if anyone knows if it is possible to fix or temp fix that I can do myself while I wait to get another. It's a black PCB acekard 2.1 and the spring loader won't "click" when the microsd card is put in. I opened it up but I can't see what's broken.
     
  2. Another World

    Another World Emulate the Planet!

    Former Staff
    10,487
    1,598
    Jan 3, 2008
    Colombia
    From Where???
    one of my 2.1s had a spring issue. i simply pushed in the msd as hard as i could and the spring popped back to life.

    duno if that will help you.

    -another world
     
  3. Stavros90
    OP

    Stavros90 Member

    Newcomer
    21
    0
    Jun 9, 2009
    United States
    Heh well that kinda worked. It seems I can get the card stuck partially beneath the plastic but it shoots out if pressure the plastic. I think I'll use it like this for now and put some tape over it so I don't lose the card.
     
  4. Another World

    Another World Emulate the Planet!

    Former Staff
    10,487
    1,598
    Jan 3, 2008
    Colombia
    From Where???
    keep trying to force the spring a few times. your acekard has a 1yr warranty. you can contact your retailer for a replacement. if the retailer needs proof check acekard.com in the news section. they clearly stated this.

    -another world
     
  5. wrettcaughn

    wrettcaughn Misunderstood Moral Elitist

    Member
    3,785
    863
    Mar 14, 2009
    United States
    Mine came with a broken spring and rather than go through returning it and waiting for another I just opened it up and fixed it. When you open it up there is a small metal lever inside the spring loader to the left. If you work it a little bit to the right with a pin you can put it back into place. Just make sure it is working before you put it all back together.

    The one year warranty is nice but I'm too impatient and would hate to return it and possibly receive another broken one. Plus, now I know how to fix it if it goes bad again.
     
  6. Stavros90
    OP

    Stavros90 Member

    Newcomer
    21
    0
    Jun 9, 2009
    United States
    I saw that lever Oldboy and I thought about pushing it but I wasn't completely sure. When you say push it to the left how should I be holding it. With the contacts facing towards or away from you?
     
  7. wrettcaughn

    wrettcaughn Misunderstood Moral Elitist

    Member
    3,785
    863
    Mar 14, 2009
    United States
    I had to push mine a little towards the center of the SD sleeve. You might have to play around with it until you find the right spot. Or like Another World said, you could look into your warranty.
     
  8. Stavros90
    OP

    Stavros90 Member

    Newcomer
    21
    0
    Jun 9, 2009
    United States
    Oldboy I love you. I had to mess with it for 5 minutes until it finally worked. Thing is I put in a support ticket to dealextreme (where I bought it) for a return but now... I guess I'll keep it for now. Did your spring loader ever stop working again? Once again thank you.
     
  9. wrettcaughn

    wrettcaughn Misunderstood Moral Elitist

    Member
    3,785
    863
    Mar 14, 2009
    United States
    I've had mine for about 4 months and the spring loader hasn't broken yet (since the first time I mean). I contacted leetmod as soon as it arrived to me but fixed it about ten minutes later. I told leetmod that I fixed it and not to worry about it. They sent me an email about a week later asking how I fixed it [​IMG]
     
  10. Jakob95

    Jakob95 I am the Avatar

    Suspended
    4,344
    66
    Jan 15, 2009
    United States
    New York City
    Thats what happened to me Lol. I fixed it the same way and it broke the first day I got it.
     
  11. TheDestroyer

    TheDestroyer GBAtemp's Official Keyblade Masterâ„¢

    Member
    587
    1
    May 5, 2009
    United States
    My Destroyed Village
    I just tried this just now and it worked! thanks! I too had an issue about this spring thingy it finally worked xD thanks!