Hacking BootNTR 11.1 NFIRM Support

Status
Not open for further replies.

Dracari

Well-Known Member
OP
Member
Joined
Apr 5, 2009
Messages
1,968
Trophies
0
XP
2,222
Country
United States
BootNTR has been updated for full 11.1 support, including new NFIRM support. Get it here: https://github.com/astronautlevel2/BootNTR/releases

  • Home menu support added by astronautlevel
    NFIRM support added by Aurora Wright and TuxSH

    this is Now Boot NTR11.1 Support as Native 1.1NFirm support was reached awhile ago, Boot NTR selector posts help requests should be in a New Topic or the selector thread, Offtopic posts will be reported.
  • This isnt even Support for Mode 3 builds, only for the original build by @astronautlevel a request to Lock topic has been Made since people cant behave.
 
Last edited by Dracari,

astronautlevel

Well-Known Member
Member
Joined
Jan 26, 2016
Messages
4,127
Trophies
0
Location
Maryland
Website
ataber.pw
XP
4,964
Country
United States
This should work on all consoles and regions, but it requires the developer version of luma and the firmware.bin from the luma3ds wiki (Hint: the link to the archive is somewhere on the "Installation and Upgrade" page.)

If it doesn't, post the pidf.dmp here :)
 
Last edited by astronautlevel,
  • Like
Reactions: AyanamiRei

Dracari

Well-Known Member
OP
Member
Joined
Apr 5, 2009
Messages
1,968
Trophies
0
XP
2,222
Country
United States
This should work on all consoles and regions, but it requires the developer version of luma and the firmware.bin from the luma3ds wiki (Hint: the link to the archive is somewhere on the "Installation and Upgrade" page.)

If it doesn't, post the pidf.dmp here :)
updated first post to reflect this :3
 

annson24

The Patient One
Member
Joined
May 5, 2016
Messages
1,189
Trophies
0
Age
30
XP
1,732
Country
Philippines
This should work on all consoles and regions, but it requires the developer version of luma and the firmware.bin from the luma3ds wiki (Hint: the link to the archive is somewhere on the "Installation and Upgrade" page.)

If it doesn't, post the pidf.dmp here :)
So the one from the wiki is the latest 11.0 firmware.bin? Coz I'm a little confused, because the guide said 3.x-4.x nands but looking at the file it says it has been uploaded like a week ago.

Sent from my SM-N930F using Tapatalk
 

astronautlevel

Well-Known Member
Member
Joined
Jan 26, 2016
Messages
4,127
Trophies
0
Location
Maryland
Website
ataber.pw
XP
4,964
Country
United States
So the one from the wiki is the latest 11.0 firmware.bin? Coz I'm a little confused, because the guide said 3.x-4.x nands but looking at the file it says it has been uploaded like a week ago.

Sent from my SM-N930F using Tapatalk
Yeah, you use a modern firmware.bin to launch old NANDs. I know it's a bit confusing :P

Cool. Now if someone made BootNTR Selector compatible, too.
If they want to add it, sure. Here's a link to the source: https://github.com/astronautlevel2/BootNTR/
 
  • Like
Reactions: annson24

Dracari

Well-Known Member
OP
Member
Joined
Apr 5, 2009
Messages
1,968
Trophies
0
XP
2,222
Country
United States
So the one from the wiki is the latest 11.0 firmware.bin? Coz I'm a little confused, because the guide said 3.x-4.x nands but looking at the file it says it has been uploaded like a week ago.

Sent from my SM-N930F using Tapatalk
considering 11.1 Just came out late lastnight yep. just use that or if you havent updated yet, dump your own via Decrypt9
 

nl255

Well-Known Member
Member
Joined
Apr 9, 2004
Messages
2,984
Trophies
0
XP
2,520
Country
I know almost nothing about ROP, so I can't really help with that :P

Well if it works the way I think it does, then updating the ROP payload will probably be more complicated. Am I correct in thinking that fixing BootNTR is more or less "just" a matter of finding the correct memory offsets and updating BootNTR to use them, much in the same way a gameshark/game genie code would be updated to work with a v1.1 or v1.2 ROM?
 

astronautlevel

Well-Known Member
Member
Joined
Jan 26, 2016
Messages
4,127
Trophies
0
Location
Maryland
Website
ataber.pw
XP
4,964
Country
United States
Well if it works the way I think it does, then updating the ROP payload will probably be more complicated. Am I correct in thinking that fixing BootNTR is more or less "just" a matter of finding the correct memory offsets and updating BootNTR to use them, much in the same way a gameshark/game genie code would be updated to work with a v1.1 or v1.2 ROM?
Kind of, you can take a decrypted k11 binary from 11.0 and 11.1 and look at what data was at the 11.0 offsets and find the corresponding data in the 11.1 binary.

The only issue is the dbgKernelCacheInterface offsets, which seems to have offsets that are out of range of k11. They're probably other k11 objects in axiwram that aren't in the main binary, and some reversing work is required to find the offsets for those.
 
Status
Not open for further replies.
General chit-chat
Help Users
  • No one is chatting at the moment.
    APEX PREDATOR @ APEX PREDATOR: does anyone have a cia of phonix wright trials and tribulation im trying to get it on my 3ds but...