Block Punch Out!! (NTSC-U) Update?

Discussion in 'Wii - Hacking' started by gokuguy, Jul 17, 2009.

Jul 17, 2009
  1. gokuguy
    OP

    Member gokuguy GBAtemp Fan

    Joined:
    Dec 5, 2008
    Messages:
    403
    Country:
    United States
    I just soft-modded my wii 3 days ago, so im a noob. Sorry for noob question.

    I just installed the Bannerbomb hack for 4.0U, nintendo install, & I have wad installs working from wad manager, games working on backup launcher gamma, ect.
    The only thing that bugs me now, is that whenever I try to play my burned "Punch Out!!", it bugs me to update. I tried preloader to block it, in which it does, but then says error has occured on disc. Tried BrickBlocker to remove update, same thing. The game plays fine through gamma backup, but it would be nice to fix this, so I can use it through the disc channel, like other games.

    Is it safe to install the update from the disc, or the official disc (in which I do have), & still have wad installs, homebrew channel, ect. working?
     
  2. wrettcaughn

    Member wrettcaughn Misunderstood Moral Elitist

    Joined:
    Mar 14, 2009
    Messages:
    3,785
    Country:
    United States
    Do a search for which IOS the Punch Out!! update installs and then install it manually via WAD Manager.
     
  3. WiiCrazy

    Member WiiCrazy Be water my friend!

    Joined:
    May 8, 2008
    Messages:
    2,391
    Location:
    Istanbul
    Country:
    Turkey
    If you did the 4.0 update using nintendo update then there is no harm in doing an update from disc if you are sure it's the same region as your wii...

    Update from the disc will be minor, possibly only one or two ios'es that are not in NUS (Nintendo update service) will get installed...

    You can also use newest version of gecko os to install that missing ios...
     
  4. wrettcaughn

    Member wrettcaughn Misunderstood Moral Elitist

    Joined:
    Mar 14, 2009
    Messages:
    3,785
    Country:
    United States
    If you have Trucha-bugged any IOS you will have to re-Trucha them after the update as it will overwrite them with fixed versions.
     
  5. gokuguy
    OP

    Member gokuguy GBAtemp Fan

    Joined:
    Dec 5, 2008
    Messages:
    403
    Country:
    United States
    As I said, i wouldnt know where to find it. I know what those are, I know what they do, but I cant find any individual IOS that Punch Out! installs. When I was searching through many posts, I found that someone ripped the ios updates from the Punch Out disc, to see what is actually updated, & there are many updated IOS' in the list. I have checked them myself, to see if i got the same ios' ripped when using the homebrew firmware ripper for discs as he did (forgot what its called, its a 4 letter name, that stands for something), & I got the same IOS' ripped, so im assuming they are correct. Ive found a good few people that said they said they used the disc update, & it didnt effect anything, but I wanna make sure. If the answer is yes, do i need to turn of WiiConnect24?

    *EDIT* I dont even know what "Trucha Bugged" is, so apparently not. I have not used Waninkoko's updates either. I used Bannerbomb on a "virgin" wii with 4.0U. Yes, the punch out is the same region.
     
  6. WiiCrazy

    Member WiiCrazy Be water my friend!

    Joined:
    May 8, 2008
    Messages:
    2,391
    Location:
    Istanbul
    Country:
    Turkey
    You can safely update from that disc...
    Installing wads obtained from the disc using wad manager is a bad idea unless you know what to install. In the past people bricked their wiis updating their 3.2/3.3 wiis with the IOS 30 they got from game discs that contained 3.4 update...
     
  7. gokuguy
    OP

    Member gokuguy GBAtemp Fan

    Joined:
    Dec 5, 2008
    Messages:
    403
    Country:
    United States
    Ok, thank you. Even though i have dealt with a modded wii for 3 days, Ive read a lot. One thing I did learn is what you said, about installing wads from the disc. I wasnt going to use them, I was ripping them so if i did need to patch certain ones then update, I would have them. Thanks again. Ill try it out, & place the result back here, to help others that have the same question.
     
  8. wrettcaughn

    Member wrettcaughn Misunderstood Moral Elitist

    Joined:
    Mar 14, 2009
    Messages:
    3,785
    Country:
    United States
    I found this after about 30 seconds of searching...

    "Just have Preloader installed with skip disc update check hack enabled.

    On top of that, install these IOSes too:
    1)IOS37
    2)IOS38
    3)IOS53
    4)IOS55 "

    You can run NUS Downloader on your PC to download these IOS. Or you can just update via the disc but I'm not sure what kind of effect it might have on WiiWare/VC wads if you have any installed since I don't use them.
     
  9. gokuguy
    OP

    Member gokuguy GBAtemp Fan

    Joined:
    Dec 5, 2008
    Messages:
    403
    Country:
    United States
    I put all of my Wiiware/VC games on SD. I might have to reinstall for tickets, but oh well.

    *EDIT*
    now that i think about it, if i have any troubles, I have preloader & bannerbomb. Ill just reinstall stuff if so.... (I think i heard that from somewhere else....) Ill try NUS Downloader first, it seems easier & safer. If that doesnt help, ill do the disc update.

    *EDIT2*
    Changed my mind, im gonna try disc...
     
  10. gokuguy
    OP

    Member gokuguy GBAtemp Fan

    Joined:
    Dec 5, 2008
    Messages:
    403
    Country:
    United States
    Did a disc update. Update did not effect anything. Tried wad installs, they work. Disc skips update now, but still has error when starting it from disc channel. Could someone tell me what the best & newest backup loader is?
     
  11. wrettcaughn

    Member wrettcaughn Misunderstood Moral Elitist

    Joined:
    Mar 14, 2009
    Messages:
    3,785
    Country:
    United States
    NeoGamma would be your best bet for a backup disc loader.

    Are you able to launch other backups from your regular disc channel? Do you have cIOSCORP installed?

    And what is the error you're getting? If it's a 002 error than using NeoGamma will fix your problem. If it is a "check your manual" error than you are probably trying to boot a backup from the disc channel without cIOSCORP installed (which I wouldn't recommend installing).
     
  12. gokuguy
    OP

    Member gokuguy GBAtemp Fan

    Joined:
    Dec 5, 2008
    Messages:
    403
    Country:
    United States
    2nd one sounds correct. Im using a gamma version of wiigator's backup launcher. I have no other backups yet... But it sounds like the cIOSCORP problem. How can i fix it without installing that?
     
  13. gokuguy
    OP

    Member gokuguy GBAtemp Fan

    Joined:
    Dec 5, 2008
    Messages:
    403
    Country:
    United States
    2nd one sounds correct. Im using a gamma version of wiigator's backup launcher. I have no other backups yet... But it sounds like the cIOSCORP problem. How can i fix it without installing that?
     
  14. wrettcaughn

    Member wrettcaughn Misunderstood Moral Elitist

    Joined:
    Mar 14, 2009
    Messages:
    3,785
    Country:
    United States
    You can't fix it without installing cIOSCORP. Just stick to booting with WiiPower's NeoGamma. He updates it regularly and it has all of the fixes you need.
     

Share This Page