Black Screen Atmosphere

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by jeverden, Nov 19, 2018.

  1. jeverden
    OP

    jeverden Newbie

    Newcomer
    1
    Nov 19, 2018
    United States
    On firmware 5.01 I think? I booted up hekate_ctcaer_4.2.bin and was able to get auto rcm installed.

    I attempted to boot into atmosphere and I get a black screen. I'm unable to shut down the switch by holding the power button or power button and volume buttion (I presume it's running at it's not making any usb connected sounds). Tergra says waiting for device in RCM mode. I'm not sure if I have to wait for the battery to die now very or what is going on. A little back story atmosphere did this the other time I tried booting into but it finally crashed and restarted the system and I had to use the jig to get it back into auto rcm. Now nothing works I'm stuck with a black screen (I haven't added the jig back since before I setup auto rcm so I know I didn't do anything to any pins). Super confused I'm guessing atmosphere is running in the background with no way to shut it down. Any thoughts besides letting the battery run back down?
     
  2. jeverden
    OP

    jeverden Newbie

    Newcomer
    1
    Nov 19, 2018
    United States
    Wow wondering if it isn't toast. Doesnt even seem like it's on or anything. Hooking it up via USB doesn't do anything. I have a full boot and nand backup but if it just stays at a black screen there is no way for me to restore. I've been on the Mod bandwagon since the wii and never ran into anything this scary.

    — Posts automatically merged - Please don't double post! —

    USB came unplugged. I still can't get atmosphere to boot though. Does it not work on 5.01?
     
  3. jeverden
    OP

    jeverden Newbie

    Newcomer
    1
    Nov 19, 2018
    United States
    I'm back in this scenario again. Could it possibly be because I don't have the sd card formatted fat32 but instead exfat and the drivers are missing for exfat support? I'm a bit lost I can hear the usb device connect on the computer but it never becomes available to inject the payload (almost like cfw is running in background but is a black screen).
     
  4. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    19
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Is the driver installed correctly? Check device manager.
    ExFAT shouldn't affect CFW's ability to boot, it just won't read the SD inside the OS if it's lacking the update. Anyway, ExFAT isn't really recommended as it corrupts far too frequently on the Switch, so it would be better to format the card to FAT32.
     
  5. mdmachine

    mdmachine GBAtemp Regular

    Member
    4
    Jun 15, 2009
    United States
    I had this happen to me while setting up a switch. I re-formatted the SD card (Fat32) on my macbook computer, I made some updates adding retroarch and etc... Happened again, reformat again and restore the contents. Boots up fine, then again? It also appeared to boot sometimes, sometimes boot to black...?

    Turns out I had 2 payload injectors running, one was the fusee-primary one that comes with atmosphere, other was hekate 4.2. Hekate 4.2 worked every time. the fusee-primary would boot to black 2 boot onwards...

    Never seen this on my unit, but I just told my buddy to use hekate for now.
     
  6. bjaxx87

    bjaxx87 GBAtemp Fan

    Member
    5
    Jun 17, 2011
    Germany
    I'm experiencing the same problem... It's pretty much 100% as described by this Reddit user that I found when googling for this:
    https://www.reddit.com/r/SwitchPira...lack_screen_while_launching_atmosphere_after/
    (the only difference is that I'm on 4.1.0)

    So you are saying it's SD card related?

    EDIT: It is. My old 4 GB FAT32 mSD card (from the NDS flashcard days) is working like a charm while my brandnew 200 GB exFAT mSD card keeps crashing Atmosphere. I will try my luck reformatting it.
     
    Last edited by bjaxx87, Nov 27, 2018
  7. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    19
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Some people have said that Atmo won't boot with an exFAT card if you don't have the exFAT update. I guess it needs to load some files from the SD when HOS boots up and if it's unable to it just crashes instead.
     
Loading...