Battle of the Giant Dragons

Discussion in 'NDS - ROM Hacking and Translations' started by dsliteboy, Oct 6, 2009.

  1. dsliteboy
    OP

    dsliteboy Member

    Newcomer
    23
    0
    Oct 19, 2006
    Hi there

    Is there a patch or trick to get this game going?

    On m3 and ak2i it goes to menu, start the cut scenes and then just before the game the screen gets lines line an out of tune/sync tv

    bugger I really want to play this game
     
  2. I2aven's_Sag

    I2aven's_Sag GBATemp Otaku

    Member
    726
    6
    Sep 13, 2009
    United States
    Northern Virginia
    I believe Ak2i & AKAIO 1.5 firmware solves this issue, but I could be wrong. Might try updating? I could be wrong. Good Luck.
     
  3. shineek

    shineek GBAtemp Regular

    Member
    256
    2
    Jul 14, 2007
    Poland
    yep the new loaders in AKAIO 1.5 solve the problem , if you use AKAIO 1.5 download the newset loaders from their site
     
  4. dsliteboy
    OP

    dsliteboy Member

    Newcomer
    23
    0
    Oct 19, 2006
    Confirmed Working - Many Many thanks!
     
  5. Krobelus

    Krobelus GBAtemp Regular

    Member
    163
    2
    Apr 9, 2009
    Canada
    Vancouver
    On R4 with firmware 1.18 it doesn't. It goes through the long un-skippable intro, then comes to a screen that is screwy. Like when you turn your tv to a channel with no cable and it's snowy.

    -Krobelus
     
  6. Kuragari Ryo

    Kuragari Ryo Demon Fox

    Member
    130
    9
    Mar 14, 2009
    United States
    The House Within the Reflection, Ryo Manor

    Have you tried playing it with YSmenu? That might work.
     
  7. shineek

    shineek GBAtemp Regular

    Member
    256
    2
    Jul 14, 2007
    Poland
    if YSmenu has its own loaders and they where udated then yes , if not than you cant play this game ,
    this game wont work on any official flash card firmwares , and the only confirmed way to play this game is on AKAIO 1.5 with the loaders from 05.10.2009
     
  8. shineek

    shineek GBAtemp Regular

    Member
    256
    2
    Jul 14, 2007
    Poland
    okay now im stunned by the stupidity of the creators of this game , as i heard they made around 80 anty piracy protections in this game , and its not working on most flashcards , the only exception was Acekard with AKAIO 1.5 but today i found out that this game works on a DSLinker as well , so what the hell?? is this card to old and the anty piracy protections dont work on it or what

    anyway i heard someones making a patch to make it work on R4 and clones
     
  9. Krobelus

    Krobelus GBAtemp Regular

    Member
    163
    2
    Apr 9, 2009
    Canada
    Vancouver
    Thanks Kuragari but I personally don't like YSmenu.

    Ahh well I don't mind.
    -Krobelus
     
  10. Twilight Loz

    Twilight Loz GBAtemp Fan

    Member
    382
    0
    Mar 28, 2009
    United States
    London
    Can someone tell me where to get the latest loader for ak2i? I cant seem to find it even though i searchered on google and on akaio.com
     
  11. YayMii

    YayMii hi

    Member
    4,915
    423
    Jun 24, 2009
    Canada
    that place
  12. Twilight Loz

    Twilight Loz GBAtemp Fan

    Member
    382
    0
    Mar 28, 2009
    United States
    London
    and then do I download the 5.10.2009 loader? Cool.
     
  13. muzland

    muzland Newbie

    Newcomer
    2
    0
    Sep 18, 2009
    Anyone got this to work on a TTDS card. I have tried 1.17ao8 but still have the same issues as above.

    Will akaio work on a TTDS?
     
  14. Depravo

    Depravo KALSARIKÄNNIT

    Global Moderator
    GBAtemp Patron
    Depravo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,247
    3,517
    Oct 13, 2008
    Purgatory
    1) Where did you get DSTT v1.17a08?

    2) AKAIO stands for ACEKARD-all-in-one, so no.
     
  15. Bookwormz13971

    Bookwormz13971 GBAtemp Regular

    Member
    130
    0
    Jun 22, 2009
    United States
    Hell
    Technically it's not stupidity. The creators of the game put measures to prevent anti piracy and seeing as how a large sum of people are unable to play the game on a pirated copy I believe they did their jobs.
     
  16. muzland

    muzland Newbie

    Newcomer
    2
    0
    Sep 18, 2009
    My bad, I meant 1.17a07.
     
  17. thientai99x

    thientai99x Newbie

    Newcomer
    3
    0
    Sep 14, 2009
    i'm using aka2i+akaio 1.5 but i cant play thiis game.help.
     
  18. d3co

    d3co Advanced Member

    Newcomer
    58
    0
    Feb 13, 2009
    Gambia, The
    So does this work on M3?
     
  19. KevInChester

    KevInChester GBAtemp Fan

    Member
    308
    2
    Jul 29, 2009
    Update to the latest loader:
    http://akaio.gbatemp.net/nloaders/
     
  20. shineek

    shineek GBAtemp Regular

    Member
    256
    2
    Jul 14, 2007
    Poland
    only half work , it works on DSLinker , so many protections and an oldie like DSLinker can still play this game