Apps that BRICK now.

Discussion in 'Wii - Hacking' started by xzxero, Oct 16, 2009.

  1. xzxero
    OP

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    I don't know why this hasnt been made yet, but we need a list of apps that now lead to bricks by downloading a
    stub IOS60
    which removes your system menu and preloader if you have it.
    These are mostly online updaters.
    I don't know them all, but i read about a few on here.
    You guys can help me create a full list so the community can be aware.
    If you have any of the apps below stored on your sd card or something, erase it and let people know!
    Ok so let's start.

    Waninkoko's Firmware updater 4.0
    Waninkoko's Firmware updater 4.1
    [^only if you don't have an installed and functional IOS60^]
    WiiSCU .21 [.22 works fine]
    IOS60/61 Installer /Patcher
     


  2. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    Great idea for a thread, I just want to mention that wiiscu 0.22 is safe to use, but when it's loading it still says its v0.21 even though its 0.22. So make sure you know which one you have before you use it.
     
  3. ndpndnt16

    ndpndnt16 GBAtemp Regular

    Member
    203
    0
    Dec 24, 2007
    shenzhen
    we could try to gather testers and confirm if its not a banner brick app
     
  4. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    Glad you guys mentioned this. I'd left Wanky's 4.1 updater on a guide I maintain elsewhere, but it seems like no one tried using it before I could take it down. So far no one's been bricked by following it and I'm not about to break my track record.
     
  5. xzxero
    OP

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    ?
    banner bricks have to with WAD installations.

    online updaters have absolutely nothing to do with channels.
     
  6. G0dLiKe

    G0dLiKe who needs a title ;)

    Member
    1,674
    51
    Aug 2, 2009
    United States
    We´ve been talkin bout this earlier in a thread. Good one.

    EDIT: Ahm, about WiiSCU... I used it 5 or 6 days ago on a 4.1 Wii to just update all channels and it wasnt bricked... FYI
     
  7. brice08

    brice08 Member

    Newcomer
    15
    0
    Oct 15, 2009
    France
    waninkoko's upgrade for me and low level brick!!
     
  8. xzxero
    OP

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    you must used .22 then.
    it was updated a while back.
     
  9. kedest

    kedest GBAtemp Psycho!

    Member
    3,287
    110
    Feb 6, 2007
    Netherlands
    Is it really Nintendo's intention to cause bricks or is that just a side-effect of using an unoffical updater?
    And what if you use dop-ios or nusd to download old ios files? will they be stubs too?
     
  10. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    It's a side effect of using updaters that don't have proper sanity checks on what they're doing. It's the coder's fault if it blindly grabs the latest IOS instead of what's known to work, not Nintendo's.
     
  11. G0dLiKe

    G0dLiKe who needs a title ;)

    Member
    1,674
    51
    Aug 2, 2009
    United States
    Possibly. It was the one Wacko released, I was wondering because the readme still says 0.21(just downloaded the 0.22 again to check and yes it says 0.21).

    Edit: Checked the .xml it says .22
     
  12. xzxero
    OP

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    im pretty sure its a side effect.

    dop-ios and NUSD let you choose what version of the IOS you want installed.

    v6400 is the stub version
    v6174 is the original working version.
     
  13. longtom1

    longtom1 Keep an eye on my posts cause I quick edit frequen

    Member
    2,641
    0
    Jan 12, 2009
    Honey Oils inc.
    you need to add IOS60 Patcher
     
  14. xzxero
    OP

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    done. anymore anyone can think of?
    we want the least bricks as possible!
     
  15. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    WiiSCU 0.21 and WiiSCU 0.22 are identical in every way EXCEPT v0.22 will not download the latest version if IOS60 (which is a stub), and this will only brick you if you are on 4.0 or 4.1, and don't have bootmii as boot2 (I'm pretty sure it will even brick u if u have preloader)

    So if you have WiiSCU 0.21, it is safe to use AS LONG AS you don't update IOS60.

    EDIT: on a personal note, I happened to be modding a virgin 4.0 wii ONE day after the 4.2 update and I hadn't heard about it... wiiscu 0.21 bricked me... piece of shit (no offense intended, app kicks ass, just pisses me off I bricked a friends wii)
     
  16. xzxero
    OP

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    yea but theres a huge risk of brick with the touch a button.
    thats a no go in my book.
     
  17. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    totally agree with u, every1 should upgrade to 0.22 and delete 0.21 immediately!
     
  18. Pakatus

    Pakatus GBAtemp Advanced Fan

    Member
    777
    0
    Apr 13, 2009
    Portugal
    Sticky on this please...
     
  19. lechon3x

    lechon3x Newbie

    Newcomer
    4
    0
    Oct 4, 2009
    United States
    Ios 60/61 patcher definetly. I bricked my wii last week because of it. Good thing I bought it six days before and was able to return it for a new one. On my new one, I used a combination of xzxero's and devyil's guide, even used wanin's updaters to go from 3.4u to 4.0u and then 4.1u and the only problem I had was the sistem files corrupted everytime I reintalled preloader. Changing the ios in the preloader settings fixed that. I guess I was lucky using wanin's updaters, they didn't brick me.
     
  20. xzxero
    OP

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    you mistve got realll lucky then guy.