AP-patch preservation

Discussion in 'NDS - ROM Hacking and Translations' started by Robz8, Jul 15, 2017.

  1. Tattorack

    Tattorack Interstellar Explorer

    Member
    3
    Jun 15, 2011
    Denmark
    Calisto Prime Orbital
    That app isn't working at all for me.
    No AP list I've looked at contains Age of Empire: Mythologies. It's like it's the one game in all of existence that doesn't have a patch for it.
    I mean, the graphical glitches might be something else too... but I can't think of any other reason besides AP that would causes weird glitches in Twilight++.
     
  2. JamesAaronSpirin

    JamesAaronSpirin Member

    Newcomer
    1
    Oct 20, 2012
    You need to reupload those somewhere else. Filetrip closes down in two weeks, March 31st.

    That file will be going offline too. I'd reupload it ASAP.
     
    Last edited by JamesAaronSpirin, Mar 17, 2019
    noctis90210 likes this.
  3. kevandkkim

    kevandkkim Advanced Member

    Newcomer
    4
    Nov 22, 2016
    United States
    please
    im literally one day late
     
    Bst22322 likes this.
  4. Localhorst86

    Localhorst86 GBAtemp Addict

    Member
    10
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    juggernaut911 and zfreeman like this.
  5. LowEndC

    LowEndC ǝɹıℲ ɥʇıM ǝɹıℲ ʇɥƃıℲ

    Member
    3
    GBAtemp Patron
    LowEndC is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jan 25, 2019
    Niger
    You have to die before you can wake.
    tried this, just gives me an error in Japanese every time i drag a rom onto it. do the roms need to be decrypted?
    i cant get the below roms to work, ap patch or not..
    would like to try this on them.

    Dragon Quest 5 and 9, Chrono Trigger, and The Legend of Zelda - Spirit Tracks were patched successfully with ds-scene rom tool, and separate xdelta patches i found on odrive.
    both do not work.
    there is no patch for phantom hour glass, i would like to play that too..

    running twilightmenu++ v8.0.0 and nds bootstrap v0.17.1
    on new2dsxl 11.9 luma 9.1

    dont know if this info is useful and if my problems can be fixed or what,
    i didnt want to make a github account to open an issue, as it might not even be an issue.

    ALSO,
    every issue ive seen with games not working, or hanging on black/white screen even when ap patched, you or anyone else always say "format ur sd card, i dunno"
    but users have replied with something similar to "it worked on nds bootstrap 11x but now wont on 12x"
    and ive seen this a few times.

    but it seems updates to nds bootstrap break compatibility for some games. which update broke which game? idk,

    because the main games i want, dont work, even when having an available ap patch.


    sorry for being bobo tier slowmo


    thanks rob, great app,



    All pokemon games save/load just fine for me.
     
    Last edited by LowEndC, Apr 7, 2019
  6. lordkaos

    lordkaos GBAtemp Advanced Fan

    Member
    6
    Mar 13, 2009
    United States
    You know, I said that when people still needed to use donor roms and carts in order to save, now it works perfectly without it.
     
    Last edited by lordkaos, Apr 6, 2019
  7. LowEndC

    LowEndC ǝɹıℲ ɥʇıM ǝɹıℲ ʇɥƃıℲ

    Member
    3
    GBAtemp Patron
    LowEndC is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jan 25, 2019
    Niger
    You have to die before you can wake.
    didnt go through the pages.
    just came here for the xdelta patches. :)

    Edit: and to type meaningless shite apparently
     
  8. Zaiphon

    Zaiphon GBAtemp Regular

    Member
    3
    Feb 5, 2017
    Gambia, The
    Is there a AP for Golden Sun DD EU? Only found USA.
     
  9. Shtooball

    Shtooball Member

    Newcomer
    1
    Mar 26, 2017
    United States
    https://filetrip.net/nds-downloads/...-ds-scene-rom-tool-v10-build-1205-f25536.html Downloading the tool from this site isn't possible for me. When I click on the "download file", then go to the website where I'm apparently supposed download the file, it says it's an unsafe website, but when I try to proceed, the website doesn't load. I've tried using internet explorer and google chrome, but it's all the same. Is there another website I can download it from?
     
  10. MythicalData

    MythicalData GBAtemp Advanced Fan

    Member
    6
    May 11, 2017
    United States
    https://drive.google.com/open?id=1Amb9sIzZFdA8y9r36F40NQLdwyM8KmtT
     
    alexander1970 likes this.
  11. Shtooball

    Shtooball Member

    Newcomer
    1
    Mar 26, 2017
    United States
    Whenever I try to use Custom Robo Arena, Legend of Zelda Spirit Tracks, Dragon Quest Sentials of Sky or Phantasy Star 0, It gives me an error saying "Something went wrong opening the file! Value of '4' for is not valid for 'Value'. 'Value' Should be between 'minimum' and 'maximum'. Parameter name: Value". What does that mean? How can I fix this? I apologize for being such a noob. Thank you for your time, help, and patience.
     
  12. MythicalData

    MythicalData GBAtemp Advanced Fan

    Member
    6
    May 11, 2017
    United States
    make sure you're applying the patch to the correct version of the game (region) sometimes you just have to try a few versions. Also there's a mod of ds zelda games that allow you to playthem without touch screen (like 99%) if you;'re interested
     
  13. Shtooball

    Shtooball Member

    Newcomer
    1
    Mar 26, 2017
    United States
    The AP Patch tab has a red X on it with each Rom that supposedly needs an AP Patch to run it properly.
     
  14. Ethanmodder

    Ethanmodder Newbie

    Newcomer
    1
    May 25, 2019
    United States
    Anybody have a xdelta for radiant historia?? I've been scouring for a week now ;-;

    I wouldn't have had a problem if filetrip went down -_-


    R.I.P filetrip
     
  15. kaizen

    kaizen Advanced Member

    Newcomer
    2
    Jul 28, 2009
    Anywhere
    Not sure if this is the correct thread but is anyone able to run the English patched version of Fire Emblem - Shin Monshou no Nazo Hikari to Kage no Eiyuu in Twilight Menu? I was able to AP patched the clean rom, but if I do that I wont be able to apply the English patched, however there is no AP patch for the English Patched version of the game.
     
  16. DoctorGii_

    DoctorGii_ Newbie

    Newcomer
    1
    Jun 3, 2019
    Honduras
    Been having issues trying to play Ace Attorney Investigations 2 (or 5532 - Gyakuten Kenji 2), but the english patched rom...
    First I ignored the warning and the game does run, but the letters are a jamble of random special characters... so I tried runningAP patching it:
    the OpenPatch app but got an error in Japanese, then,
    tried with one above and it doesn't appear to have an ap patch or be able to patch it at all..

    I did went to those xdelta files but it ain't there..

    Running it through the latest TWiLight Menu build on an n3ds w/CFW. I still have my previous save which works on the 2 current ds emulators and also twilight does load it, its just the letters are incomprehensible to read because its just a repetetion of the same letter for some reason.
     
  17. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23
    Nov 21, 2005
    United Kingdom
    I once had a brief conversation on what it would take to adapt the save to prevent existing saves from working for one of those ace attorney projects. Text encoding issues being the main reason for that. In the end I believe they decided to not do anything and note it in the NFO/readme/install/release notes. Short version time to start over.

    Depending upon what goes you might also be running into the patch stacking issues we have discussed for other games. I would not expect AP removal and translations to conflict at a base level but the patches might not play nicely together. General idea of how to work around it https://gbatemp.net/threads/ap-patch-preservation.477536/page-4#post-8498778 .
     
    alivebacon likes this.
  18. chrisman02

    chrisman02 Member

    Newcomer
    1
    Dec 8, 2015
    United States
    So I have an interesting problem. Running Linux Mint, trying to use the DS-Scene tool using Wine.

    It's not recognizing xdelta files at all. That's what you're supposed to use with it for the AP patches, correct?

    Sorry, been years since I modded Nintendo consoles so I'm a noob at this. Recently installed CFW on my DSi and have been running backups and other roms fine off the SD card, unless they need an AP patch applied, eg Ghost Trick.

    If this is just a case of DS-Scene not playing well with Wine, what are the options for Linux users (Debian based) to apply AP patches?

    Sorry if this is the wrong thread to be asking this.
     
  19. AAAAARRRGH

    AAAAARRRGH Newbie

    Newcomer
    1
    Jun 5, 2019
    United States
    Neither do any of the TF games
     
  20. DMSalesman

    DMSalesman Member

    Newcomer
    2
    Jun 18, 2017
    Italy
    The garbled text is the AP measure. Use the patch below.

    https://mega.nz/#!35oCjQBa!R6FQLW6mg5PZWGFNWAHNaLZfTOE4sjrfQdabdHaFsKI
     
Loading...