AKAIO 1.6rc, Homebrew Soft Reset, technical Q

Discussion in 'Acekard' started by Atashi, Mar 11, 2010.

  1. Atashi
    OP

    Atashi Out of the Loop

    Member
    176
    2
    Feb 4, 2010
    Canada
    Ontario, Canada
    I'm not really sure where this question would belong... the new AKAIO 1.6rc has homebrew soft reset which is wonderful, but I've found that only some homebrews work with it, while others don't. I'm not talking about big popular projects, just little simple things.

    For example, I've tried compiling a handful of the examples that come with DevKitPro / DevKitArm (latest build) and soft reset appears not to work with any of them. I've tried both the IRQ and the SWI hook settings in the AKAIO options menu...

    So I'm wondering if either there is something about how devkitpro builds the files, or maybe something in libnds, that makes the resulting binaries incompatible with AKAIO's soft reset?

    And if that's the case, is there something that can be fixed, or changed? Or rather, is there something I can fix or change, to ensure that any homebrew I build, will be compatible with the AKAIO hb soft reset?

    Thanks & Cheers!

    -Atashi
     
  2. CannonFoddr

    CannonFoddr Regular GBATemp Lurker

    Member
    4,111
    68
    Sep 23, 2006
    Sitting by computer
    Perhaps you could PM one of the AKAIO team & they may be able to tell you 'straight from the horses mouth' how AKAIO expects how Homebrew should be prorgrammed to accept soft-reset
     
  3. saxamo

    saxamo Spaaaaace!

    Member
    775
    33
    Aug 6, 2006
    United States
    NYC
    Can you tell me what is the key combination to reset homebrew? is it L R A B X Y?
     
  4. penthaler

    penthaler GBAtemp Fan

    Member
    357
    1
    Oct 28, 2009
    mystique
    Its the same combination as softreset games -> L+R+A+B+arrow_down
     
  5. Normmatt

    Normmatt Former AKAIO Programmer

    Member
    2,142
    543
    Dec 14, 2004
    New Zealand
    The latest libnds isn't supported yet I'll add support for it soon.
     
  6. Atashi
    OP

    Atashi Out of the Loop

    Member
    176
    2
    Feb 4, 2010
    Canada
    Ontario, Canada
    Awesome! Thanks so much Normatt for all the work you & the AKAIO team put in to this!

    -Atashi
     
  7. nissen22

    nissen22 Member

    Newcomer
    12
    0
    May 8, 2010
    United States
    norway
    I got a strange bug with akaio 1.6rc2 soft-reset [​IMG] When i soft reset the theme changes to standar and the language changes to portugise and to fix it i have to reboot the system and start up acekard again and choose the theme i want and change back to english [​IMG]
     
  8. d3monsting

    d3monsting GBAtemp Regular

    Member
    119
    1
    May 9, 2010
    United States
    What's this box for
    @nissen22
    I believe this is a known bug... search for more indepth info.... someone said changing the globalsettings.ini (or something like that) to READ ONLY, is a possible solution....?