Gaming After installing CTR got "The software was closed because an error occurred" [SOLVED]

AnonDragon

Active Member
OP
Newcomer
Joined
Jun 21, 2016
Messages
37
Trophies
0
Location
Somewhere
XP
136
Country
Colombia
Hello, I am having the following problem. After installing the base Crash Team Racing game and its latest update on my system memory (NSPs; the first one with Goldleaf and the latter with Lithium, both through USB method), I am getting the "The software was closed because an error occurred" which does not allow the game to start. I have the latest atmosphere (0.9.3) with latest sigpatches (es/kip) on 7.0.1 Firmware.

I just checked https://gbatemp.net/threads/the-software-was-closed-because-an-error-occurred.533703/ and did not find a solution in there, because I am not using any cheat engine nor have detected any problems with other games/installs on my SD card.

Also saw https://gbatemp.net/threads/the-software-was-closed-because-an-error-occurred.543921/ and yes, also tried deleting, redownloading, and reinstalling. Checked for corrupted data and there's none.

Any ideas?

(UPDATE)

This problem was solved by carefully updating my FW to 8.1.0 with ChoiDujourNX
 
Last edited by AnonDragon,

Andalitez

Well-Known Member
Member
Joined
Jul 2, 2018
Messages
495
Trophies
0
Location
Final Space
XP
1,132
Country
United States
My SO was playing Don't Starve Switch Edition for a few months already. She told me last week the game would randomly freeze, and display the error you referring to.Although I use SX OS 5gb emunand

I attempted to fix it in the following way.
Redownloaded the base and update nsp files.
Replaced the emunand version with a previous backup.
Reinstalled the game + update using goldleaf (this made it 100% worse because she couldn't even run the game anymore,it would just crash with this error)
Changed microSD cards

In the end I ended up using Checkpoint to backup saves and reloading 8.1.0 on the 5gb emunand using ChoiNX with system initialization selected.

This seems to have worked, no more errors or lockups so far. It could have something to do with corruption in tickets/title rights etc

I'm not saying do what I did,but it was the last steps before I started replacing hardware like purchasing a new sd card and card reader
 

KnightRiderX420

The Anigmatic Anomoly
Member
Joined
Nov 24, 2018
Messages
151
Trophies
0
Age
46
Location
U.S.A.
Website
www.beyondwindows10.com
XP
625
Country
United States
Hello, I am having the following problem. After installing the base Crash Team Racing game and its latest update on my system memory (NSPs; the first one with Goldleaf and the latter with Lithium, both through USB method), I am getting the "The software was closed because an error occurred" which does not allow the game to start. I have the latest atmosphere (0.9.3) with latest sigpatches (es/kip) on 7.0.1 Firmware.

I just checked https://gbatemp.net/threads/the-software-was-closed-because-an-error-occurred.533703/ and did not find a solution in there, because I am not using any cheat engine nor have detected any problems with other games/installs on my SD card.

Also saw https://gbatemp.net/threads/the-software-was-closed-because-an-error-occurred.543921/ and yes, also tried deleting, redownloading, and reinstalling. Checked for corrupted data and there's none.

Any ideas?

I believe in your scenario its a matter of having the correct espatches installed. i ran into the same issue till i updated said patches with new version and no more unload-able already installed nsps. at least for me anyway.
so i would advise upgrading your atmosphere to 9.4 and getting latest espatches to match it. tho be aware some floating around that are incomplete caused my system to just begin to boot get to the atmos symbol and hang. all i'm saying is if you copy over your old ones to upgrade make sure none of previous firms are missing in the bunch. that was my solution that fixed and helped me at least :)

especialy if the game isnt reporting being corrupted in any way when trying to start it.... looks like a simple espatches corruption issue. :)
 
Last edited by KnightRiderX420,
  • Like
Reactions: AnonDragon

AnonDragon

Active Member
OP
Newcomer
Joined
Jun 21, 2016
Messages
37
Trophies
0
Location
Somewhere
XP
136
Country
Colombia
I believe in your scenario its a matter of having the correct espatches installed. i ran into the same issue till i updated said patches with new version and no more unload-able already installed nsps. at least for me anyway.
so i would advise upgrading your atmosphere to 9.4 and getting latest espatches to match it. tho be aware some floating around that are incomplete caused my system to just begin to boot get to the atmos symbol and hang. all i'm saying is if you copy over your old ones to upgrade make sure none of previous firms are missing in the bunch. that was my solution that fixed and helped me at least :)

especialy if the game isnt reporting being corrupted in any way when trying to start it.... looks like a simple espatches corruption issue. :)

Thank you for your reply.

Just attempted upgrading to 0.9.4 with patches, but no good, that game still won't start :(

I'm using these: https://gbatemp.net/threads/i-heard-that-you-guys-need-some-sweet-patches-for-atmosphere.521164/

I wonder whether I should try installing the XCI version... Or this has nothing to do?



My SO was playing Don't Starve Switch Edition for a few months already. She told me last week the game would randomly freeze, and display the error you referring to.Although I use SX OS 5gb emunand

I attempted to fix it in the following way.
Redownloaded the base and update nsp files.
Replaced the emunand version with a previous backup.
Reinstalled the game + update using goldleaf (this made it 100% worse because she couldn't even run the game anymore,it would just crash with this error)
Changed microSD cards

In the end I ended up using Checkpoint to backup saves and reloading 8.1.0 on the 5gb emunand using ChoiNX with system initialization selected.

This seems to have worked, no more errors or lockups so far. It could have something to do with corruption in tickets/title rights etc

I'm not saying do what I did,but it was the last steps before I started replacing hardware like purchasing a new sd card and card reader

Hmm, interesting scenario. However, I installed it on the system memory and haven't had any other issues with my SD


-----------------------------

(UPDATE)

I tried to install Smash Ultimate's latest update + DLCs (used Lithium USB, this time on SD) and I am getting the same error :ohnoes: ... what could I be missing? Any other files/patches? Should I try an older CFW? Should I upgrade my console's Firmware to some 8.x?
 
Last edited by AnonDragon,

Andalitez

Well-Known Member
Member
Joined
Jul 2, 2018
Messages
495
Trophies
0
Location
Final Space
XP
1,132
Country
United States
Thank you for your reply.

Just attempted upgrading to 0.9.4 with patches, but no good, that game still won't start :(

I'm using these: https://gbatemp.net/threads/i-heard-that-you-guys-need-some-sweet-patches-for-atmosphere.521164/

I wonder whether I should try installing the XCI version... Or this has nothing to do?





Hmm, interesting scenario. However, I installed it on the system memory and haven't had any other issues with my SD


-----------------------------

(UPDATE)

I tried to install Smash Ultimate's latest update + DLCs (used Lithium USB, this time on SD) and I am getting the same error :ohnoes: ... what could I be missing? Any other files/patches? Should I try an older CFW? Should I upgrade my console's Firmware to some 8.x?
My suggestion is to backup all saves and reinstall firmware as a fresh console,wiping all data in the process
 

Mike_77712

Well-Known Member
Member
Joined
Apr 7, 2016
Messages
180
Trophies
0
Age
25
XP
577
Country
United States
Im
My suggestion is to backup all saves and reinstall firmware as a fresh console,wiping all data in the process
Dont mean to hijack but I'm having the same issue, certain nsps giving that error upon opening. How I do I make a fresh install with emunand?
 

Andalitez

Well-Known Member
Member
Joined
Jul 2, 2018
Messages
495
Trophies
0
Location
Final Space
XP
1,132
Country
United States
Im
Dont mean to hijack but I'm having the same issue, certain nsps giving that error upon opening. How I do I make a fresh install with emunand?
Which emunand/emummc are you using bud?
The idea is to get the firmware files for your firmware version(e.g 8.1.0) from that darthsternie site and use ChoidujourNX to reload it, selecting the appropriate options ( Leave autoRCM on if you use autoRCM or turn it off if you don't), then choose system initialization that will wipe your switch. Choose exfat version of firmware even if you use fat32 sd card.

Just remember to back up your saves before you start, and if you want a linked account on the switch after the wipe,you can use Kefir Updater
 

KnightRiderX420

The Anigmatic Anomoly
Member
Joined
Nov 24, 2018
Messages
151
Trophies
0
Age
46
Location
U.S.A.
Website
www.beyondwindows10.com
XP
625
Country
United States
in any sense i tried 2 diferent installers for the same game not the one you did but with the same issue. goldleaf 7.1 installed ok but failed to startr.... hbg forked tinfoil 4.1 installer worked and game starts... so my new advise is try a different installer... i know alot of folks here dont like them but hbg seems to give good releases with alot of functionality. so if your interested google there dicord server invite link or pm me as i dont know if i can directly link it here without getting into trouble.... and goldleaf installer does mention something about missing tickets and failed installs but hbgshop... not a problem. and 1 more thing. did you re run the latest version of lockpick_rcm to update your prod keys file and copy paste it to the root of your sd card? also dump your new tsec keys and kfuses... i am not sure those are still needed but every new firmware i always update them just incase i also dump package 1 & 2. i will also say this 9.4 seemed to at first give me a heep of issues. heck now i even have a dual bootable lineage and HOS msd card that works great.... now that i know how todo that i am getting a bigger card as the 1 i have is 128gb... all said and done on this with emunand and lineage i get about 69 ggs of nsp installs plus hb and retroarch with kodi on lineage.... after installling repo its worth it all the way ;)
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: https://youtu.be/7EvzUBlh9Qo