Action Replay DSi and Shunyweb Savegames Converter 2.0

Discussion in 'Other Flashing Hardware & Software' started by angelXwind, May 24, 2012.

  1. angelXwind
    OP

    Newcomer angelXwind -angelXwind sinks back into her hiding hole-

    Joined:
    Jul 19, 2010
    Messages:
    14
    Location:
    Inside her hiding hole.
    Country:
    United States
    So, I got an Action Replay DSi from a friend of mine, and got it all set up properly.
    Though, it seems that the savegame dumping ability of it is rather crippled.

    This isn't the first time I've had this, as he lent this to me a year ago to help him use Pokesav on his Pokemon Platinum savegame.

    Back then, I dumped the save using the built-in save dumper, which dumps to the DUC format. Then I pretty much used the Shunyweb Savegames Converter to convert this from the DUC format to SAV. (Acekard RPG | EZFlash V | RAW Format (.sav))

    Then I proceeded to open it using Pokesav, and all went fine. It only corrupts when I convert it to SAV. (or any other format)


    So now he gives it to me, because he accidentally reset it, and doesn't have the cable, so now I have it. Then he wants me to do the Pokesav operation again, so that's exactly what I do. However, something rather strange happened. The savegame dumps just fine, but when I ran it through Shunyweb, the resulting SAV was not readable by Pokesav (it spat out incorrect values for just about everything), or NO$GBA.

    After trying a lot of times, I decide to use Rudolph's NDS Backup Tool (WiFi), since the ARDSi has homebrew support, and that dumps just fine. (though I have an offtopic question about this, refer to the end of the post for it). Dumping via the Backup Tool obviously worked, and Pokesav could read it just fine, along with the emulators. Weird.

    Any idea what causes this?

    If I re-flash the DS cart with the original DUC it made, it ends up working just fine.

    And about the said off-topic question: Why is it that the NDS Backup Tool will always claim to "fail" at 99%, resulting in a SAV that is a couple of bytes short, but otherwise still valid? I have to run it through the Shunyweb Converter just to pad it to the correct size, or else nothing accepts it. (this is a SAV > SAV conversion)

    Another weird thing is that when I tried dumping the save of Pokemon Pearl, the resulting file was 512KB, even though the actual save data is only 256KB. (Once again, had to run it through the Shunyweb Converter to pad it to 512KB, also a SAV > SAV conversion)
     
  2. UniqueGeek

    Member UniqueGeek PMD Researcher

    Joined:
    May 29, 2009
    Messages:
    1,371
    Country:
    United States

Share This Page