ACE3DS Plus?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Runehasa, Mar 30, 2015.

  1. Runehasa
    OP

    Runehasa GBAtemp Regular

    Member
    253
    123
    Oct 12, 2007
    United States
    Ohio
    Looking at the ACE3DS Plus website it says it will work on 9.5 firmware directly but mine sure as hell doesnt. Does anyone know if it needs to be updated or where to find this update. On the ace3ds website i cant seem to find anything besides the wood firmware
     
  2. maffinre

    maffinre Newbie

    Newcomer
    6
    0
    Mar 12, 2015
    Gambia, The
    You need to install the newest firmware (aos 2.13) from the official website on your ace3ds plus.
    Then you HAVE to put it in a normal ds oder ds lite (or a 3DS with a firmware below 5.0 I tink) and then it'll work on a 3DS or N3DS with a firmware up to 9.6 (I just fought with my ace3ds plus card about 3 hrs ago, but now its working).
     
  3. Technicmaster0

    Technicmaster0 GBAtemp Addict

    Member
    2,999
    603
    Oct 22, 2011
    Gambia, The
    That probably won't work since the AOS is only the Kernel (aka Ace3DS' "Firmware" tho firmware technically means something else).
    The Ace3DS team usually released a new revision of the card after the old one got blocked by a 3DS system update.
     
  4. Runehasa
    OP

    Runehasa GBAtemp Regular

    Member
    253
    123
    Oct 12, 2007
    United States
    Ohio
    Yeah I was guessing that was probably the case. It used to work on my old 4.5 3ds xl but since I migrated to my N3DS I cant seem to get it to work. If there is no firmware upgrade available anyone else have any suggestions for a card that will play DS games?