5.00 M33-4 psp Phat

Discussion in 'PSP - Games & Content' started by DarkWing, Jan 16, 2010.

  1. DarkWing
    OP

    DarkWing Advanced Member

    Member
    63
    0
    Nov 4, 2002
    United States
    JC Tenn
    Been reading through the posts of cfw and such... Alot to process and I aint the greatest at the installing / etc for it to begin with so bare with me.. If someone else has posted this and I missed it [​IMG] if not [​IMG] ..

    I am on psp phat running M-334 5.00

    Downloaded the Lunar demo and of course it gives me the your 5.00 u need 6.20 or later.. I really wanna play the demo is there a fix I can use just for that OR should I just wait till game comes out and get get the full then... Cso Iso ftw ... Would like to get the actual whole game since Im kinda a Lunar geek.... But If I get it then I will have the umd issues either way I need to either update so I can play the demo or just wait till release..

    If theres an update from my current version I dont wanna lose my emus that I am already running capcom/neo geo etc.. If so which ones do I need to do.. Keep in mind
     
  2. Jamstruth

    Jamstruth Secondary Feline Anthropomorph

    Member
    3,456
    185
    Apr 23, 2009
    North East Scotland
    Update to 5.50 GEN D and you may be able to have it work as it has a decryptor for most games>5.50, none of your homebrew/saves will be lost in flashing your firmware just name and wi-fi settings
     
  3. Shardnax

    Shardnax GBAtemp Regular

    Member
    179
    1
    Aug 23, 2008
    United States
    Can the newest GEN firmware play PSP2?
     
  4. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    Yes
     
  5. DarkWing
    OP

    DarkWing Advanced Member

    Member
    63
    0
    Nov 4, 2002
    United States
    JC Tenn
    [​IMG]
    Cool will look into doing that if I decide to get the actual thing when it comes out.. Been "playing" the import and I am pleased at it so far.. Dont know what they saying lol but seeing how I have played through it so many times I pretty much know all the dialog for it lol..

    Dw
     
  6. Ryupower

    Ryupower Brood

    Member
    2,924
    433
    Oct 8, 2007
    United States
    i have the demo(as an CSO) , working on 5.00 m33-6
    i did it myself

    the UMD will NOT work on 5.00 m33-6


    for most newer game (5.55+)
    you need the Patch and decrypt the games eboot.bin for the to run on 5.00 m33-6


    the game has ALL new dialog
     
  7. Skyline969

    Skyline969 MENUdo Afficionado

    Member
    2,207
    8
    Nov 18, 2008
    Canada
    Saskatchewan
    Or, you can use 5.50 GEN-D (or D2 or D3) which already decrypts the games for you, so you just throw the ISO on and play.
     
  8. steve-p

    steve-p GBAtemp Advanced Fan

    Member
    503
    0
    Apr 13, 2009
    i'm getting fed-up with GEN fanboys telling people everything will work, GEN will NOT decrypt games that need 6.10 or 6.20 - you need to patch them for GEN just as much as for M33
     
  9. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    I'm getting fed-up with M33 fanboys telling people everything won't work, GEN WILL decrypt games that need 6.10 not 6.20 - you DONT need to patch them for GEN just like you have to for M33.

    (There is hardly any 6.20 games out. Just KH:BBS I think.)
     
  10. Jamstruth

    Jamstruth Secondary Feline Anthropomorph

    Member
    3,456
    185
    Apr 23, 2009
    North East Scotland
    What's more GEN will play the official UMD unlike you M33 guys who have to pirate if you want the newer games. Not sure whether that's an advantage or a disadvantage, it is for me as I have very limited memory stick capacity at the moment.

    M33 is outdated, you should all admit it. Its a good firmware but GEN's just an update on it. Its just as stable and all homebrew I have tried so far works fine.