3DS XL won't boot without sd card

Discussion in '3DS - Console, Accessories and Hardware' started by Samlake, Jan 23, 2017.

  1. Samlake
    OP

    Samlake Member

    Newcomer
    48
    3
    Jan 22, 2017
    United States
    As i said in the title, i can't boot with my sd card and if i insert it when it is on, it says "can't read the sd card".
    Help pls
     
  2. GerbilSoft

    GerbilSoft GBAtemp Addict

    Member
    2,110
    2,353
    Mar 8, 2012
    United States
    Did you install arm9loaderhax? If so, then this is expected behavior, assuming you didn't also set up a CFW in CTRNAND.
     
    Samlake likes this.
  3. Samlake
    OP

    Samlake Member

    Newcomer
    48
    3
    Jan 22, 2017
    United States
    Yeah, i have arm9loaderhax.bin on the sdcard ( i installed it on the nand too ) with luma 6.6 installed
     
    Last edited by Samlake, Jan 24, 2017
  4. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Have u tested sd card to see if it's failing? Use H2Testw
     
  5. MRJPGames

    MRJPGames Pretty great guy

    Member
    1,111
    717
    Aug 17, 2013
    Netherlands
    The Netherlands
    He said it didn't boot WITHOUT the SD card. So it does work with the SD card, clearly not a problem with the SD Card.


    I would suggest trying to reinstall it on CTRNAND, and see if your able to boot without SD then, but why would you want to boot without SD anyways?
     
  6. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
     
  7. Samlake
    OP

    Samlake Member

    Newcomer
    48
    3
    Jan 22, 2017
    United States
    Oh my bad, i wanted to say "won't boot with sd card"
     
  8. spkuja

    spkuja GBAtemp Regular

    Member
    263
    76
    May 7, 2007
    Sounds like your SD might be dying. Have you tried backing everything up and formatting it with SD Formatter?
     
    el_gonz87 likes this.
  9. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Does the blue light stay on without SD? Or does it go immediately off?
     
  10. SkyQueen

    SkyQueen Arch3DS Developer || B0MBrHax

    Member
    228
    109
    Apr 23, 2016
    Japan
    Seteguya-ku, Tokyo, Japan
    Could be that the writespan on the SD card is done. My first 512 gb Micro finally failed and couldn't be used anymore and did the same thing.
     
    el_gonz87 likes this.
  11. Samlake
    OP

    Samlake Member

    Newcomer
    48
    3
    Jan 22, 2017
    United States
    I don't know where i stored my arm9loaderhax.bin on my pc. Huh, it goes off immediately ;_;
     
  12. SkyQueen

    SkyQueen Arch3DS Developer || B0MBrHax

    Member
    228
    109
    Apr 23, 2016
    Japan
    Seteguya-ku, Tokyo, Japan
    Just try to put all your files on a new SD card and go grab the latest Arm9 file and see if that works.
     
  13. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    You probably either:
    a) Didn't install arm9loaderhax.bin in CTRNAND at all.
    b) Put arm9loaderhax.bin it in the wrong place of CTRNAND.
    c) Have an older version of A9LH which doesn't load from CTRNAND.

    I'm almost positive it's your SD card now. @MRJPGames thoughts?

    Suggestion, get a new SD copy all files and you can get the arm9loaderhax.bin from here: https://github.com/AuroraWright/Luma3DS/releases.
     
  14. Samlake
    OP

    Samlake Member

    Newcomer
    48
    3
    Jan 22, 2017
    United States
    Where can i find the latest arm9 file
    Does a9lh works without the cartridge slot ? Cuz i dont have it
    Thanks you for your help guys :)
    The arm9 is the latest version cuz i installed it a week ago and it is stored in the ctrnand, it worked before
     
    Last edited by Samlake, Jan 24, 2017
  15. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Look at my last post, I linked to the latest stable release.
     
  16. Samlake
    OP

    Samlake Member

    Newcomer
    48
    3
    Jan 22, 2017
    United States
    I wanted to say, if i put an empty sd card, it not boots
    @el_gonz87 i didn't find your post :/
     
    Last edited by Samlake, Jan 24, 2017
  17. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
  18. Samlake
    OP

    Samlake Member

    Newcomer
    48
    3
    Jan 22, 2017
    United States
    Thanks, will try when ill be back home
     
  19. Samlake
    OP

    Samlake Member

    Newcomer
    48
    3
    Jan 22, 2017
    United States
    I replaced my old arm9 file with the one included in luma6.6 but the blue led still turn on and off gradually
     
  20. GerbilSoft

    GerbilSoft GBAtemp Addict

    Member
    2,110
    2,353
    Mar 8, 2012
    United States
    You set it up as arm9loaderhax.bin, not arm9.bin, right?