Windows 10 waking computer from sleep mode

Discussion in 'Computer Software and Operating Systems' started by loco365, Aug 21, 2015.

  1. loco365
    OP

    loco365 GBAtemp Guru

    Member
    5,458
    2,673
    Sep 1, 2010
    I've had an issue that's only shown up since installing Windows 10. I'm well aware that Windows 10 can schedule a time for which it will restart itself to install updates, however, the time that is scheduled is usually at night, when the computer - a laptop in this case - is in sleep mode. It seems they thought of a way around it, because my laptop will wake itself up and restart itself to install the updates. There's a few problems I have with this:

    1. All my programs are closed, which is never fun.
    2. If my laptop is in my bag, say I forgot to take it out to charge it after coming home from work, it will run the risk of overheating and damaging components.
    3. If it isn't plugged in and the install takes longer than usual, the battery could die and I may end up with a brick.

    I have tried toggling the No auto restart with logged in users, but I was woken up last night by the attached monitor turning on at 4AM, so it doesn't seem to have worked. Is there any other way to disable the ability for my computer to do this?
     
    osirisjem likes this.
  2. osirisjem

    osirisjem Wii U: Y U No Sell ?

    Member
    1,072
    353
    Jun 19, 2011
    Canada
    Write a script to Disable the ethernet port when you put it in sleep mode ?
     
  3. GameSystem

    GameSystem GBAtemp Regular

    Member
    258
    144
    Sep 14, 2009
    United States
    You could also try right clicking on your wifi settings and set your connection as metered. Windows won't auto download updates while on metered connections and thus you won't have to restart. I think clicking on your battery icon and setting it to battery saver does the same thing. Then whenever you want to download updates, you can just do it manually.
     
    Seriel likes this.
  4. loco365
    OP

    loco365 GBAtemp Guru

    Member
    5,458
    2,673
    Sep 1, 2010
    The port automatically turns off in sleep mode already. It's actually part of a multi-output port on my laptop. It comes with an adapter that connects to allow for ethernet and VGA out. When the computer is sleeping, there are no lights on to show communication. In addition, any applications that require use of the internet aren't updated until the computer next turns on. The port itself is dormant until a few moments after the computer is turned on as well - the laptop's display is on before the attached monitor even gets a video signal.

    That and WiFi doesn't run in sleep mode.
    The way my laptop is right now (That is, since it had Windows 10 installed), it's been running on an ethernet connection as to allow me to game online because the WiFi in the apartment is such a bottleneck. I don't have any issues with it installing updates, I just don't want it to be restarting itself without my express consent, and having it even on a scheduled time isn't the most friendly option. Plus, with me bring my laptop to school for assignments and whatnot, I don't want to have to remember to set all my WiFi APs as metered, in the event that I do forget one.
     
    Last edited by loco365, Aug 21, 2015
  5. loco365
    OP

    loco365 GBAtemp Guru

    Member
    5,458
    2,673
    Sep 1, 2010
    Thought I'd bump this up. I set a registry key (HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU\NoAutoRebootWithLoggedOnUsers) and set its value to 1, which should disable this feature, however, this morning my computer turned on and was rebooted, all my programs and documents closed. Has anyone found a way to go about this without having to use Windows 10 Pro or better?
     
  6. VinsCool

    VinsCool Insecure

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,508
    26,921
    Jan 7, 2014
    Canada
    Another World
    I use extended sleep mode, which takes a bit longer to wake up, but at least it doesn't automatically turn on, since it is "off" with saved ram to the drive.
     
  7. nastys

    nastys ナースティス

    Member
    1,465
    857
    Aug 5, 2014
    Italy
    Earth
    You could also disable the Windows Update service with services.msc.
     
  8. Joe88

    Joe88 [λ]

    Member
    11,540
    2,748
    Jan 6, 2008
    United States
    NYC
    It doing it on mine as well, I disabled all the stuff and it still wakes up
    as a temp fix I just set it to going into sleep mode after 1 min after no activity since it likes to wake up in the middle of the night

    it seems it is the windows update service, I saw it last checked for updates at a time I wasnt even using it, another thing that needs to be fixed, hopefully ships with threshold 2