WiiFlow Lite

Discussion in 'Wii - Backup Loaders' started by fledge68, Apr 11, 2016.

  1. xLAKITUx

    xLAKITUx Member

    Newcomer
    2
    Aug 19, 2011
    United States
    Ya know, I only tried the one, and it worked. I'm at work now. I'll test when I get home to see if they both play. I typically select Wii games via plugin select menu. (Pressing 'B' to bring up the menu, then selecting the Wii icon)
     
  2. Jochte

    Jochte Member

    Newcomer
    1
    Mar 7, 2017
    United States
    I have seen this happen too with wii games across many versions of wiiflow lite (via plugin source menu)-- where one random title/boxcover will out of the blue appear twice and remain that way. If the title is deleted, then returned to usb, and cache refreshed then the title displays normally. At a later date when cache is refreshed again another random title will show a double display. It only seems to happen once with one random title and at a random time *I think* when cache is refreshed.
     
    Last edited by Jochte, Dec 5, 2018
  3. fledge68
    OP

    fledge68 GBAtemp Maniac

    Member
    8
    Jan 30, 2012
    United States
    so a couple of things to try
    1. run wfl and select the first one. with the game selected press '+' on wiimote to bring up game info screen. note the game ID. now go back and select the other game and do the same. compare the two ID's. also the ID listed should be the title of the wbfs files in your wbfs folder.

    2. you said you only found one instance of the game in your wbfs folder. move that one folder with the wbfs file in it to somewhere else. now run wfl and reload cache. does the game still show up? if yes then you have another instance of that game. if not then that's very strange indeed but you can move the game back to the wbfs folder, run wfl, and reload cache and hopefully only one instance shows up this time.
     
  4. xLAKITUx

    xLAKITUx Member

    Newcomer
    2
    Aug 19, 2011
    United States
    I figured it out when I went home on my lunch break. It was an issue with duplicate folders. I had a good, full dump of the .wbfs file and a partial dump that was causing issues. That took care of the duplicate title.
     
    fledge68 likes this.
  5. pepobr

    pepobr Member

    Newcomer
    4
    Jun 21, 2007
    Brazil
    São Paulo
    Yes, soon after the animation he returns to the HBC.
     
  6. fledge68
    OP

    fledge68 GBAtemp Maniac

    Member
    8
    Jan 30, 2012
    United States
    is wiiflow lite on SD? if so edit wiiflow_lite.ini. under [DEBUG] set sd_write_log to yes
    now run wiiflow lite with force cios on and wfl should make wiiflow.log file on the root of your sd card. copy and paste it here it might tell me at what point wfl is failing.
     
    suspendedhatch likes this.
  7. pepobr

    pepobr Member

    Newcomer
    4
    Jun 21, 2007
    Brazil
    São Paulo
    Okay, I'll do it in a few moments, but first I'll bring you more information. I can make the loader run IF I run the games from my SD. in this case everything seems to work normally, but when I click on play the videogame reboots! I made the test with pimp my wii last version (3.03) and everything is normal, I repeat only the wiiflow does not work on my wii.
    the loader does not seem to work with the games on the pendrive, but when they are in SD I can change the partition options, for example I can choose USB1 for the wii games, but it appears that screen saying that it has not located any game. very strange. I'm going to take the test you asked for.
     
  8. obiwansith

    obiwansith Newbie

    Newcomer
    1
    Dec 5, 2018
    Chile
    Thanks, testing.
     
  9. pepobr

    pepobr Member

    Newcomer
    4
    Jun 21, 2007
    Brazil
    São Paulo
    here is what you asked me:

    Welcome to WiiFlow Lite 5.0.1!
    This is the debug output.
    Real Wii
    AHBPROT disabled = yes
    IOS58 v6176
    patched isfs_permissions 1 times.
    patched es_setuid 1 times.
    patched es_identify 1 times.
    patched hash_check 0 times.
    patched new_hash_check 1 times.
    Init ISFS
    Found WiiFlow Save
    Loading IOS Settings from wiiflow save
    FAT Partition at sd: mounted.
    using SD only, no need for USB mounting.
    Running sound thread
    Wiiflow boot.dol Location: sd:/apps/wiiflow_lite
    Data Directory: sd:/wiiflow
    Wii Games Directory: %s:/wbfs
    Nintendont found
    GameCube Games Directory: %s:/games
    Loading cIOS map
    Found cIOS in slot 222
    Found cIOS in slot 223
    Found cIOS in slot 224
    Found d2x base 56 in slot 249
    Found d2x base 57 in slot 250
    Found d2x base 58 in slot 251
    Setting Wii games partition to: 0
    Creating Gamelist
    Games found: 1
    Coverflow started!
    wiiflow main screen ready!
    Saving IOS Settings to wiiflow save
    Coverflow stopped!
    Cleanup Coverflow
    Stopping sound thread
    Stopped sound thread
    MEM1_freesize(): 10342384
    MEM2_freesize(): 42573824

    loader hangs on logo screen!
     
  10. pepobr

    pepobr Member

    Newcomer
    4
    Jun 21, 2007
    Brazil
    São Paulo
    I deleted the wbfs folder from the SD card (I only had 1 game in it) and put the pendrive (with 5 games). the wiiflow only recognizes the game that was in SD, the others that are in the pendrive are not listed. the wiiflow does not seem to save the option "SD only on/off" (page 11), because every time I enter this option it is YES. Whenever I try to play, the wiiflow hangs on the loading screen. new log:

    Welcome to WiiFlow Lite 5.0.1!
    This is the debug output.
    Real Wii
    AHBPROT disabled = yes
    IOS58 v6176
    patched isfs_permissions 1 times.
    patched es_setuid 1 times.
    patched es_identify 1 times.
    patched hash_check 0 times.
    patched new_hash_check 1 times.
    Init ISFS
    Found WiiFlow Save
    FAT Partition at sd: mounted.
    Changing USB port to port 0....
    * * * * * * * * * * * *
    * HDD Information
    * Sectors: 15794175
    * Size [Sector Size]: 7 GB [512]
    * * * * * * * * * * * *
    Running sound thread
    Wiiflow boot.dol Location: sd:/apps/wiiflow_lite
    Data Directory: sd:/wiiflow
    Wii Games Directory: %s:/wbfs
    Nintendont found
    GameCube Games Directory: %s:/games
    Loading cIOS map
    Found cIOS in slot 222
    Found cIOS in slot 223
    Found cIOS in slot 224
    Found d2x base 56 in slot 249
    Found d2x base 57 in slot 250
    Found d2x base 58 in slot 251
    Setting Wii games partition to: 0
    Creating Gamelist
    Games found: 1
    Coverflow started!
    wiiflow main screen ready!
    Cleanup Coverflow
    Coverflow stopped!
    Stopping sound thread
    Stopped sound thread
    MEM1_freesize(): 10342384
    MEM2_freesize(): 42031104
     
  11. pepobr

    pepobr Member

    Newcomer
    4
    Jun 21, 2007
    Brazil
    São Paulo
    Okay, I got an old HD and everything is working fine. it seems that the loader is not very compatible with pendrives. I would like to thank the support of fledge68 who was very patient and tried to help me in any way.
     
    fledge68 likes this.
  12. fledge68
    OP

    fledge68 GBAtemp Maniac

    Member
    8
    Jan 30, 2012
    United States
    the first one is fine. it never mounts the usb device because you have sd only set and need to change it to off. but i noticed you changed the cios settings in startup settings. don't understand why the reboot freezes on splash screen image and doesn't output anything to the log.

    the second one shows you are using IOS58 and it mounts the usb device. then the wii games partition is set to SD since thats what you had previously and 1 game found because its a cached list that needed to be reloaded. not sure why after wiiflow main screen ready! you didn't seem to do anything. why didn't you change the wii partition from SD to usb? sd only was not set otherwise wiiflow wouldn't have mounted the usb device.you seem to have just exited wiiflow.

    also when you change sd only to off you need to properly exit wiiflow lite by going to the home menu and pressing 'home' button on wiimote or exit to menu and selecting exit to system menu or hbc. when you do this the wiiflow lite.ini is updated for the next boot.
     
    pepobr likes this.
  13. pepobr

    pepobr Member

    Newcomer
    4
    Jun 21, 2007
    Brazil
    São Paulo
    One last thing, I also tested a microSD with USB adapter and it worked perfectly. who does not want to use an HD, that would be the only option.
     
  14. Brawl345

    Brawl345 GBAtemp Advanced Fan

    Member
    7
    Jan 14, 2012
    Germany
    The WiiTDB.xml seems to always use the english language, but I want my game titles to be shown in German - how can I change this?
     
  15. jamallego

    jamallego Member

    Newcomer
    2
    Sep 10, 2014
    Colombia
    hi everyone, first of all thank you very much fledge68 for keeping these loader update.....its awesome!!

    i want to know if the game "Adventures of tintin" works ok for some of you, i play it and freezes after completing a level or a cinematic.......

    i read in these forum a solution but requires Sneek: https://gbatemp.net/threads/the-adventures-of-tintin-the-secret-of-the-unicorn-freezes.311809/

    Just wanna know if there is a way to play it using the loaders.....i have the most recent wiiflow lite and usbloader gx, on both i get a freeze screen, play from a external USB, try it on IOS 249 and 250
     
  16. fledge68
    OP

    fledge68 GBAtemp Maniac

    Member
    8
    Jan 30, 2012
    United States
    so the gametdb language code is taken from the current language file you have wiiflow (lite) set to. so in order for your titles to be in german your wiiflow (lite) language must be german. and to switch to german means you must have german.ini in dev:/wiiflow/languages/.
    i do see a minor problem. if you change wiiflows language it may not change your titles even after reload cache. you will need to properly exit wiiflow for it to update wiiflow_lite.ini and reboot wiiflow lite and do a reload cache. at least until i fix it in the next commit.
     
    Brawl345 and Tetsuo Shima like this.
  17. JustMeDaFaq

    JustMeDaFaq Member

    Newcomer
    3
    Apr 17, 2017
    Germany
    Hi,
    first, thanks for your work.

    When i used wiiflow back in the days, there where reflections of the game boxes on the bottom. Is it a bug that they are missing now or intended? (Attached a screenshot)
     

    Attached Files:

  18. fledge68
    OP

    fledge68 GBAtemp Maniac

    Member
    8
    Jan 30, 2012
    United States
    intended. you can easily add them back in by selecting adjust coverflow. there should be mirror and alpha options.

    @Brawl345 @Tetsuo Shima so i tried changing wiiflow language and for me it doesn't change the titles. then i looked in wiitdb.xml and 90% of the game titles are in english regardless of the language selected. especially for ntsc-u games. i did notice that japan and chinese are different and while they showed different titles in wiiflow it wasnt correct. it was mainly (o) 0 or stuff like that. not sure how to make japanese and chinese characters show up. anyway, can you guys confirm that changing wiiflow language, exiting wiiflow, restart it, and reload cache works?
     
  19. JustMeDaFaq

    JustMeDaFaq Member

    Newcomer
    3
    Apr 17, 2017
    Germany
    Can only get the title mirror to work. Under Mirror Effect, "Title intensity", tho normal "intensity" value does nothing
     
  20. Brawl345

    Brawl345 GBAtemp Advanced Fan

    Member
    7
    Jan 14, 2012
    Germany
    That did the trick, thanks! Changed the language to german, restarted and reloaded the cache -> titles are shown in German!

    The XML lists every language, I have PAL games obviously so they have multiple titles. E.g. Mario & Sonic at the olympic games -> Mario & Sonic bei den olympischen Spielen

    EDIT: I've made a pull request for an updated German translation! Will try to keep it updated in the future if more strings are added/changed.
     
    Last edited by Brawl345, Dec 9, 2018
    fledge68 likes this.
Loading...