Wiiflow Help with rom separation/Source Menu.

Discussion in 'Wii - Backup Loaders' started by FurryShep, Nov 24, 2014.

  1. FurryShep
    OP

    FurryShep Newbie

    Newcomer
    2
    0
    Nov 24, 2014
    United States
    Hey there~

    I am an experienced Wii softmod enduser and just recently started to use Wiiflow and I am in love with all its nice features, so much that I even set it up to boot right into it!
    But I have been having issues with rom separation on the custom source menu.
    I swear I've read everything on it several times and still nothing so here we are.

    Trying to get separate menu's for GBA, GB, GBC games all using the source menu and vba-gx.
    The emuflow/roms just wont show up, every time I try it says "no plugins found" then (select partition).
    I've tried clearing the cache several times as well, that doesnt help.

    Here's what I'm running:
    Wiiflow latest version
    The advanced custom source menu pack by Mastershoes
    Custom Theme Carbonik Ab2 (turning it off didnt help)

    Here's my plugin files in root:/wiiflow/plugins

    vbagx_gb.ini
    __________
    [PLUGIN]
    magic=56424158 //Gameboy
    coverColor=fcff00
    coverFolder=GB
    fileTypes=.zip
    romDir=vbagx/GB
    dolFile=vbagx-mod9.dol
    bannerSound=gba.ogg
    displayname=Gameboy Classic
    ReturnLoader=yes
    consoleCoverID=nintendo


    vbagx_gba.ini
    __________
    [PLUGIN]
    magic=56424178 //Gameboy Advanced
    coverColor=fcff00
    coverFolder=GBA
    fileTypes=.zip
    romDir=vbagx/GBA
    dolFile=vbagx-mod9.dol
    bannerSound=gba.ogg
    displayname=Gameboy Advance
    ReturnLoader=yes
    consoleCoverID=nintendo


    vbagx_gbc.ini
    __________
    [PLUGIN]
    magic=56424168 //Gameboy Color
    coverColor=fcff00
    coverFolder=GBC
    fileTypes=.zip
    romDir=vbagx/GBC
    dolFile=vbagx-mod9.dol
    bannerSound=gba.ogg
    displayname=Gameboy Color
    ReturnLoader=yes
    consoleCoverID=nintendo


    And here's my source_menu.ini (relevant sections)
    __________
    [BUTTON_8]
    image=GB.png
    image_s=GBb.png
    source=plugin
    magic=56424158
    emuflow=6

    [BUTTON_9]
    image=GBC.png
    image_s=GBCb.png
    source=plugin
    magic=56424168
    emuflow=6

    [BUTTON_10]
    image=GBA.png
    image_s=GBAb.png
    source=plugin
    magic=56424178
    emuflow=6


    Also if it helps the .dol is here:
    root:/apps/vbagx/boot.dol


    Thanks for any help! :)


    Also if anyone could help me figure out how to get covers working for custom NAND channels (Like installed wad channel forwarders) that'd be nice. :D
     
  2. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,520
    Jan 14, 2012
    Ideas factory :)
  3. FurryShep
    OP

    FurryShep Newbie

    Newcomer
    2
    0
    Nov 24, 2014
    United States
    Thanks I went ahead and used your master pack as a base with the plugins and the source_menu.ini and I finally got it working.
    Main reason why I didnt do this in the first place was the bulkiness of the pack, with so many different hombrew apps and stuff in it.

    I wonder if it was the covers that tripped me up...

    Anyway, thanks again! :)

    Now if only I could figure out how to get the missing covers for my nand channels like Project M and WAD Manager.
     
  4. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,520
    Jan 14, 2012
    Ideas factory :)
    download them via settings > manage covers
    in case some still missing you can add them manually to wiiflow/boxcovers folder using the ID4
     
  5. ymx28

    ymx28 Newbie

    Newcomer
    1
    0
    Sep 2, 2016
    Gambia, The
    same probleme here! kind of..

    I have also used your Pack as a basis. Only wanted to be able to switch between different emulators in WiiFlow. All that works, but when I am in the N64 menu for example, I see all the roms from my SD card, not only .v64 files.

    Why is that so and what can I do!?
     
    Last edited by ymx28, Sep 2, 2016