Why can't update a R4i v1.4 card even on an older DSi?

Discussion in 'NDS - Flashcarts and Accessories' started by ItsJustMe, Dec 10, 2016.

  1. ItsJustMe
    OP

    ItsJustMe Member

    Newcomer
    20
    0
    Dec 10, 2016
    Hello everyone, I just registered here after finding this website come up alot in my Google searches to try and solve my problem, hopefully by making this thread someone here knows why I'm not being able to upgrade the card.


    So I just bought a 2nd hand DSi that came with this R4i card (the one that just says v1.4 without the WiFi logo):

    [​IMG]


    From what I can tell this is a legit card, with Truth Inquiry label.


    This being all new to me, and me being stupid, I updated the Firmware on my DSi to 1.4.5E and ofcourse the card stopped working. I searched online alot and from what I could gather I should be able to update the card to a newer Firmware and Kernel to work on a 1.4.5E DSi, so I borrowed an Old DSi with version 1.3E, put the updated files I got from the Official Website ( http://r4i-sdhc.com/downloade.asp ) in it.

    So the card works on the old DSi, I can boot R4i (shows up as a Star Wars Lethal Alliance), and boot roms, but when I go to the upgrade Screen instead of getting this:

    [​IMG]


    I only get a screen that shows the Current version as "Support Model: NDSL, NDSI 1.40", there's no New Version, Info or Upgrade Button displayed, and I've checked the flash file is present.


    If I try to use the Wi-Fi engine icon some times it fails to connect, and when it connects it fails to request login to server with the error "Erro code: -1071"


    I already tried download older versions of Kernel/Firmware (R4i V1.42b, V1.67b) I found online but all have the same behavior, no upgrade button is displayed.


    Does anyone know why this is happening? Should I be able to upgrade using a DSi with an old firmware?


    Thanks in advance.
     
  2. how_do_i_do_that

    how_do_i_do_that Blue Wizard is about to die.

    Member
    4,953
    270
    May 16, 2008
    Antarctica
    You have insufficient posts to view user location.
    Depending on the clone a person has, the website associated with the upgrade function tends to be dead and deleted. Meaning that upgrade button is a source for fake hope to get your flashcart updated.

    For other clones that still have a website available, the flashcart tends to not be upgradeable. The upgrade button for your flashcart is for the system menu update rather than the firmware to the flashcart so that it can run on an updated handheld firmware.


    ---

    As for R4 clones, someone said that DS flashcarts are no longer blacklisted on a 3DS because nintendo is more focused on the Gateway and Sky3DS flashcarts instead. That means that the R4 clones don't need to upgrade the firmware to work on an older handheld like the DSi or DS.
     
    Last edited by how_do_i_do_that, Dec 10, 2016
  3. ItsJustMe
    OP

    ItsJustMe Member

    Newcomer
    20
    0
    Dec 10, 2016
    I'm not sure I follow. The website is up and running and it's where I'm downloading the files from.
     
  4. how_do_i_do_that

    how_do_i_do_that Blue Wizard is about to die.

    Member
    4,953
    270
    May 16, 2008
    Antarctica
    You have insufficient posts to view user location.
    As for R4 clones, someone said that DS flashcarts are no longer blacklisted on a 3DS because nintendo is more focused on the Gateway and Sky3DS flashcarts instead. That means that the R4 clones don't need to upgrade the firmware to work on an older handheld like the DSi or DS.
     
  5. ItsJustMe
    OP

    ItsJustMe Member

    Newcomer
    20
    0
    Dec 10, 2016
    This one is definetly for Firmware upgrade of the Flashcard as I was able to upgrade using LightShell's from this very own forum ( https://gbatemp.net/threads/lightshells-utilities.450174/ ) to patch the Flash file and the update button appeared now. Problem is it's now saying Support Model: NDSL, NDSI 1.44, 3DS 4.4 but not 1.45 (or 1.4.5, i'm assuming it's the same).

    I posted in his thread hopefully he'll reply there.
     
    Last edited by ItsJustMe, Dec 10, 2016
  6. how_do_i_do_that

    how_do_i_do_that Blue Wizard is about to die.

    Member
    4,953
    270
    May 16, 2008
    Antarctica
    You have insufficient posts to view user location.
    Opinion: I believe the site release an update but not update the update-me-file on the site to reflect that there is an update. So the cart basically doesn't see any new update.

    I personally just recommend that you just buy a DS flashcart that already supports the DSi 1.4.5 firmware. Less hassle considering that the DSi is an EOL (End of Life) product now. The eshop for the DSi closes next year.
     
    Last edited by how_do_i_do_that, Dec 10, 2016
  7. LightShell

    LightShell GBAtemp Regular

    Member
    124
    13
    Nov 20, 2016
    fat1:/lightshell
    no they include firmware for r4i but they use newer update for the r4i 3ds rts so the older cards dont get updates, his card is not supposed to be 1.4.4 compatible because it got old firmware so he needs to get new firmware upgrade for r4 if his r4 can handle it.
     
  8. how_do_i_do_that

    how_do_i_do_that Blue Wizard is about to die.

    Member
    4,953
    270
    May 16, 2008
    Antarctica
    You have insufficient posts to view user location.
    At least it isn't like the timebomb coded R4 dual core crap.

    Totally forgot about the "you get one system update, then you have to buy a new one" tactic.
     
    Last edited by how_do_i_do_that, Dec 11, 2016