What PS Vita games will require 3.61+?

Discussion in 'PS Vita - Games & Content' started by Stephano, Nov 27, 2016.

  1. Stephano
    OP

    Stephano I love you Charlie

    Member
    1,472
    1,334
    Feb 18, 2016
    United States
    An anti-anime bunker
    I know several people are upset that Stein's Gate 0 require 3.61+ software and that got me thinking as well as worried. Will all future games require 3.61+ firmware? I say this because i'm looking forward to several games like shantae but i don't want to loose Henkaku. Any thoughts?
     
  2. TheKawaiiDesu

    TheKawaiiDesu Ball of Kawaiiness

    Member
    1,436
    1,513
    Aug 23, 2015
    Korea, North
    Lowee
    Well, at this point, we can be pretty sure that any future game will require 3.61+.
    The real question is "will we ever be able to play 3.61+ games on 3.60?", and the answer is "maybe someday".
     
  3. GuyInDogSuit

    GuyInDogSuit Your friendly neighborhood guy in a dog suit.

    Member
    1,400
    311
    Aug 1, 2008
    United States
    Antelope, CA
    At least in the case of some of those games, they're ported to PC or PS3/4 as well. So it's not totally hopeless.
     
  4. Chrisser_75

    Chrisser_75 GBAtemp Regular

    Member
    264
    108
    Dec 12, 2014
    Germany
    Germany
  5. Gnarmagon

    Gnarmagon Noob <3

    Member
    588
    116
    Dec 12, 2016
    Germany
    everything released after December 2016 ? (Shantae Half Genie Hero was one of the first ?)
    but you don't have to care about it, there are already to many games below 3.60
     
  6. NiMR0D9TIN85

    NiMR0D9TIN85 Advanced Member

    Newcomer
    81
    7
    Nov 10, 2014
    Saudi Arabia
    Saudi Arabia
    Hi guys I have a question, if we updated the game like NoNpDrm games , can we back it up using QCMA to our PC and delete the game from PS Vita and if I wanted to play it again just connect my vita and transfer it from PC to PS Vita again, will it still work? thanks in advance
     
  7. nazomeku

    nazomeku Member

    Newcomer
    13
    3
    Mar 21, 2018
    United States
    I'm hoping P3D and P5D don't require the newer firmware. I'm already going to buy the PS4 versions, just want the Vita ones for convenience.
     
  8. Chrisser_75

    Chrisser_75 GBAtemp Regular

    Member
    264
    108
    Dec 12, 2014
    Germany
    Germany
    i think Oceanhorn needs a 3.61+ firmware
     
Loading...