1. PewnyPL

    OP PewnyPL GBAtemp Advanced Fan
    Member

    Joined:
    Feb 2, 2014
    Messages:
    703
    Country:
    Poland
    I bought the following adapter: https://allegro.pl/oferta/adapter-sieciowy-lan-usb-do-nintendo-switch-8309481367 (the site is in polish sadly), it's marketed as an adapter for the Switch and the box it came from (manufacturer is called "Honson") claims it works with Switch, Wii U and Wii.
    Now onto the actual problem. The adapter, when connected to the side ports of the Dock, is not recognized at all, Switch doesn't show the MAC address, the light on the router doesn't light up for cable connection, etc, and obviously I'm gettiing the 2110-1100 error, that the adapter may be connected incorrectly.
    The interesting part however is, when I connect it to the rear port (the USB3.0 one) of the Dock, the adapter is recognized and the MAC address is reported (it's 00-0E-C6-E4-6E-55 in case anyone wants to confirm chipset manufacturer and such). When I try to connect however, I get the error 2110-2963 Unable to obtain IP address. Looking at the router, there is some very brief network activity.
    Thinking that perhaps something is wrong with my Dock, I tried both my Wii U and Wii (the box does claim they are compatible) and neither of those consoles recognize the adapter at all, Wii U acts like if it's not connected, Wii can't do the connection test either and in both cases there is no light on the router indicating the cable is connected.
    As a last test I connected the adapter to my laptop, it connected to the network immediately, and it reports as follows: "ASIX AX88179 USB 3.0 to Gigabit Ethernet Adapter" and with USB\VID_0B95&PID_1790\000EC6E46E55 which as far as I can google up, would mean it's an AX88179 chipset.

    Does anyone know what may be the problem? Is my dock faulty? Is it the adapter? Sadly I don't have an USB-C to USB-A adapter to try connecting it to the Switch in handheld mode.

    EDIT: Well, I messed around with it some more. I managed to get an USB-C OTG adapter, and I tested the LAN adapter with my phone first (works perfectly) then connected it to the Switch, but still got the exact same error. I also noticed that the side ports DO work, just... only if I don't put the plug in fully (if there's like, 1mm gap it powers on and is detected), but alas, despite being detected, the connection error still happens.
    I also did try to put in IP manually, but that just changed the error message to 2110-3127 Could not connect to the internet. Could not perform DNS name resolution.
     
    Last edited by PewnyPL, Nov 22, 2019
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - adapter, problem, Weird