Weird Issue W/ A9lh and Gateway

Discussion in '3DS - Flashcards & Custom Firmwares' started by veraci_00, Jun 13, 2016.

  1. veraci_00
    OP

    veraci_00 GBAtemp Fan

    Member
    408
    33
    Mar 6, 2016
    United States
    I just updated a9lh to version 2, but now Gateway doesn't work anymore. I have Gateway chain loading with down, but I just get a black screen. whenever I try to put the payload on the root to run by default, the system powers on then off instantly. I don't know what's going on.
     
  2. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    Did you use a screen init arm9loaderhax payload?
     
  3. veraci_00
    OP

    veraci_00 GBAtemp Fan

    Member
    408
    33
    Mar 6, 2016
    United States
    I did, yes.
     
  4. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    Have you tried deleting luma3ds config.bin?

    — Posts automatically merged - Please don't double post! —

    In the Luma folder
     
  5. veraci_00
    OP

    veraci_00 GBAtemp Fan

    Member
    408
    33
    Mar 6, 2016
    United States
    just tried that. it didn't work.
     
  6. Kyojin

    Kyojin #include "brain.h"

    Member
    467
    232
    Sep 7, 2015
    France
    It is a known issue, you'll have to wait until Gateway releases a new payload, or someone releases something unofficial like it was done before Gateway provided their official payload.
     
    astronautlevel likes this.
  7. astronautlevel

    astronautlevel Finding a reason, waiting for a miracle

    Member
    4,044
    5,090
    Jan 26, 2016
    United States
    That Nightly Siteā„¢
    You can also switch to a9lh "v1" which works with GW.
     
    Kyojin likes this.
  8. angelus kun

    angelus kun GBAtemp Fan

    Member
    348
    87
    Aug 7, 2015
    Mexico
    in my dreams
    Just go back to V1 like me c:
     
  9. veraci_00
    OP

    veraci_00 GBAtemp Fan

    Member
    408
    33
    Mar 6, 2016
    United States
    how do I downgrade?
     
  10. angelus kun

    angelus kun GBAtemp Fan

    Member
    348
    87
    Aug 7, 2015
    Mexico
    in my dreams
    You don"t need to downgrade just reinstall A9LH with your old files
     
  11. veraci_00
    OP

    veraci_00 GBAtemp Fan

    Member
    408
    33
    Mar 6, 2016
    United States
    how do u mean? with safe installer? it says that if u use v1's file with safeinstaller v2, u'll brick.
     
  12. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,818
    1,114
    May 31, 2013
    Belarus
    Caves
    Current Gateway payload is not compatible with V2 A9lh, as it's already confirmed. You have to downgrade back to V1 use this https://github.com/d0k3/SafeA9LHInstaller/releases/tag/v1.5.2mod2 and make sure you use the older payloads and not V2 ones.

    It's mentioned here:

    http://gbatemp.net/threads/the-status-of-gateway-and-a9lh.427889/page-71
     
  13. veraci_00
    OP

    veraci_00 GBAtemp Fan

    Member
    408
    33
    Mar 6, 2016
    United States
    what I'm confused by is do I need to downgrade to 9.2? some say yes, others say no.

    — Posts automatically merged - Please don't double post! —

    can I just reflash the a9lh nand backup and I'll be on version 1 again? it was made while on v1.
     
  14. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,501
    5,464
    Mar 17, 2010
    Norway
    Alola
    I saw someone suggesting you need to uninstall V2, and then reinstall V1 (which requires being on 9.2), as according to them, the key2 that is changed in the V2 update is not changed back when you install V1.
    I wouldn't try to reinstall V1 over V2 directly until you are sure it'll work, or you might end up with a brick.
    If you have a backup from V1, you can flash that with Decrypt9 (don't select Keep A9LH) and you'll be back on V1.
     
  15. Redferne

    Redferne GBAtemp Advanced Fan

    Member
    773
    258
    Oct 28, 2015
    If you use the right installer and files you can go back to V1 and chainload GW with Luma (or directly or another boot manager).
     
  16. juan_3579

    juan_3579 GBAtemp Regular

    Member
    101
    18
    Jun 25, 2015
    United States
    Do we have to uninstall v2 before reflashing an old nand dump to move to v1 a9lh? I didn't do that yesterday and everything seems fine, but seeing this makes me a little concerned.
     
  17. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,501
    5,464
    Mar 17, 2010
    Norway
    Alola
    Flashing a NAND dump without the Keep A9LH option overwrites everything.
     
    juan_3579 likes this.
  18. veraci_00
    OP

    veraci_00 GBAtemp Fan

    Member
    408
    33
    Mar 6, 2016
    United States
    that is what I did. all seems to be working again. :)