Warioware DIY fat error issue

Discussion in 'Acekard' started by warpio, Sep 17, 2014.

  1. warpio
    OP

    warpio Member

    Newcomer
    12
    1
    Dec 22, 2008
    Canada
    I'm not sure what I'm missing here. I have Acekard 2.1, with SDHC card, and with akaio 1.9 installed on it, and Warioware D.I.Y. is the only game that doesn't work. Whenever I load it, I get the "FAT error" message. All other games work fine, so it can't be a defective card, right?

    The wiki suggested trying all of the other DMA modes, but I tried that and it doesn't seem to work. I'm confused about this and wondering if I'm doing something wrong. It says immediately after pressing A to launch the game, then you hold either X or A and the "Loading" text should be either green or red instead of the default yellow. However, when I try this, the text is always yellow. It seems like this option to change DMA mode isn't even available anymore in the latest firmware?

    Other than that, I am all out of ideas. Can anyone confirm that Warioware DIY does in fact work on Acekard 2.1 with the latest firmware?
     
  2. warpio
    OP

    warpio Member

    Newcomer
    12
    1
    Dec 22, 2008
    Canada
    I've just noticed that the sav file it generates for Warioware DIY is 32MB, which is twice the size of the rom itself... that can't be right. Save files are supposed to be like 512kb... what is going on here?

    Edit: I fixed it just now, by going into Rom settings, and changing the save type to 32M. It was set to 256M before, which is probably why it didn't work
     
  3. orochi115

    orochi115 GBAtemp Regular

    Member
    150
    50
    Jun 8, 2013
    Switzerland
    You're totally wrong. 256Mb is the correct save size for this game. However any value above 64Mb will cause "FAT Error" in AKAIO. I think it's a bug of AKAIO, because "FAT Error" is displayed by firmware patch instead of game itself.
    I'm still looking for a solution for it now.