Waninkoko's 4.1 SM updater

Discussion in 'Wii - Hacking' started by kwirky, Jul 16, 2009.

Jul 16, 2009

Waninkoko's 4.1 SM updater by kwirky at 11:11 PM (53,919 Views / 0 Likes) 141 replies

  1. kwirky
    OP

    Newcomer kwirky Advanced Member

    Joined:
    Mar 14, 2009
    Messages:
    69
    Country:
    United States
    It updates the system menu 4.1 only so it is safe to install. I test it on my 4.0U Wii. Wii sports resorts works after I play a Wiiware from SD card.

    http://www.teknoconsolas.es/blogs/waninkoko

    +--------------------------------+
    | [+] Firmware Updater v4.1 |
    | developed by Waninkoko |
    +--------------------------------+
    | www.teknoconsolas.es |
    +--------------------------------+


    [ DISCLAIMER ]:

    - THIS APPLICATION COMES WITH NO WARRANTY AT ALL, NEITHER EXPRESS NOR IMPLIED.
    I DO NOT TAKE ANY RESPONSIBILITY FOR ANY DAMAGE IN YOUR WII CONSOLE
    BECAUSE OF A IMPROPER USAGE OF THIS SOFTWARE.


    [ DESCRIPTION ]:

    - This application allows you to update your console's firmware, installing *only* the
    most important updates (System IOS, System Menu, new channels...).

    Thanks to this you can keep some features like Trucha bug that affected first IOS
    versions.


    [ REQUISITES ]:

    - 150-250 free blocks.
    - Internet connection.


    [ HOW TO USE ]:

    - Run the application with any method to load homebrew and the update will be done
    automatically.


    [ KUDOS ]:

    - Team Twiizers
    - devkitPRO Team
    - frontier
    - All my betatesters.
     


  2. djricekcn

    Member djricekcn GBAtemp Advanced Fan

    Joined:
    May 29, 2009
    Messages:
    792
    Country:
    United States
    So, if you have a softmooded Wii use this?
     
  3. vergilite

    Member vergilite GBATemps Regular Clown

    Joined:
    Apr 14, 2009
    Messages:
    737
    Location:
    Liv-Liv-Liverpool YEAH!
    Country:
    United Kingdom
    id still wait a wile to see if any horror stories emerge about this updater (wanikoko might be all powerful along with team twiizers ect but mistakes can happen and i don't want a lovely white paper weight)
     
  4. MillionsKnives

    Member MillionsKnives GBAtemp Regular

    Joined:
    Jun 26, 2006
    Messages:
    156
    Country:
    United States
    I'm a little skeptical to try this as I am still on 3.2u firmware. Would be nice if it worked... I've been meaning to upgrade.
     
  5. vergilite

    Member vergilite GBATemps Regular Clown

    Joined:
    Apr 14, 2009
    Messages:
    737
    Location:
    Liv-Liv-Liverpool YEAH!
    Country:
    United Kingdom
    you should [​IMG] (update that is) use the ultimate 4.0 guide on these forums to update to 4.0 if you follow all the instructions you should be fine [​IMG] (bootmii wouldn't hurt)
    and then when needed update to 4.1 ect
     
  6. SanGor

    Member SanGor Witchhunter

    Joined:
    Aug 21, 2008
    Messages:
    993
    Country:
    United States
    just download IO60 and system menu 4.1 with NUSDownloader and install it with any wadinstaller.
    Can't be more simple than this, no need for some extra app for each system menu version ...
     
  7. WiiBlaster

    Member WiiBlaster GBAtemp Maniac

    Joined:
    Nov 23, 2008
    Messages:
    1,189
    Country:
    United States
    Also if you already had a patched IOS60 on the 4.0 a 4.1 update doesn't overwrite it, so you'll still have a trucha IOS60 installed anyways.

    edit: At least this was true for me. when i updated officially

    I prefer updating by hand, or officially. over any other method anyways
     
  8. s3phir0th115

    Member s3phir0th115 GBAtemp Advanced Fan

    Joined:
    Dec 31, 2008
    Messages:
    700
    Country:
    United States
    This.

    And I still think you can stay on 3.2 and be fine with homebrew. When waninkoko's cIOS rev14 is out, there will be no reason at all to update anymore, as the nand emulator would obsolete Nintendo's sd feature.
     
  9. Tux'

    Member Tux' GBAtemp Advanced Fan

    Joined:
    Feb 8, 2009
    Messages:
    723
    Location:
    The flat lands.
    Country:
    Canada

    Exactly. I'd wait for Wanin to release rev 14 before updating. That's what I'm doing because I don't have WSR.
     
  10. FPSDars

    Newcomer FPSDars Member

    Joined:
    Mar 15, 2009
    Messages:
    29
    Country:
    United States
    Well, I decided to use this to update, no problems so far. Everything's working after updating. Only downside is I lost my custom System Menu theme, but oh well.
     
  11. srcdecay

    Newcomer srcdecay Member

    Joined:
    May 31, 2009
    Messages:
    18
    Country:
    United States
    will updating affect preloader and bootmii?
     
  12. WiiBlaster

    Member WiiBlaster GBAtemp Maniac

    Joined:
    Nov 23, 2008
    Messages:
    1,189
    Country:
    United States
    not bootmii, but it will effect the preloader hacks, This should be a given
     
  13. 9th_Sage

    Member 9th_Sage GBAtemp Maniac

    Joined:
    Apr 30, 2008
    Messages:
    1,481
    Country:
    United States
    That's what I was just thinking...why bother with this when you can just get the System Menu via NUSDownloader and install it that way? It's faster even since the Wii doesn't have to download the menu itself.
     
  14. PrimeTime 84

    Newcomer PrimeTime 84 Advanced Member

    Joined:
    Nov 6, 2008
    Messages:
    96
    Country:
    Brazil
    The hacks goes down, but Preloader continue to work? [​IMG]
     
  15. djricekcn

    Member djricekcn GBAtemp Advanced Fan

    Joined:
    May 29, 2009
    Messages:
    792
    Country:
    United States
    Is this what I need to use the shop channel? I'm on 4.0j on a Wii J console.
     
  16. s3phir0th115

    Member s3phir0th115 GBAtemp Advanced Fan

    Joined:
    Dec 31, 2008
    Messages:
    700
    Country:
    United States
    The dependencies of programs are not system menu's as you may think. They need IOS's.

    I can run the newest shop channel on 3.2 as long as I have the IOS it needs installed.

    To fully answer your question, the newest shop channel requires IOS61 to be installed to function. I have tried modifying it to just use the custom IOS, or even modifying IOS61 to be trucha patched, and it doesn't work. So just a clean IOS61 with a clean shop channel work fine.

    (If anyone knows how to make the shop channel work with a patched IOS61, or how to make it run on the cIOS without Error 002, let me know if you don't mind.)
     
  17. SifJar

    Member SifJar Not a pirate

    Joined:
    Apr 4, 2009
    Messages:
    6,022
    Country:
    United Kingdom
    this is completely pointless. the only title that changed in this update is the system menu. no IOS where touched, so if you have 4.0 with trucha IOS, just hit the update button in wii settings. then you definetly wont brick unless you lose power and you can still use any homebrew.
     
  18. s3phir0th115

    Member s3phir0th115 GBAtemp Advanced Fan

    Joined:
    Dec 31, 2008
    Messages:
    700
    Country:
    United States
    You do know that Nintendo updates your IOS's too? Not just your system menu?

    That's exactly why some people have the Nintendo updater thing saying they're out of date when they used Waninkoko's 4.0 updater.
     
  19. Arm the Homeless

    Member Arm the Homeless Custom Title

    Joined:
    May 26, 2008
    Messages:
    1,762
    Location:
    /home/andy/
    Country:
    United States
    Preloader is erased from the system (it IS part of the system menu).

    You have to reinstall it for it to "continue to work".
     
  20. pm_41

    Member pm_41 GBAtemp Regular

    Joined:
    Jul 1, 2009
    Messages:
    204
    Location:
    Lurking in my Wii's NAND
    Country:
    United States
    Thanks! Installing it now. [​IMG]
     

Share This Page