Version 2.0b1

Discussion in '3DS - Flashcards & Custom Firmwares' started by mathew1971, Jan 15, 2014.

  1. mathew1971
    OP

    mathew1971 Member

    Newcomer
    21
    3
    Oct 13, 2008
    From what has been written regarding bricks with gateway am i correct in thinking that the safest way for gateway users to prevent the possibility of a brick is to revert back to Version 2.0b1 for now until gateway put out a new upgrade without the malicious code?

     
  2. Arras

    Arras GBAtemp Guru

    Member
    5,878
    2,711
    Sep 14, 2010
    Netherlands
    As long as you use the official launchers from the Gateway site any version is fine. While the latest version does have bricking code, it can't be triggered unless the file is modified in a special way.
     
  3. Steena

    Steena GBAtemp Advanced Fan

    Member
    561
    272
    Sep 13, 2009
    Italy
    I don't want to be the doom prophecy guy, but others (more knowledgeable) also pointed out that there is always a very, very remote possibility of the first checks passing and eventual errors coming up after those safety checks, which would make it trigger the brick. I think that if you aren't using specific 2.0b2 features, it's simply better to be on 2.0b1 or older versions for the time being. But I guess the chances of it happening are so low that it's a matter of preference.
     
  4. Cyberdrive

    Cyberdrive GBAtemp Regular

    Member
    134
    27
    Aug 6, 2013
    Serbia, Republic of
  5. Arras

    Arras GBAtemp Guru

    Member
    5,878
    2,711
    Sep 14, 2010
    Netherlands
    Honestly the chances of a meteor dropping on top of your head in about 5 minutes are probably the same as that, maybe with the exception of using it near an exploded nuclear power plant or something equally silly.
     
    cearp and Keylogger like this.
  6. mathew1971
    OP

    mathew1971 Member

    Newcomer
    21
    3
    Oct 13, 2008
    I assume to revert to Version 2.0b1 i just do the same as when i installed Version 2.0b2 again but obviously with the Version 2.0b1 installer etc?
     
  7. mathew1971
    OP

    mathew1971 Member

    Newcomer
    21
    3
    Oct 13, 2008
    So its just launcher.dat that i need to change to be back on Version 2.0b1?
     
  8. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    3,237
    667
    Oct 22, 2011
    Gambia, The
    Yep.
     
  9. Huntereb

    Huntereb GBAtemp Addict

    Member
    2,748
    949
    Sep 1, 2013
    United States
    Better safe than sorry, you're making a good choice mathew1971.
     
  10. Tomobobo

    Tomobobo Champion.

    Member
    1,003
    87
    Nov 26, 2005
    United States
    Don't listen to these fearful, unfounded comments.

    So far no one using the gateway card with the newest gateway software has suffered any injury.
     
  11. mathew1971
    OP

    mathew1971 Member

    Newcomer
    21
    3
    Oct 13, 2008
    Changed launcher.dat - for now - i know its very unlikely to happen but rather be safe than sorry - lets just hope Gateway come up trumps with 2.0 final!
     
  12. CIH137

    CIH137 GBAtemp Regular

    Member
    148
    13
    Dec 9, 2013
    United States
    You could always try to find the brick code and modify it but that is by far the WORST idea.
     
  13. Huntereb

    Huntereb GBAtemp Addict

    Member
    2,748
    949
    Sep 1, 2013
    United States

    Then why bring it up? :D
     
  14. MrOldboy

    MrOldboy Advanced Member

    Newcomer
    77
    4
    May 7, 2009
    United States
    Does anyone have a link to 1b? I haven't received my GW card yet so I never downloaded any FW at all.
     
  15. Saturosias

    Saturosias Sakura-sō Resident

    Member
    594
    290
    Dec 27, 2010
    United States
    Linking to the launchers is not allowed on GBAtemp, Google is your friend.
     
  16. Ryft

    Ryft GBAtemp Advanced Fan

    Member
    546
    188
    Nov 21, 2013
    United States
    Illinois

    Find the link for the latest firmware and change the version number in the url to whatever one you want.
     
  17. CIH137

    CIH137 GBAtemp Regular

    Member
    148
    13
    Dec 9, 2013
    United States

    Well someone is gonna have to do it if r4 wants to keep up with gateway
     
  18. Huntereb

    Huntereb GBAtemp Addict

    Member
    2,748
    949
    Sep 1, 2013
    United States

    ...Or do their own work, which I'd love to see, but am doubtful of weather or not we actually will see it.
     
    CIH137 likes this.
  19. mathew1971
    OP

    mathew1971 Member

    Newcomer
    21
    3
    Oct 13, 2008
    With the report on here today from un-modded Gateway user getting a brick with b2 launcher.dat - it must make common sense for all gateway users to change to b1 for now until we get some clarity on the problem.
     
  20. liquidsolidyetboth

    liquidsolidyetboth Advanced Member

    Newcomer
    52
    6
    Dec 6, 2013
    United States
    Los Angeles
    Do we need to format the emunand to revert back to b1 ? or just change launcher.dat for b1 and done ?

    After read thru TONs of comment on like 4-5 threads i have decided to revert back to b1 as well. Its just bs that they have to put kill code that would also endanger bricking legit gateway carts, maybe they gone paranoid but this is why all modding/homebrew/carts scene suck they all behave like little children