USB Loader GX

By cyrex, Apr 19, 2009 6,147,339 27,276 40

  1. nakata6790

    nakata6790 True Player
    Member

    Joined:
    Sep 17, 2009
    Messages:
    890
    Country:
    Greece
    I had the same issue. My WD 750GB HDD MyBook essentials (plug powered 3.5', and connected to usb port 0 of Wii) suddenly* took up about 2 to 3 minutes to get in game. In some games like CoD MW3 and CoD BO online multiplayer modes, it lagged like CRAZY on IOS 250.

    I reformatted the drive to FAT32 with 32kb clusters, and now it is back in full force. It boots about 31 seconds to play a game in usb loader GX from power up and 37 seconds if i let a dvd in the drive (for Dios Mios games like 1080, Sonic Collection, Midway Arcade Treasures, XIII etc).

    Oh, and i now use IOS 223 for the CoD online modes in MW3 & BO, lags very very little, if at all.

    By comparison, a 2.5' HDD, usb-powered Intenso 750GB i have, takes about 30 seconds to get in game from gx when powered on. It also never lags in Wii CoD online games. Unfortunately it is not compatible with Dios Mios (i'll try a Y cable in the future) so i had to fix the old WD HDD again.

    *drive was constantly moved back and forth by from the Wii to the PC, to add games and movies, and one time it fell on the floor. Lesson learned, now i added everything i ever wanted to the HDD and i leave it well alone by the Wii at all times. Got a 64GB HCSD for movies.

    TL;DR
    Back up & format your HDD :yaywii:
     
  2. VashTS

    VashTS Beat it, son
    Member

    Joined:
    Mar 14, 2009
    Messages:
    4,199
    Country:
    United States
    what about defragging regularly? that should solve any issues like you experienced.

    maybe build a defragger into GX? doubt its likely but maybe possible
     
  3. Nemesis90

    Nemesis90 GBAtemp Fan
    Member

    Joined:
    Nov 12, 2011
    Messages:
    315
    Country:
    United States
    I've just discovered something else that may be important to this issue, it looks like the slow booting occurs even without a HDD present, it will sit at "loading USB" for 45 sec regardless if a drive is plugged in. I also discovered that lag/stuttering occurs when checking/unchecking game lists from the icon at the top of the GUI, again regardless if a HDD is inserted. I hope this info helps narrows something down.
     
  4. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,309
    Country:
    France
    I was going to suggest using the "Synch FAT32" option in the settings > features, but it only affects HDD.
    You are saying it's doing it without HDD too :(

    Maybe there's an issue with your SD card then? Like I said above, the lag happen if the SD card is locked so maybe it happen when reading/writing is slow too.
    Try another SD card before formating it for nothing.
     
  5. NapalmOmega

    NapalmOmega Advanced Member
    Newcomer

    Joined:
    Aug 19, 2013
    Messages:
    79
    Country:
    United States
    Been trying to load my passport HDD for the last 3 days. Try just about everything. But my HDD is never acknowledged and if it is its stuck on "Loading" and the wii remote shuts off. Any and all input would be appreciated.

    sysCheck v2.1.0b19 by Double_A and R2-D2199, Nano
    ...runs on IOS58 (rev 6176).

    Region: NTSC-U
    System Menu 4.3U (v513)
    Priiloader installed
    Drive date: 2006.05.26
    Homebrew Channel 1.1.2 running on IOS58
    HomebrewFilter ist nicht installiert
    Hollywood v0x11
    Console ID: 35928869
    Boot2 v4
    Found 53 titles.
    Found 35 IOS on this console. 4 of them are stub.

    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4123): No Patches
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS51 (rev 4864): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5661): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS61 (rev 5662): No Patches
    IOS80 (rev 16174): Trucha Bug, NAND Access
    IOS236[36] (rev 65535, Info: rev 3351): Trucha Bug, ES Identify, NAND Access
    IOS249[56] (rev 20, Info: rev 20): Trucha Bug, NAND Access, USB 2.0
    IOS250[38] (rev 20, Info: rev 20): Trucha Bug, ES Identify, NAND Access
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v10

    Report generated on 2014/03/05.
     
  6. Nemesis90

    Nemesis90 GBAtemp Fan
    Member

    Joined:
    Nov 12, 2011
    Messages:
    315
    Country:
    United States
    I just did a fresh install of the app on a 2gb card with no games or other apps and those symptoms still occur.
     
  7. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,309
    Country:
    France
    NapalmOmega: Which version of the loader are you using?
    Which IOS are you using? (IOS58 or 249?)

    Update your cIOS, they are old. install d2x cIOS v10 for Wii (not for vWii).

    Nemesis90: Sorry I don't know what the problem is.
    Did you try another cIOS version (10 <-> 10-alt), or using the loader with IOS58 instead of cIOS (set 58 in meta.xml argument, or set loader IOS to 58 in the settings)?
    After that, I don't know what to suggest.
    You tested without hdd, with a different/clean SD, and with different IOS.
    Test another USBloader.
     
  8. NapalmOmega

    NapalmOmega Advanced Member
    Newcomer

    Joined:
    Aug 19, 2013
    Messages:
    79
    Country:
    United States
     
  9. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,309
    Country:
    France
    Then update the cIOS in slot 249 and 250.
    You are using revision 20
    There's a revision 21, and 10 other different versions based on revision 21 called "d2x cIOS".

    install one if this:
    - cIOS d2x version 8: Final, stable release.
    - cIOS d2x version 10: v8 + more HDD supported.
    - cIOS d2x version 10-alternative: v10 + with Dual USB support, but less EmuNAND support.

    you need to install:
    d2x cIOS v10
    slot: 249
    base IOS : 56
    version 21010

    d2x cIOS v10
    slot: 250
    base IOS: 57
    version 21010
     
  10. Nemesis90

    Nemesis90 GBAtemp Fan
    Member

    Joined:
    Nov 12, 2011
    Messages:
    315
    Country:
    United States
    IOS58 worked, nags are gone ;). I have one more question, my brother has the same setup that i do, but when you launch the app on his system he gets a message like this "Error: USB not detected. Switching to channel mode" when a USB device is not inserted on his, but this doesn't happen on mine and we both use the same latest version (r1218mod1). Also i think this app should get it's own unique settings folder name on the root. It seems to be having problems with ocarina support for certain games, as well as having problems coin-siding with Wiixplorer, which has the same "config" folder name on the SD root. I may just be over thinking this.
     
  11. NapalmOmega

    NapalmOmega Advanced Member
    Newcomer

    Joined:
    Aug 19, 2013
    Messages:
    79
    Country:
    United States
    ok updated to the latest cIOS and now an error pops up "USB Loader GX needs unstubbed cios 222 v4 or 249 v9+". I'm starting to think my wii just can't use usb loader gx or any loader of any kind. To anyone who sees this I would like to compare my syscheck with others who have working cIOS to see where mines differ.

    sysCheck v2.1.0b19 by Double_A and R2-D2199, Nano
    ...runs on IOS58 (rev 6176).

    Region: NTSC-U
    System Menu 4.3U (v513)
    Priiloader installed
    Drive date: 2006.05.26
    Homebrew Channel 1.1.2 running on IOS58
    HomebrewFilter ist nicht installiert
    Hollywood v0x11
    Console ID: 35928869
    Boot2 v4
    Found 52 titles.
    Found 35 IOS on this console. 4 of them are stub.

    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4123): No Patches
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS51 (rev 4864): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5661): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS61 (rev 5662): No Patches
    IOS80 (rev 16174): Trucha Bug, NAND Access
    IOS222[38] (rev 65535, Info: hermes-v5.1): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS236[36] (rev 65535, Info: rev 3351): Trucha Bug, ES Identify, NAND Access
    IOS249[56] (rev 21010, Info: d2x-v10beta53-alt): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 21010, Info: d2x-v10beta53-alt): Trucha Bug, NAND Access, USB 2.0
    BC v6
    MIOS v10

    Report generated on 2014/03/07.
     
  12. Maxternal

    Maxternal Peanut Gallery Spokesman
    Member

    Joined:
    Nov 15, 2011
    Messages:
    5,210
    Country:
    Not sure if this is your problem but just to be sure, are you running the latest version of GX? r1218mod1 is the latest.
     
  13. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,309
    Country:
    France
    It should work fine now.
    Your cIOS are not stubbed at all.

    like maxternal said, be sure to use latest revision : r1218 mod1.
    Extract the "boot.dol" located in the "IOS249" folder, and replace your old boot.dol in your SD/apps/usbloader_gx/ folder, then launch the loader from HBC or Forwarder.

    Maybe your USBLoader's setting is wrong
    you can either edit the .cfg file manually to set IOS to 249, or just delete all .cfg file you find in the /apps/usbloader_gx/ folder
     
  14. NapalmOmega

    NapalmOmega Advanced Member
    Newcomer

    Joined:
    Aug 19, 2013
    Messages:
    79
    Country:
    United States
    Thanks that solved that problem. But, now my hdd is not being detected. GX starts up ,but not my hdd. Same thing for wii flow, uloader and some other loaders. Now, I thing the problem is with the formatting. I'm using wii backup manager and converting ntfs to wbfs with windows 8.
    I see alot of options in GX ,but i'm not gonna mess with it.

    My HDD is in the usb slot 0 and twenty seconds counts down anyway. My HDD is a passport ultra 500gb and I tried two other usb ,so I am fairly certain the problem is from my laptop to my HDD.
     
  15. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,309
    Country:
    France
    with the latest revision, it's using IOS58 to detect the drive.
    Maybe it's an issue with your drive.

    Edit your meta.xml located in the loader's folder using notepad (or any other text editor).
    delete the two "<--- Remove this line" you see
    it will allow forcing a cIOS on boot.
    --IOS=249 will force the loader to reload to IOS249 before mounting the drive, instead of using IOS58.
     
  16. NapalmOmega

    NapalmOmega Advanced Member
    Newcomer

    Joined:
    Aug 19, 2013
    Messages:
    79
    Country:
    United States
    Ok so i used vga emulator and uploaded roms from usb port 0 so the drive is not the problem.

    Could you be more specific on what to delete in the xml because I don't see anything that resembles what you told me to delete.
     
  17. TheBroCode

    TheBroCode GBAtemp Regular
    Member

    Joined:
    Oct 31, 2012
    Messages:
    167
    Country:
  18. NapalmOmega

    NapalmOmega Advanced Member
    Newcomer

    Joined:
    Aug 19, 2013
    Messages:
    79
    Country:
    United States
    What Partition do you guys use?
     
  19. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,309
    Country:
    France
    partition type?
    Most users are using FAT32, because it's compatible with all homebrew, emulators, Gamecube ISO and EmuNAND.
    some users prefer NTFS because it can be used to store big files too.
    Some users (less and less) are still using WBFS partitions. but it's an unstable and easily corrupted format and is not recommended.

    About the meta.xml:
    https://code.google.com/p/usbloader-gui/source/browse/trunk/HBC/META.XML
    line 7 and 12
    Or maybe you have an old version and you don't have these lines.
    You seems yo have everything old (cIOS, homebrew, probably the HBC too)


    To compile the sources :
    use SVN to get the latest revision
    Install Devkitpro and PPC_r26
    Download the additional library package on the download tab, and extract/add it to your devkitpro folder. (it should replace the entire libogc, and add files to portlib folder if you already have it)
    You can know compile.
     
  20. NapalmOmega

    NapalmOmega Advanced Member
    Newcomer

    Joined:
    Aug 19, 2013
    Messages:
    79
    Country:
    United States
    Ok I made more progress.gx loads my hdd and usb ,but does not show my backups nor lets me back up games to my hdd. At times its really laggy and weird. I think you were right, there is something wrong with my driver. My wii makes these strange noises when my hdd is connected. I might just get a new wii all together.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Loader,