USB Loader GX: Multiple issues

Discussion in 'Wii - Backup Loaders' started by BlazeHeatnix, Dec 21, 2015.

  1. BlazeHeatnix
    OP

    BlazeHeatnix Advanced Member

    Newcomer
    87
    5
    Jul 4, 2015
    United States
    I'm tired of making separate threads for these things, so I'm just going to have one single thread with every issue I'm currently having with USB Loader GX, and I hope someone can help me.

    1. Covers are not showing up. I downloaded every cover imaginable via WiiBackupManager and all custom paths are correct, but in the loader I don't see any of the covers. Even when I download in the loader itself it says "All covers downloaded". All I see is a red circle with a cross through it saying "Cover not found". The covers are on my SD while the games are on the USB, is this a problem?

    2. I can't change the background music...the music I want is in OGG format and the music path is set to where it is, but the loader says it's in the wrong file format. I tried mp3 too, that didn't work either.

    3. How do I install multi-disc Gamecube games for Nintendont? I know how to do them on pc, but what about installing directly from the discs?

    Thanks in advance
     
    Last edited by BlazeHeatnix, Dec 21, 2015
  2. Santaros

    Santaros GBAtemp Regular

    Member
    197
    66
    Oct 5, 2013
    I would say the problem is likely that you are trying to run it via both SD and USB. Have to wait for somebody more knowledgeable to chime in, but I have tried to do the same thing with apps that would only run via SD and it was a pain in the ass, would only detect the SD when the USB device was unplugged. In my case I'm running 2 partitions on the same external HDD and it's not a problem.
     
    ISO-Man likes this.
  3. ISO-Man

    ISO-Man GBAtemp Regular

    Member
    185
    13
    Mar 24, 2013
    United States
    Agreed, my setup fails with SD/USB at same instance. I use a small partition on the usb also :)

    ISO-Man
     
  4. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,005
    774
    Mar 2, 2015
    United States
    The app and data can absolutely be put on SD while leaving the games on USB. That's how I have mine set up. What you can't do is use two USB storage drives at the same time.
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,261
    8,738
    Oct 27, 2002
    France
    Engine room, learning
    1. it's good.
    it's even recommended to use SD for all the ressources (covers, cheats, etc.), and USB for game's ISO.

    I don't understand why the covers would not display. Even the one downloaded directly from the loader.
    it could be a path issue if you didn't put the correct name, but using the internal updater won't use bad filenames so it should load.

    your SD card is FAT16/FAT32 ? (not exfat, but I don't think it would even detect it).

    2.
    I never used that feature.
    I didn't code it, never used it, never debugged it.
    All I know is that you shouldn't use this feature with dual USB, like Greywolf said.
    SD is always mounted and accessible, while USB are shut downed without informing the user when using dual USB feature (to switch from one drive to another, it needs to shutdown because only one at a time is possible)

    MP3 should work.

    it seems strange that both covers and mp3 can't be read.
    Maybe your SD is bad.
    Please, format it with Panasonic SDCardFormater. (not with windows's default format option)
    3.
    Multi disc games :
    Put both ISO into the same folder.
    rename the first disc to "game.iso"
    rename the second disc to "disc2.iso"

    example:
    /games/Tales of symphonia [GQSEAF]/game.iso
    /games/Tales of symphonia [GQSEAF]/disc2.iso


    nintendont is also compatible with "multi-game" disc, but I don't think this was your question.
     
  6. BlazeHeatnix
    OP

    BlazeHeatnix Advanced Member

    Newcomer
    87
    5
    Jul 4, 2015
    United States
    That's not what I asked. I don't have the discs as ISOs. I'm installing from retail discs. Also my SD is not bad, it's already been formatted.
     
  7. ISO-Man

    ISO-Man GBAtemp Regular

    Member
    185
    13
    Mar 24, 2013
    United States
    Stupid question, but Is it a true SD or a Micro SD Adapter? My Wii's did not like the adapters. Just a thought :)

    ISO-Man
     
  8. BlazeHeatnix
    OP

    BlazeHeatnix Advanced Member

    Newcomer
    87
    5
    Jul 4, 2015
    United States
    It's a true SD.

    Also I fixed the cover issue, in WiiBackupManager settings I changed the configuration from "CFG USB loader" to "USB loader GX" and reinstalled covers, and now the loader sees them.
     
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,261
    8,738
    Oct 27, 2002
    France
    Engine room, learning
    even easier !

    launch USBLoaderGX, insert any disc (1 or 2), select install.
    insert the second one, select install.
    done :D

    I designed the loader to detect if you already have a disc from the same game on the partition you use to dump games and put the second ISO into the same folder.
    Some games have the disc number as internal game's title, for example "tales of symphonia disc1" is the name of the game on the first disc, but it will place the second disc in the same folder (not in "tales of symphonia disc2").
    Even if it's named "disc1" in the folder name it's not an issue for auto-swap.
    you can rename the folder later manually if you want and if you don't like "disc1" as part of the folder's name, but it will not affect compatibility.
     
  10. BlazeHeatnix
    OP

    BlazeHeatnix Advanced Member

    Newcomer
    87
    5
    Jul 4, 2015
    United States
    Great, thanks :)

    I still haven't solved the music issue. Covers now work and I can now download them in the loader with no problems.
     
  11. tswntk

    tswntk GBAtemp Advanced Fan

    Member
    650
    136
    Aug 6, 2012
    Switzerland
    I used to share the covers among all loaders though I have not touch the other loaders for ages. The image formats are the same.
    I still think its a setting problem.

    did you edit the path settings manually (using text editors in PC) or via the setting menu of the loaders?
    do you happens to have setting files in both SD and USB? IIRC, usbloadergx will search for setting files in SD first no matter where your installed the apps. Cyan should have a more definite answer on this.
     
  12. BlazeHeatnix
    OP

    BlazeHeatnix Advanced Member

    Newcomer
    87
    5
    Jul 4, 2015
    United States
    I don't know exactly what I did. In WiiBackupManager, under Settings, in the Covers tab, I changed "USB Loader Configuration" from Configurable USB loader, to USB Loader GX. And then right below that, I redirected the base cover folder to EXACTLY where the base cover folder was. And then I synced and downloaded some missing covers, and then suddenly ALL of them showed up in the loader itself.

    The path settings never changed in the loader itself. And I still need help with the sound please, this is a Christmas gift for someone :(
     
    Last edited by BlazeHeatnix, Dec 22, 2015
  13. BlazeHeatnix
    OP

    BlazeHeatnix Advanced Member

    Newcomer
    87
    5
    Jul 4, 2015
    United States
    I FINALLY figured out what was wrong with the custom music. I had put the music in the root of the SD and tried to load it from there. The problem was, and I didn't notice at first, was when you open the sound loader the directory says this:

    [​IMG]

    When clicking on music files it kept that weird nic in the directory and wouldn't load properly. When clicking on any of the folders, it resets:

    [​IMG]

    I put all the music in a music folder instead and that did the trick. Hopefully the dev can fix this little bug so someone else won't be confused like I was.
     
    Last edited by BlazeHeatnix, Dec 22, 2015