USB Loader GX forwarder FAT help

Discussion in 'Wii - Hacking' started by newr, Jun 18, 2009.

  1. newr
    OP

    newr Advanced Member

    Newcomer
    57
    0
    Jan 2, 2009
    Canada
    I've been trying to install USB loader GX on my Wii...running IOS249v10. I was able to run loader through homebrew and when I had a single partition to format. I am now trying to run it through the forwarder and create a FAT partition for the boot.dol and covers etc....

    I read from the readmii file to create a partition on PC which I did. One as NTFS and another as FAT...then when USB loader says it needs to format as WBTS it goes into code dump page. So this seem to be a problem with the partition? Am I doing it correct? I've also placed the boot.dol into the correct directory in the FAT partition.. and when I run the channel created by the forwarder...same dump occurs.

    Am I doing something wrong?

    Thanks for the advice!
     
  2. newr
    OP

    newr Advanced Member

    Newcomer
    57
    0
    Jan 2, 2009
    Canada
    anyone has any idea about my question?
     
  3. TroyTheZombie

    TroyTheZombie GBAtemp Advanced Maniac

    Member
    1,631
    4
    Mar 3, 2009
    Canada
    Calgary, Canada
    k, first off, is the FAT32 partition the first partition on the drive? it has to be for any app to see it.

    and 2nd

    my advice is just format them both as fat.

    here, a tool i use for just such purposes.

    http://www.mediafire.com/download.php?mizwnzjawdm
     
  4. Midnightzak

    Midnightzak GBAtemp Regular

    Member
    176
    0
    Aug 5, 2008
    United States
    I was having trouble getting a USB loader to format for me as well, so I just got a WBFS manager for Windows and had that program do the work for me. Once it formatted WBFS my Wii had no problem seeing it. I've been dumping Wii Game discs for hours now... (though SSBB only took about 30 mins as opposed to 2.5 hours most say)
     
  5. newr
    OP

    newr Advanced Member

    Newcomer
    57
    0
    Jan 2, 2009
    Canada
    I did format the drive as WBFS as it won't let me do it on the Wii..and it does see that partition if I run the program through homebrew with the SD in.
     
  6. newr
    OP

    newr Advanced Member

    Newcomer
    57
    0
    Jan 2, 2009
    Canada
    Ok..I've formatted the FAT partition first and other for the WBFS...stiill same problem, it code dumps when I try forwarder. I have the newest version. It works fine if I run it through homebrew channel just with the USB drive. So I guess the FAT partition is being read. Just can't do the forwarder channel.

    Could it by the CIOS? I am using ver10 IOS249..does it need other IOS to work?
     
  7. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,346
    326
    Nov 19, 2008
    United States
    Sandy, UT
    Try formatting it in a WBFS Manager.
     
  8. TroyTheZombie

    TroyTheZombie GBAtemp Advanced Maniac

    Member
    1,631
    4
    Mar 3, 2009
    Canada
    Calgary, Canada

    could a bad forwarder. give me a bit, I'll put up one that should work.
     
  9. newr
    OP

    newr Advanced Member

    Newcomer
    57
    0
    Jan 2, 2009
    Canada
    OK..I somehow got it working finally. Don't really know why it wasn't working. I did format the drive with WBFS manager. The only way I got it working is to run update after it loaded in homebrew and update all the files. Then the forwarder seem to work. I have the most updated forwarder from the website already and used that boot.dol in the HDD..so don't know why it was causing code dump before.

    Anyway, thanks for all the suggestion.