USB Loader GX changing themes.

Discussion in 'Wii - Backup Loaders' started by terumpk2, Apr 10, 2015.

  1. terumpk2
    OP

    terumpk2 Newbie

    Newcomer
    3
    0
    Apr 10, 2015
    I cant seem to change the theme on my Usb loader, right now i have it as the default theme but when i manually put files onto my SD card to my SD:/(themesdirectory)/ and put the custom path as that, the theme doesnt change, and also nothing comes up when i go into the themes folder in the custom paths setting on the loader, its just a blank folder. if anyone could tell me if im doing something wrong and how to properly install them it would be great.

    Also when i try to download themes from the Theme downloader on the USB loader it just gives me an error when i try to download and then crashes the loader when i try exit the downloader.
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,572
    8,918
    Oct 27, 2002
    France
    Engine room, learning
    you need this format :

    if you set the theme directory to SD:/themedir/
    then you need :

    SD:/themedir/Theme_filename.them
    SD:/themedir/Theme_foldername/all your pictures inside this sub folder

    Example:
    SD:/themedir/christmas.them
    SD:/themedir/christmas/abcIcon.png
    SD:/themedir/christmas/add.png
    etc.

    When you go to the Theme select menu, the loader lists all the ".them" files found in the /themedir/ folder. It doesn't list subfolders if there's no corresponding .them file.



    The theme downloader menu doesn't work anymore because the theme repository Website owner decided to block direct download access and users now require to register and pass though advertisement to download themes.
    I will probably remove the theme downloader menu, but I find it a good way to see what exists and what can be downloaded on spiffy website. users just can't download from the loader anymore :(
     
  3. terumpk2
    OP

    terumpk2 Newbie

    Newcomer
    3
    0
    Apr 10, 2015
    Thanks!:lol: got the theme to change finally, took me ages to try figure out on my own, was searching on google on how to do it aswell but couldnt find it.

    Theres something else im hoping you could help me with, i have just dance 2015 on my loader and i cant seem to get it to work it just black screens everytime i try load it up. ive tried changing the game iOS to 250 and 224 and Using force pal 60 and ntsc but i still get black screen, any ideas on how i can get it to work? it would be much appreciated
     
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,572
    8,918
    Oct 27, 2002
    France
    Engine room, learning
    if using slot250 (or more correctly a cIOS based on IOS57, if your slot250 and 224 are using a different IOS base then it will have no effect!) didn't help, then maybe your ISO is bad.
    Try dumping your game again, or verify its Sha1 with WiiBackupManager option.
     
  5. terumpk2
    OP

    terumpk2 Newbie

    Newcomer
    3
    0
    Apr 10, 2015
    Managed to fix it thanksâ˜ș turns out I had an outdated version on USB loader, so I updated it, and then installed the cios versions with the same bases like you said and it worked! Thanks for a your help
     
  6. Wii Tink

    Wii Tink Newbie

    Newcomer
    4
    0
    Apr 4, 2016
    United States
    I really need help! I followed all of your instructions as to how to change the theme, or at least I think I did, and I can get all the icons to move all over the place, most times they are bizarrely placed (ie: Games: x Then Under it with how much space is left on the hard drive and then on top of the 2 of those the time, all in black)... but the screen only stays white. I named everything in the folder "name".png and I still can't get it to work. I've been trying absolutely everything! I even changed the "customs path" and "theme path" to the path I want them to be on, but still isn't working. I hope someone can help, I'm soooo frustrated with it. I've been trying for several days but it just wont work.

    Also, I did download the themes off the site itself, so I really don't understand it. :(
     
  7. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,572
    8,918
    Oct 27, 2002
    France
    Engine room, learning
    if the loader detects your theme, then it means you placed the file to the correct folder.
    If it miss all the pictures, then you don't have them to the correct location or name.

    Open the them file into a text editor, there should be the expected name for the sub-folder where the picture need to be placed to.

    If elements seems not correctly placed, maybe the theme you downloaded was designed for an old version of the loader.
     
  8. Wii Tink

    Wii Tink Newbie

    Newcomer
    4
    0
    Apr 4, 2016
    United States
    I have the themes and the pictures.png in the same folders, all in SD/"Game". This is for each game. Is that wrong?
     
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,572
    8,918
    Oct 27, 2002
    France
    Engine room, learning
    That's your issue.

    Also, the "themes folder" NEED to be the place where you have the "them" files, not the one where you have the pictures!

    SD:/apps/usbloader_gx/themes/ <--- this is the default theme folder defined in "settings>user's paths"

    Then to load a theme, you need to go to "settings>theme menu" and from this menu you select the detected them file.



    You need this layout :
    inside "themes" folder, you need to put the ".them" files.
    example :
    SD:/apps/usbloader_gx/themes/default.them
    SD:/apps/usbloader_gx/themes/blue.them
    SD:/apps/usbloader_gx/themes/red.them
    etc.

    If a theme use different pictures or fonts, they usually are in a subfolder inside the themes folder.
    SD:/apps/usbloader_gx/themes/school.them
    SD:/apps/usbloader_gx/themes/school/ <--- another folder, and inside you have the png files. Do not put the png insde "themes" but inside another folder located in themes.


    SD:/apps/usbloader_gx/themes/school.them
    SD:/apps/usbloader_gx/themes/school/menu.png
    SD:/apps/usbloader_gx/themes/school/font.ttf
    SD:/apps/usbloader_gx/themes/stargate.them
    SD:/apps/usbloader_gx/themes/stargate_pictures/menu.png
    SD:/apps/usbloader_gx/themes/etc.

    the folder's name where the png are located is defined inside the ".them" file.
     
  10. Wii Tink

    Wii Tink Newbie

    Newcomer
    4
    0
    Apr 4, 2016
    United States
    Sorry if I'm posting this wrong too... I'm new here and keep getting my posts removed. I have tried absolutely everything to get the theme to work but I can't get it to work at all. I put the theme into SD:/themedir/"game name" and in the same folder were the .png files (I named all of them .png, but it didn't make any difference with .png or not).

    I can get to the theme when I go into "custom paths" and then into "theme path", changed the folder to the "game name" theme folder, but I'm really lost as to what I'm doing wrong, because instead of getting a new picture and shuffling all of the icons everywhere, I get white with the icons going everywhere... sometimes not even proper as they are all piled on top of each other sometimes.

    Please, if someone can help me, I'd appreciate it... I've been struggling with this for several days now and I'm so frustrated with it but I'd love to surprise my son with it.

    Thanks.
     
  11. Wii Tink

    Wii Tink Newbie

    Newcomer
    4
    0
    Apr 4, 2016
    United States
    I couldn't find this thread so I posted a new thread, sorry. Now that I found this thread I can just talk on this one. Okay, so I got 2/12 to work... not sure why the 10 aren't working now. Any suggestions as to what happened to those ones?
     
  12. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,158
    802
    Mar 2, 2015
    United States
    The .them file and all the images for it go in one folder.

    ex:
    /themes/footheme/
    /themes/footheme/footheme.them
    /themes/footheme/*.png

    If it's still not working it might be an old theme that's no longer compatible.
     
  13. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,572
    8,918
    Oct 27, 2002
    France
    Engine room, learning
    Note: I merged your other thread into this one, so there's no duplicated help in two different location, by different users.


    It's hard to see what's wrong without knowing how and where you placed the files on your device.
    If you could provide a screenshot, or write the path here, so we can see if you copied and extracted all the files to the correct folder, then we could help you better.
    Could you also tell us which themes you are trying to install ? maybe they are outdated or incompatible with your current loader's version. give us links to the themes.

    Please, use default path !
    Don't set the theme path to "SD:/themedir/"
    /apps/usbloader_gx/themes/ folder instead (use the path inside the folder where you have the loader installed, if it's on SD, use SD:/apps/usbloader_gx/themes/)

    Once you understand how it works and get everything working fine, then you can think about using another, custom, path for your needs, but for now please use all default settings. it's easier to help you and prevent differences with users helping you.


    @GreyWolf :
    that's wrong.
    the .them file is not inside a subfolder.

    Correct layout is :
    /themes/footheme.them
    /themes/footheme_subfolder_name/*.png

    The folder name is not always the same than the "them" filename.
    it's not because you have "cool.them" that you need to put the pictures in a "cool" subfolder. the subfolder could be name "awesome", you set the folder name inside the .them file, so the loader need to load the .them first to know the subfolder name, you can't put the .them inside the unknown subfolder name.
     
  14. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,158
    802
    Mar 2, 2015
    United States
    Ah, ok. Maybe his resource folder name is the issue then. :P
     
  15. colking

    colking Advanced Member

    Newcomer
    89
    10
    Jan 14, 2016
    Canada

    I can't see the .them file when I try to set path in USB loader gx. What ami doing wrong? Thanks
     
  16. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,158
    802
    Mar 2, 2015
    United States
    The path dialog doesn't show files, only folder names. Just make a folder called "themes" in your /apps/usbloader_gx/ folder and put your themes in it. ".them" goes in the main folder, the theme resources folder needs to be in the same place. If you still don't see themes in the settings make sure the path is right in Custom Paths. (Note the theme downloader doesn't work anymore so you'll have to copy them manually.)
     
  17. colking

    colking Advanced Member

    Newcomer
    89
    10
    Jan 14, 2016
    Canada
    Thanks dude, I'll try that! :)
     
  18. colking

    colking Advanced Member

    Newcomer
    89
    10
    Jan 14, 2016
    Canada
    Still not working... Could it be my sd card? Its a 64gb and running USB Loader on vwii. Could I try putting Themes on external hard drive where my games are?
    thanks
     
    Last edited by colking, Jan 16, 2017
  19. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,158
    802
    Mar 2, 2015
    United States
    You can put them anywhere, you just have to change the theme path in "Custom Paths".

    This is how an example theme called "Test" should be assuming you're using the default theme path:

    /apps/usbloader_gx/themes/Test.them
    /apps/usbloader_gx/thems/Test <- folder with images, sounds, etc for theme.

    Also make sure the them has the image folder name set properly in it. In this case it should be "Image-Folder: Test\n".

    Your theme path should be set to "/apps/usbloader_gx/themes/" and not the name of the theme you're using.
     
    Last edited by GreyWolf, Jan 16, 2017
  20. colking

    colking Advanced Member

    Newcomer
    89
    10
    Jan 14, 2016
    Canada
    Just tried that and still nothing... Maybe these themes are no good? thanks again.