USB FAT device could not be opened error???

Discussion in 'Wii - Hardware, Devices and Utilities' started by DeadlyRevengexX, Jun 4, 2017.

  1. DeadlyRevengexX
    OP

    DeadlyRevengexX GBAtemp Regular

    Member
    123
    15
    May 20, 2017
    United States
    Hey again all! Once again I have run into a brand new problem on my original 4.3u modded Wii using Nintendont v4.444.

    Ok so first off, my external 2TB HDD has been working about 75% of the time and running games great on Nintendont, but the rest of the time Nintendont gives me the error listed in the title above, and leaving Nintendont then re-entering it does not fix it.. which in turn forces me too hold the power button on my Wii to shut it off, then power off my HDD, then power back on my HDD, then turn back on my Wii... and even THEN sometimes I get the exact same error, and sometimes I'll get the error 4 times in a row after restarting everything 4 times as well, THEN the 5th time it will work. Also when the game is playing it plays perfectly for hours, with no problems.. but I'm writing here because I'm so tired (litteraly) of having to manually reset everything by hand just to play.. especially when the Wii is across the room.

    Things to Note: My HDD is plugged directly to the wall, so I know it is receiving enough voltage. My Wii is plugged to an extension chord though as there are no more free outlets. When I plug my HDD in my windows 10 PC, sometimes rarely it tells me that there are errors on the drive and when it asks to fix it I click yes, and after, 50% of the time it tells me errors have been fixed, and the other 50% of the time it tells me that no errors where found. Ok.. so what "errors" did you find the first time PC!?

    More issues: The same happens with USBloaderGX.. I'll get similar error message sometimes. Also at times my harddrive willbe green as if it's asleep when I go to open it to play a game in Nintendont or USB loaderGX and it will seem as if nothing is connected. Most of the time it becomes red to show it's not sleeping and being used, and it works..

    (My last 500GB HDD that I had worked perfectly, and never gave me an error, so I know it's not my Wii.)

    Anyways, I'm almost positive that everything on my Wii is modded correctly. I just want to solve this mystery and hopefully you guys can lead me to the correct resolution without me having to replace anything or spend money. lol


    Thanks in advance!
     
  2. AyoobD

    AyoobD Newbie

    Newcomer
    2
    0
    Jun 14, 2017
    well i had this problem and i just fixed it, i ran it 4 times to check and its working fine for me

    steps:

    1-make sure that your drive is formatted FAT32 and cluster size 32K and set to active

    2-when you put the game in your hard drive make sure the path is like this (Mario Party 5 as an example), USB:\Games\Mario Party 5\Game

    3-Make sure your hard disk is plugged on the top port not the bottom on the back of your wii
     
  3. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,864
    5,018
    Mar 17, 2010
    Norway
    Alola
    Always make sure to safely eject the drive, or it could cause the kind of corruption you mention.
    It sounds like your drive's sleep mode is causing issues, depending on the drive you have there may be a tool you can use to disable sleep mode.
     
  4. DeadlyRevengexX
    OP

    DeadlyRevengexX GBAtemp Regular

    Member
    123
    15
    May 20, 2017
    United States
    I believe that may be the issue as well.. but sometimes I back out to the main menu of the Wii and it's still red! D: As if it's working.. but it shouldn't be, it should be green as in sleep right? My HDD is a 2TB generic one from Amazon.com, it has great reviews too.. so I'm confused. My harddrive has 2 colors to it's light, red when it's being used, and green when it's connected to everything but it's not being used. When do I know when it's in sleep mode?

    Also what is a program I can use to disable sleep mode that will not corrupt any of my data?

    It's really annoying.. I'm constantly shutting everything off and on again like 4 times untill the HDD gets recognized by usb laoder gx. :wacko: It's pretty frustrating considering I just want to plug it in and play. Sometimes I even back out of the game to switch games and usb loader gx won't recognize it again.. the HDD is plugged into the wall as well so it's receiving the right amount of power, and its FAT 32 with 32 bit clusters.