update to 1.1.3 without the ds-x server

Discussion in 'Other Flashing Hardware & Software' started by sanchox, Aug 22, 2008.

  1. sanchox
    OP

    sanchox Newbie

    Newcomer
    7
    0
    Jan 31, 2008
    United States
    so i dug out my ds and the ds-x after a few months of storage and i would like to update the ds-x to 1.1.3. upon running the update program from the ds-x website i get an error that the app cannot find the server... i have gone to this thread: http://www.gbatemp.net/index.php?showtopic=97017 and have downloaded the supposedly hacked version of the 1.1.3 updater that is supposed to work "offline" yet i get an error each time i attempt to update my ds-x: "Unable to download latest DS-Xtreme firmware, Error : 302 Found"

    does anyone know how to update my ds-x to 1.1.3 without the official ds-x servers up??? this sucks [​IMG]
     
  2. pbolmstedt

    pbolmstedt GBAtemp Regular

    Member
    160
    0
    Nov 13, 2006
    There's instructions in the "DS-X Open Source Firmware Project" wiki hosted here.
     
  3. Virusak

    Virusak GBAtemp Regular

    Member
    121
    0
    Jul 8, 2007
    well I tried to hex edit the updater as described in the wiki but then I couldn't launch it, it says that its not a valid win32 app
    any help?
     
  4. polychromeuganda

    polychromeuganda Newbie

    Newcomer
    3
    0
    Aug 25, 2008
    United States
    To make the edit you have to use something that lets you edit PE format files and fixes up the checksums.

    Having done that, it still doesn't work for me. Has MS has crippled the file:// access method in some recent security update?

    Editing the string to file://MYPC/C:\temp\update.txt onlyesults in a message saying the file could not be opened. (lets assume m PCs name is MYPC, and the file is really at C:\temp\update.txt)

    and yes...the string in update.txt was similarly updated to point to update.bin..

    ...and for completeness, using my LAN IP address instead of my machine name doesn't change anything.
     
  5. kazumi213

    kazumi213 GBAtemp Regular

    Member
    293
    0
    Oct 16, 2006
    I updated my DS-X to FW 1.1.3 beta locally. The method described on the wiki doesn't work because the updater executable doesn't accept file:// nor ftp:// access methods. The only way is using http:// and running a local web server.
     
  6. PKGINGO

    PKGINGO GBAtemp Regular

    Member
    135
    0
    Jul 27, 2007
    United States
    my updater does not work offline, it points to files hosted on my server.
     
  7. pbolmstedt

    pbolmstedt GBAtemp Regular

    Member
    160
    0
    Nov 13, 2006
    For the record, this path doesn't work in IE@XPSP3 for me (and so maybe the "underlying API" doesn't accept it). I had to remove the computer name to get it working: file:///c:\update.txt. Firefox will swallow anything (file://MYPC/c:\, file://./c:\ etc) but doesn't use an "underlying API" the way IE does.
     
  8. Virusak

    Virusak GBAtemp Regular

    Member
    121
    0
    Jul 8, 2007
    and could you change it to a 1.1.3 update please? I think many people would appreciate it.
     
  9. PKGINGO

    PKGINGO GBAtemp Regular

    Member
    135
    0
    Jul 27, 2007
    United States
    If you read my post ive done both 1.1.2 and 1.1.3
     
  10. agentm

    agentm Member

    Newcomer
    43
    0
    Nov 11, 2008
    PKGINGO - have you taken the 1.1.3 update.bin file down from your server? The up.txt is still hosted, but when I run your Ds_Xtreme_updater_v1.1.3.exe file, it returns the "Unable to download latest DS-Xtreme firmware, Error : 302 Found" error message.

    I tried hosting the files on a server elsewhere, editing the up.txt file and hex editing the Ds_Xtreme_updater_v1.1.3.exe file with the new path to the files, but afterwards I get an error stating that the edited updater is not valid win32 app.

    Any suggestions?
     
  11. sanchox
    OP

    sanchox Newbie

    Newcomer
    7
    0
    Jan 31, 2008
    United States
    about two weeks ago I tried the official 1.1.3b update app that uses the ds-x.com servers and I was able to upgrade [​IMG] give that a shot, it may still work!
     
  12. Virusak

    Virusak GBAtemp Regular

    Member
    121
    0
    Jul 8, 2007
    it works, the error has to be on your side
     
  13. agentm

    agentm Member

    Newcomer
    43
    0
    Nov 11, 2008
    Thanks for the replies. After a few attempts using different editors, I finally got the update done! [​IMG] I was disappointed to find that I still need to apply the arm7 fix to more recent titles though. [​IMG]

    Sanchox - out of interest, I checked the official 1.1.3b update app, and indeed it is working (for the moment, at least)! I could've saved myself a bit of time, if I'd have done this first.
     
  14. PKGINGO

    PKGINGO GBAtemp Regular

    Member
    135
    0
    Jul 27, 2007
    United States
    Many apologies... I've been wrapped up with studying for finals and mother 3... not exactly a good combination. I had a small quota issue, which has been resolved. The 1.1.3 updater is now working correctly. Again many apologies again before I vanish [​IMG]. While you can, I really think you should download from the DSX server because that is the official place to download updates from. Mine is only a backup solution.

    Again sorry, I've been so busy, but with any luck over the break, I just might finish my rhapsody stuff so we can enjoy it [​IMG]. Take care!