UAE2All2 - Can't get roms to run

bptbptbpt

Member
OP
Newcomer
Joined
Nov 28, 2021
Messages
14
Trophies
0
Age
43
XP
99
Country
Belgium
Just installed UAE4ALL v2.0 on my Switch, I think I did it right and accordingly to the instructions (which I can't link but they are on this forum):
-unpacked the uae4all2 folder in the zip onto my SDcard:\Switch folder
-filled the kickstart folder with the two roms, kick13 and kick31 which I checked for their checksum.
-I put a few hdf files in the rom folder.

Now I can launch uae4all2 properly on my switch. I can also select a rom for df0:
But, how do I run it? I tried pressing the + on my controller. I get then one of three things, depending on my selection for the A500 or A1200 setting on the main screen:

- a white screen
- the amiga 500 boot screen (showing the hand with the floppy)
- the amiga 1200 boot screen

But nothing happens: no rom is being loaded/run. I tried 6 different roms and tried switching the a500 and a1200 a bit. E.g: A1200 setting for an AGA game, but A500 or A1200 for an older game.
But.. still nothing more than one of the aforementioned three screens.
How do I proceed?

By the way I ignored the part about NSP injection in the instructions, because I don't know what that is nor could I find more info on it. Could that be the problem? Also I don't know how to run uae4all2 as a game rather than from Album on my Switch (this is mentioned somewhere).

-------
Edit: also tried to load the hdf as File1 HDD. This results in a prompt screen when I press +. Don't know what to enter in this screen.
 
Last edited by bptbptbpt,
  • Like
Reactions: Metoroid0

Dungeonseeker

Well-Known Member
Member
Joined
Mar 28, 2016
Messages
440
Trophies
0
Age
42
XP
1,689
Country
HDF files are hard disc files, not floppy files. You need to mount them as HDDs and the emulator should boot right into the game.

ADF games are floppy images.
 

kidkat210

Well-Known Member
Member
Joined
Nov 9, 2016
Messages
1,092
Trophies
0
Age
29
XP
2,422
Country
United States
Nsp injection or the correct wording for it is title override, is the homebrew menu taking over a game/app for full ram access. To preform the title override method to boot homebrew menu with full ram, just hold R and launch a game while still holding R. Most homebrew need full ram access to properly preform.

Also you can set up a game to boot to the homebrew menu without having to hold any buttons. I setup a 5mb or 12mb game to always boot homebrew menu instead of the game
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: https://youtu.be/qgx6kuoF5tI?t=1355