TriiForce WAD extraction, the easy way

Discussion in 'Wii - Hacking' started by tripellex, Aug 19, 2009.

Aug 19, 2009
  1. tripellex
    OP

    Member tripellex GBAtemp Regular

    Joined:
    Mar 6, 2009
    Messages:
    129
    Country:
    United States
    Hey guys, I decided to help everyone out, and created a DOS batch file to use with ZX-81's awesome wad2nand tool. With the batch file, you can put everything into one folder containing all your wads, and it will extract the title and tickets for all the wads in that folder.

    The batch file and instructions can be found HERE

    This completely automates the extraction of all your WADs without having to type in each file name individually.

    Enjoy!
     


  2. carbonyle

    Member carbonyle GBAtemp Fan

    Joined:
    Jan 9, 2009
    Messages:
    360
    Location:
    Switzerland
    Country:
    Switzerland
    First: thanks
    But you don't have to type each file name, you can just type 2 letters and then tab key [​IMG]
     
  3. aabbccdd

    Member aabbccdd GBAtemp Regular

    Joined:
    Jul 28, 2009
    Messages:
    179
    Country:
    Finland
    Yeah, but still this is great for us who have multiple wads to install at once, so THANKS. :-)
     
  4. icebrg5

    Member icebrg5 GBAtemp Addict

    Joined:
    Apr 1, 2007
    Messages:
    2,326
    Country:
    United States
    Does anyone know why when i use this the outputted folders are automatically made into shared folders?

    Now everytime i use this it outputs them into the title and ticket folders but makes them shared so when i try to cut and paste them to my hard drive with my nand backup on it i get all these permission boxes popping up everytime now.

    I tried unsharing the folders but get the same results.

    Im using vista and all the folders are on the desktop


    EDIT:

    If i put the folder wad2nand on my hard drive and not on the desktop the outputted folders created by the batch file are not automatically made to share.

    Why is this?

    I unshared all the folders on the desktop but nothings working trying to get it to work from the desktop.
     
  5. Digital1980

    Member Digital1980 GBAtemp Fan

    Joined:
    Jan 8, 2008
    Messages:
    499
    Country:
    United States
    Thank you! Just what I have been looking for.

    I will test this and bring back my results.

    Quick basic noob question though. Why do I have to run a .bat from DOS mode? Why can't I just execute like an .exe? Obviously .bat files don't run that way. Do .exe files automatically run .bats or something?
     
  6. Digital1980

    Member Digital1980 GBAtemp Fan

    Joined:
    Jan 8, 2008
    Messages:
    499
    Country:
    United States
    Are you sharing any directories on your PC at all?

    An easy to look would be to browse from another computer on the network if you have one. If not, just go to my network places and it should show what you are sharing. By default I think it's "My Shared Folder" or something.

    PM me for more help if you can't get it.
     
  7. icebrg5

    Member icebrg5 GBAtemp Addict

    Joined:
    Apr 1, 2007
    Messages:
    2,326
    Country:
    United States
    I've found the folder it claims to be sharing and turned sharing off but it does the same thing.

    Not worth the headache anymore to me.

    I just put it all on my 2nd hard drive where i keep all my wii files and made a shortcut to the folder on the desktop and it works fine this way.


    Thanks for the help though i appreciate it.
     
  8. icebrg5

    Member icebrg5 GBAtemp Addict

    Joined:
    Apr 1, 2007
    Messages:
    2,326
    Country:
    United States
    I tried the batch file method out and heres what i found.

    Doing a small number of wads at one time seems to work.
    I did it with 2-4 wads then tested them and they play.

    Then i tried doing 43 wads at one time and none of them will play at all with triforce.I get either black screens or the message eject disc and turn off wii and refer to manual.
     
  9. tripellex
    OP

    Member tripellex GBAtemp Regular

    Joined:
    Mar 6, 2009
    Messages:
    129
    Country:
    United States
    Not sure what you're doing wrong. I ran the batch file on an entire folder containing all the VC games, and every game works perfectly. Be sure you're using the .DOL version of TriiForce beta 5, the one that says version 0.42.
     
  10. icebrg5

    Member icebrg5 GBAtemp Addict

    Joined:
    Apr 1, 2007
    Messages:
    2,326
    Country:
    United States

    I am running the dol version and beta 5.

    Im gonna test all 43 at once again and see what happens.

    EDIT: I added them all again and copied the two folders to my usb drive.The first time some files didnt copy over so i copied everything
    back over again.I tried out about 10 games or so and they seem to be working.

    Contra III will not work for nothing though.


    No matter how i install it it will not work at all.

    Ive tried with wad manager and w2n and w2n batch file nothing works.
     
  11. dsfanatic5

    Member dsfanatic5 Team ICO Freak

    Joined:
    Mar 15, 2009
    Messages:
    762
    Country:
    United States
    Thanks for this batch file, it works perfectly!

    I wish I could say the same for most of my games however. Any WiiWare that was patched to region free needs to be sent to my recycle bin (or repatched?), since no settings will get these to launch.

    Many of my NTSC games won't load either, no matter what settings I use. I'm sure these issues will be found and fixed in a future revision of Triforce though.
     
  12. djda

    Member djda GBAtemp Regular

    Joined:
    Apr 15, 2009
    Messages:
    240
    Country:
    Barbados
    This is exactaly what came into my mind earlier after i installed about 30 VC games this would have helped but at least for the wiiware games ill have this many thanks for this simple but useful app.
     
  13. wilsoff

    Member wilsoff GBAtemp Regular

    Joined:
    Dec 29, 2008
    Messages:
    292
    Country:
    United States
    Thanks for this, it's very handy! For those that don't want to wait 45 seconds at megaupload, or are blocked access, here are the content of the files:

    Instructions:

    1) Put all the WADs you want to use with TriiForce into a folder somewhere, preferrably in C:\Temp\Wads

    2) Download wad2nand from http://zx81.zx81.free.fr/public/wii/wad2nand/wad2nand.7z

    3) Extract the wad2nand.7z and the batch file in this archive (w2n.bat) to the folder you placed all the WADs

    4) Go to Start -> Run and type cmd then hit enter

    5) At the DOS prompt, navigate to the folder (for this document, we assume C:\Temp\Wads) by typing in cd C:\Temp\Wads

    6) Type in w2d.bat and hit enter, and wait. Depending on how many WADs you have, it should take a few minutes. Do not touch your keyboard or mouse. Go have a snack or something and when you come back, there should be 2 new folders, a /ticket and /title folder in the wads directory. Move both of these new folders to wherever you have your NAND extract at, merging the folders if they already exist.


    Batch (create a text file with this in it and save as something.bat):

    Code:
    @echo off
    for %%x in (*.wad *.bat) do start /w wad2nand.exe "%%x"
     
  14. nash79

    Member nash79 GBAtemp Regular

    Joined:
    Sep 27, 2008
    Messages:
    172
    Country:
    United States
    You bat kicks arse dude. Thanks
     
  15. vettacossx

    Member vettacossx Wii Theme Team Founder

    Joined:
    Sep 19, 2008
    Messages:
    1,329
    Location:
    Right Behind You! Uh Oh!
    Country:
    Ireland
    Just wanted to stop by to say THANKS SO MUCH!


    i used Drag and Drop method

    Drag wad2nande.exe into run window hit spacebar one time drag HIGLIGHT AND DRAG ALL THE WAD INTO THE TEXT BOX then hit enter and it spits out my folders... Can i do a similar approach for this?
     
  16. Robotech2079

    Newcomer Robotech2079 Member

    Joined:
    Aug 25, 2009
    Messages:
    11
    Country:
    United States
    Sorry if this has been mentioned before....I cannot figure out what I am doing wrong...I have a copy of my nand in the root of my SD created by Bootmi...I even used Simple FS (2.0) to create the import, meta, shared1, shared2, sys, tmp, ticket, and title folders...wad2nand was used to create a new set of ticket and title folders to overwrite the ones created by Simple FS....When I load up Triiforce on the HBC, (using the load nand from SD option) I get a return -1 error and it crashes ....What should I do to make it load up? Thanks for your assistance.
     
  17. Wiiwu

    Member Wiiwu GBAtemp Regular

    Joined:
    Jan 21, 2009
    Messages:
    209
    Location:
    Asia
    Country:
    Hong Kong
  18. Robotech2079

    Newcomer Robotech2079 Member

    Joined:
    Aug 25, 2009
    Messages:
    11
    Country:
    United States
    Can you post a tutorial or list steps on how to use this....With ShowMiiWad, I tried creating the title and ticket folders again but Triiforce STILL gives me a -1 error when it tries to read the 00010001 folder....NAND.bin is 528 MB for me and it is located (along with copies of the title and ticket folders) in the /sd directory....there are also import, meta, shared1, shared2, sys, ticket, title, and tmp folders in the /isfs directory...what could I possibly be doing wrong? [​IMG]
     
  19. Xras

    Member Xras GBAtemp Regular

    Joined:
    Nov 11, 2008
    Messages:
    139
    Country:
    Netherlands
    @ robotech: I believe you need to have the import, meta, shared1, shared2, sys, ticket, title folders in the ROOT of your SD......
     
  20. Robotech2079

    Newcomer Robotech2079 Member

    Joined:
    Aug 25, 2009
    Messages:
    11
    Country:
    United States
    I will try to place all of those folders in /sd....keeping my fingers crossed....
     

Share This Page