triiforce mrc

Discussion in 'Wii - Hacking' started by marc_max, Oct 9, 2009.

Oct 9, 2009

triiforce mrc by marc_max at 9:42 AM (297,720 Views / 0 Likes) 982 replies

  1. marc_max
    OP

    Member marc_max GBAtemp Advanced Fan

    Joined:
    Jun 19, 2008
    Messages:
    812
    Country:
    Spain
    [​IMG]
    Download v10b
    Download images from wiitdb.com
    Download 2010.01 official images pack
    Download sr_corsario's Neo-Geo injection image pack
    Download Tetsuo Shima's VC injection image pack
    Download twig123's complete NTSC-U VC set image pack

    Triiforce mrc is a modification of the original Triiforce, it adds a new GUI.

    Features:
    • New minimalist GUI with images
    • A button: play game
    • 1/2 buttons: sort games
    • HOME button: game options and triiforce configuration
    • Requires Waninkoko cIOS rev14 or higher (rev15, 18 y 19 not supported)
    How to load images?
    • You can use the autodownloader since v10 or...
    • Put them in sd:/triiforce_mrc/ or usb:/triiforce_mrc/
    • The menu will try to find the image file with all its four id characters (example: WTPP.png for Tetris Party PAL)
    • If it can't find it, then it will try to find the image file with its first three characters (example: WTP.png will show for any region version of Tetris Party)
     


  2. linuxares

    Member linuxares GBAtemp Maniac

    Joined:
    Aug 5, 2007
    Messages:
    1,370
    Country:
    Sweden
    Nice, can you provide screenshots? =)
     
  3. clivefrog

    Newcomer clivefrog Advanced Member

    Joined:
    Dec 22, 2006
    Messages:
    72
    Country:
    it crashes if you press + to skip page when you're on the last page, as least it does for me anyway
     
  4. marc_max
    OP

    Member marc_max GBAtemp Advanced Fan

    Joined:
    Jun 19, 2008
    Messages:
    812
    Country:
    Spain
    That's very strange. How many games do you have installed?
     
  5. dipswitch

    Newcomer dipswitch Member

    Joined:
    Jul 11, 2007
    Messages:
    44
    Country:
    United States
    Just tried to get v2...
    nvrmd, link is working now. I'll try this one out.

    I tried the previous version yesterday and all it would do is take me back to bootmii when I tried to launch your mod.
     
  6. kawrus

    Newcomer kawrus Newbie

    Joined:
    Sep 12, 2009
    Messages:
    1
    Country:
    United Kingdom
    Hi, great gui for triiforce, Would it be possable to make a version of this that works from emulated nand from SD rather than USB?
     
  7. dipswitch

    Newcomer dipswitch Member

    Joined:
    Jul 11, 2007
    Messages:
    44
    Country:
    United States
    I got this one to work fine with my SD nand but for whatever reason I get an error when trying nand on USB. Says it can't retrieve title list then when I press a button, it code dumps. I have not been able to get any triiforce version working with emulated nand on USB. Emulated nand on SD works fine though. Can anyone help getting emulated nand on USB working for me?
     
  8. zektor

    Member zektor GBAtemp Maniac

    Joined:
    Nov 29, 2005
    Messages:
    1,325
    Country:
    United States
    Does this have a fix for large SDHC cards? I have never been able to make Triiforce work with my 16GB SDHC card.
     
  9. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    I think marc's version only has USB support, it autoloads from USB (at least his v2 did), unlike the generic triiforce beta 6 that gives you the option of choosing real nand, usb nand and sd nand. So if you don't have a usb plugged in (with the appropriate files on it) it wont run after loading via homebrew.
     
  10. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    FYI, the "download v2" link is actually a link for his version 3
     
  11. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    u got this version to work off SD nand? Are you sure you're not referring to the standard triiforce beta 6 release? I thought this only loads USB nand.

    to get it working off usb nand try the following. run Simple FS Dumper via homebrew. The dumped folders are in the root of your SD card and are titled as follows: import, meta, Shared1, Shared2, sys, ticket, title, tmp. Copy all these to the root of your USB drive. It should work now. Some people are having trouble dumping a good nand rip. If this doesn't work for you (I think it should), I know dogegg has a nand dump on his mediafire repository page (google it, I don't have the link with me). Copy that to your SD, then run simple fs dumper again, then try it. Be sure to get the simple FS dumper that dumps to SD, there is a version that claims to dump to USBs but its buggy. Also, look into wad2nand, this is a good way of adding games to your virtual nand using only your computer.

    Hmm, just remembered you said you had this working off SD nand, if that's the case, before doing everything I said above, try copying these folders (import, meta, Shared1, Shared2, sys, ticket, title, tmp) from your SD card to your USB and try it. If it loads from your SD with your existing files, I see no reason why it wouldn't work off of a USB (provided your USB is compatible!!)
     
  12. marc_max
    OP

    Member marc_max GBAtemp Advanced Fan

    Joined:
    Jun 19, 2008
    Messages:
    812
    Country:
    Spain
    Yes, the download link is for version 3, sorry [​IMG]
    Version 3 includes SD emu too.
    It also has a copy-pasted 'set video mode' function from Waninkoko's USB Loader, this way I got Sin & Punishment PAL working correctly with RGB cable (previous versions ran the game in red screen).

    So the original Triiforce does not work for you? Then it must be a problem with your USB drive.
    It's FAT or FAT32?
     
  13. Royusmc

    Member Royusmc GBAtemp Regular

    Joined:
    May 22, 2009
    Messages:
    223
    Country:
    United States
    Is there a way I can change the config file on the sd card to auto load from usb. It is just is a step I would like to skip. Now can I say wow. We love it, so thanks for this awsome gui.
     
  14. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    there's a config file?????
     
  15. dipswitch

    Newcomer dipswitch Member

    Joined:
    Jul 11, 2007
    Messages:
    44
    Country:
    United States
    "u got this version to work off SD nand?"

    Yes, the latest version I suppose has SD nand support and it seemed to work just fine until just now. I think I screwed something up or discovered a bug. I loaded up triiforce mrc just to verify that SD nand was working after reading your post. I listed my titles just fine. Then I pressed 1 which took me to a copy/move screen and said press B to cancel. When I pressed B nothing happened. So I had a game highlighted and I think I pressed A which looked like it tried to load the game but was just a green screen. I reset my Wii and now when I run triiforce mrc and select SD nand, it says it can find titles then code dumps.

    So it was working a few minutes ago but no longer. [​IMG]

    "Hmm, just remembered you said you had this working off SD nand, if that's the case, before doing everything I said above, try copying these folders (import, meta, Shared1, Shared2, sys, ticket, title, tmp) from your SD card to your USB and try it."

    I have tried exactly as you stated. When I try to load from USB Nand it always just says cant find title list then code dumps. I will look into wad2nand as you suggested.

    "If it loads from your SD with your existing files, I see no reason why it wouldn't work off of a USB (provided your USB is compatible!!)"

    Thats what has me so puzzled. My drive works just fine with my emulators and running homebrew with HBC.

    "So the original Triiforce does not work for you? Then it must be a problem with your USB drive.
    It's FAT or FAT32?"

    It is partitioned as FAT and WBFS. Original triiforce does same thing code dumps after saying it cant find title list. The drive seems to work fine with everything else, mplayer-ce, HBC, fceugx, Snes9xGX, and vbagx.
     
  16. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    hey, can't look into this too much right now (@ work, lol). But just a thought, make sure you've added at least one title to your USB (using wad 2 nand or w/e), if its crashing when its pulling the title list, it may be crashing because there are no titles.

    Also, if you're using wad manager to install wads to your USB, its possible that has corrupted your "title" and "ticket" folders (I've had this happen to me, which is why I only use wad2nand to add games now). Try this... try deleting the contents of both folders (tickets and titles), back it up somewhere else just in case. Then try it again, it may load fine now, just without any titles, if it doesn't, try adding one title using wad2nand.
     
  17. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    The nand emu is 100% inside the cIOS! The device compatiblity depends 100% on the cIOS.
     
  18. dipswitch

    Newcomer dipswitch Member

    Joined:
    Jul 11, 2007
    Messages:
    44
    Country:
    United States
    I understand that the nand emu is inside the cIOS. My main USB drive seems to work fine with everything except for nand emulation. As a test I copied the contents of my nand dump from my main USB drive to a 1gb flash drive and now triiforce works fine with the flash drive. Wadmanager will even install to USB nand (it doesn't with my main USB drive). Anyways I suppose its a compatibility issue with my drive with nand emulation of cIOS although it works fine with my other loaders.

    At least I got it working with my 1gb flash drive. Now only if I could get my main drive working I'll be set. Thanks for all the advice and thanks WiiPower and marc_max for Triiforce and the mod. Any further advice on how to get my USB drive working will be greatly appreciated.

    edit: Yeah there's definitely something weird going on with my drive. I can install wads with wadmanager 1.4 just fine, however wadmanager 1.5 give error =-1.
     
  19. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    Are you installing to a nand emulation device? If so, forget about wad manager and google a PC program called wad2nand.

    If you're using wad manager 1.5, make sure you're choosing the right source. Theres USB, and there's USB 2.0. If your drive is plugged into the bottom USB slot, use USB 2.0, if its plugged into the top, use USB. If USB 2.0 isn't working for you, make sure you installed cIOS 202 for USB2 (I know this is for mplayer, I dont think its for wadmanager but it can't hurt)
     
  20. crinz

    Newcomer crinz Member

    Joined:
    Feb 23, 2008
    Messages:
    44
    Country:
    United Kingdom
    ignore me
     

Share This Page