Gaming The Problems With X7 and X8 in Mega Man X Legacy Collection 2 [Steam]

JazzPlaysStuff

Member
OP
Newcomer
Joined
Aug 17, 2020
Messages
19
Trophies
0
Age
17
XP
79
Country
Russia
I bought this collection for the sake of getting a better experience of X8 (as I was playing it on PCSX2 and it had slowdowns if the music was on. Weird, yeah), but... the game had slowdowns so bad that continuing the playthrough on a laggy emulator was a much better option. What's that?
Well, the audio was delaying during the cutscenes, as well as during the gameplay and the whole experience had bigger input delayes than an unofficial emulator of PS2. X5, on the other hand, was working fine, it was running much better than X8 and, as I had later checked, X7 (although it didn't run particularly well on PCSX2 either, even with no BGM fix which didn't reduce the lag completely).

I guess it's the problem with 3D titles, but then I asked my buddies on how did these titles run for them and they both were working on 60 FPS without any slowdowns.
My PC is not even that bad, it can run new games on Mid-to-Max graphical settings without lagging. Soooo... how do I fix this? I can't get a refund now, I was trying to fix it myself for far too long, so I might as well try to experiment with it until the end of time, lol.

My specs are:
AMD A10-7850K Radeon R7, 12 Compute Cores 4C+8G 3.70 GHz
I hope I wrote that down correctly ^^;
 

spotanjo3

Well-Known Member
Member
Joined
Nov 6, 2002
Messages
10,928
Trophies
1
XP
5,289
Country
United States
I bought this collection for the sake of getting a better experience of X8 (as I was playing it on PCSX2 and it had slowdowns if the music was on. Weird, yeah), but... the game had slowdowns so bad that continuing the playthrough on a laggy emulator was a much better option. What's that?
Well, the audio was delaying during the cutscenes, as well as during the gameplay and the whole experience had bigger input delayes than an unofficial emulator of PS2. X5, on the other hand, was working fine, it was running much better than X8 and, as I had later checked, X7 (although it didn't run particularly well on PCSX2 either, even with no BGM fix which didn't reduce the lag completely).

I guess it's the problem with 3D titles, but then I asked my buddies on how did these titles run for them and they both were working on 60 FPS without any slowdowns.
My PC is not even that bad, it can run new games on Mid-to-Max graphical settings without lagging. Soooo... how do I fix this? I can't get a refund now, I was trying to fix it myself for far too long, so I might as well try to experiment with it until the end of time, lol.

My specs are:
AMD A10-7850K Radeon R7, 12 Compute Cores 4C+8G 3.70 GHz
I hope I wrote that down correctly ^^;

The best answer to your question s the developer of PCSX2 at PCSX2 forum. They give you 100 percent correct answer better than we do.
 

JazzPlaysStuff

Member
OP
Newcomer
Joined
Aug 17, 2020
Messages
19
Trophies
0
Age
17
XP
79
Country
Russia
The best answer to your question s the developer of PCSX2 at PCSX2 forum. They give you 100 percent correct answer better than we do.

Well, I was actually asking how to solve the slowdown problem in Legacy Collection, not in PCSX2 (I just mentioned how the games were running better on that emulator than the official collection done by (or at least released by) CAPCOM)
 

Hero-Link

Hero of Derrr
Member
Joined
Nov 6, 2002
Messages
1,210
Trophies
0
Age
36
Location
Portugal
XP
1,089
Country
Portugal
I believe your graphics card is very old, emulators and games usually push the GPU more than the CPU.

R7 models arent new, can you confirm the entire model of the card?
 

JazzPlaysStuff

Member
OP
Newcomer
Joined
Aug 17, 2020
Messages
19
Trophies
0
Age
17
XP
79
Country
Russia
I believe your graphics card is very old, emulators and games usually push the GPU more than the CPU.

R7 models arent new, can you confirm the entire model of the card?

My dad bought it in 2017. 5 years is very old, yep?

I think it's both a graphics card and a processor or something. That's what I remember.

But why then these same games run better on a non-commercial emulator? Sure, I can play in total silence (which I did for X8, ho-ho), but why does it work that way? My friends' PCs are not even that new too. One of them had a laptop to my knowledge.
 

AlexMCS

Human
Member
Joined
Jul 3, 2018
Messages
338
Trophies
0
Age
36
Location
Fortaleza
XP
1,511
Country
Brazil
You're using integrated CPU graphics (APU, in AMD lingo).
It's only good for low demanding games and emulation of ancient systems. (PS1 or earlier).
You need an actual video board with it's own GPU to play games.
 

JazzPlaysStuff

Member
OP
Newcomer
Joined
Aug 17, 2020
Messages
19
Trophies
0
Age
17
XP
79
Country
Russia
You're using integrated CPU graphics (APU, in AMD lingo).
It's only good for low demanding games and emulation of ancient systems. (PS1 or earlier).
You need an actual video board with it's own GPU to play games.

OK, got it. Guess I'll wait until I'll be able to get something better from my parents, lol.
Thank you for the help!
 

JazzPlaysStuff

Member
OP
Newcomer
Joined
Aug 17, 2020
Messages
19
Trophies
0
Age
17
XP
79
Country
Russia
So... Collection fixed itself after a year since purchase and I don't know why. It now runs perfectly, and the only thing that lags are subtitles during CGI cutscenes in X8 which is not an issue.

I guess the solution to this problem is: Reinstall the whole thing and it will work. LoL.
But thanks everyone to helping me anyway!
 

Hero-Link

Hero of Derrr
Member
Joined
Nov 6, 2002
Messages
1,210
Trophies
0
Age
36
Location
Portugal
XP
1,089
Country
Portugal
That is most likely as they might have shifted most of the processing to the CPU (board) instead of the GPU (graphics card).

The way would be to get a proper card, you dont need a super high end graphics card, a mid range would suffice. But right now, there is a shortage and all Graphics cards are pretty expensive.
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: lol