The millionth "What Should I Buy?" thread

Discussion in 'NDS - Flashcarts and Accessories' started by Kirb94, Sep 30, 2009.

  1. Kirb94
    OP

    Kirb94 Member

    Newcomer
    25
    0
    Sep 9, 2009
    United States
    Okay, now I own an R4i and to be honest, it sucks, it doesn't play many games and so forth. It might just be me, but whatever. So, I'm planning to buy a new flashcard that will work with the DS Lite, and the DSi

    This is what I want in a flashcard (in order from most important to least):
    - Compatibility with games especially with new releases such as 358/2 days and M&L3 and any in the future. (VERY Important)
    - Firmware Updates
    - $20 or below


    I've been hearing about the M3i Zero and the Acekard 2i, but I thought I'd ask first before opening my wallet. Also, any links to trusted retailers would be nice.
     
  2. asdf

    asdf GBAtemp Advanced Fan

    Member
    827
    0
    May 20, 2009
    United States
    Torrance, CA
    http://www.dealextreme.com/details.dx/sku.18728

    /thread
     
  3. Josh192

    Josh192 Advanced Member

    Newcomer
    94
    1
    Feb 6, 2007
    Try to use YSMenu, that way you can play all the latest games on the r4 using ysmenu.
     
  4. Kirb94
    OP

    Kirb94 Member

    Newcomer
    25
    0
    Sep 9, 2009
    United States
    I've tried that but all I get is an Unsupported DLDI message.
     
  5. Langin

    Langin GBAtemp's kpop addict

    Member
    4,643
    766
    Jul 29, 2008
    Netherlands
    The Hague
    ak2I is very good! try that one! just as adsf said!